Jump to content
ClaraOS

*LØST* Kan ikke lave ændringer via ftp

Recommended Posts

Hej

Jeg er i tvivl om jeg har gjort noget grundlæggende forkert i min installation (som ellers virker ganske fint). Men jeg kan ikke ændre noget via min ftp-adgang, dvs. uploade ændringer til moduler, oversættelser eller noget som helst. Det er lige som om, der ikke er 'hul igennem' til hvad der sker i shoppen. Et eksempel er et modul, jeg netop har købt, som kræver lidt oversættelse i de mails, det sender til kunden (gavekort). Når jeg prøver at ændre via oversættelsesfunktionen i backend, kan jeg godt få adgang til at rette i mails, men så snart jeg gemmer, forsvinder alle filerne, og der kommer en meddelelse om, at filerne mangler. Det samme, sker, hvis jeg prøver at rette i de grundlæggende mails, både i mit theme og i core. 

Så prøvede jeg i stedet at slette modulet, rette i filerne i modulfilerne direkte på min computer som txt og html, komprimere og uploade modulmappen igen og installere igen. Intet resultat, den viser bare den præcis samme version af modulet, som om det aldrig var slettet. Så slettede jeg det igen, og prøvede at uploade det manuelt via min ftp-klient (Filezilla) Jeg kan sagtens uploade, og det ligger lige så fint i mappen, men det kan ikke findes via backenden. Samme hvis jeg prøver at rette eller uploade noget som helst andet via ftp - ingen ændringer at se online. Når jeg installerer et modul på sædvanlig vis (via backend) fremgår det ikke i filmapperne når jeg kigger via min ftp. Hvad er det der sker?

Jeg bruger version 1.6.1.2

Min shop er her: www.cleo-garn.dk

Håber nogen kan hjælpe.

Venlig hilsen

Clara

Edited by ClaraOS
Løst

Share this post


Link to post
Share on other sites

Det lyder mest af alt til, at du uploader til det forkerte sted, når du bruger FTP. Kan vi se nogle skærmdumps?

Det med at ændringer ikke gemmes, har igennem mange versioner ofte været et problem for specielt mails og PDF, hvor shoppen overskriver eller sletter alt. Det er meget muligt, at det er årsagen i din shop. Nu er det også en ældre version helt fra 2015, og du skriver ikke, om du førhen har kunne rette på de måder du forsøger nu? Har du overvejet en opgradering til 1.6.1.23? Der er trods alt rettet en del bugs siden din version.

Lige en tilføjelse, hvilken PHP version bruger din shop? Det kan du se under Avancerede parametre - Konfigurationsinformation.

Edited by Prestafan1234

Share this post


Link to post
Share on other sites

Tak for hurtigt svar. Så vidt jeg husker, har det aldrig virket at uploade noget via ftp, nej.

Jeg har prøvet at opgradere via 1-click modulet, men jeg kunne ikke få det til at virke, så derfor er jeg stadig i den gamle version. Jeg bruger php-version 5.6.38.

Jeg har prøvet at uploade modulet både i modulmappen under mit tema og i den anden modules-mappe, der ligger på roden (se screnshot).

 

 

Skærmbillede 2018-11-30 kl. 15.46.42.png

Share this post


Link to post
Share on other sites

Svært at svare på hvad der går galt - men umiddelbart lyder det mærkeligt at du ikke kan se ændringerne via. FTP... Det er ikke fordi at du har filtreret dine moduler, så du kun ser dem der allerede er installeret?

 

Som Prestafan1234 siger vil det nok være optimalt at få opgraderet til den nyeste version - nu ved jeg ikke hvor du er hostet, men flere hosts skifter snart til PHP 7.2 hvilket gør at ældre versioner af PrestaShop ikke længere vil virke.

Share this post


Link to post
Share on other sites

Ja, det er også temmelig mærkeligt.... Og nej, der er intet der kan ændres via ftp'en, hverken moduler eller andet, så det kan godt ligne at jeg bør få nogen til at se det efter i sømmene.

Tak for tippet ang. PHP, det må jeg hellere få kigget på.

Share this post


Link to post
Share on other sites

Hurra, jeg fandt ud af hvad der var galt med min ftp-adgang! Jeg fik opdateret min PHP for noget tid siden, og var ikke lige opmærksom på, at serverens IP-adresse ændrede sig i den forbindelse, så jeg har åbenbart fået forbindelse til en kopi af min shop, der lå på den gamle server. Nu hvor jeg forbinder til den rigtige IP-adresse, fungerer det sjovt nok noget bedre:D

Så blev jeg så meget klogere;D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More