Jump to content
Grafyx89

Erreur Atos : impossible d'exécuter le binaire

Recommended Posts

Bonjour à tous, 

Je sais que le sujet a été traité plusieurs fois mais j'ai du mal à comprend les issues de chacun 

Après avoir mis à jour le module Atos, j'ai l'erreur suivante : Erreur Atos : impossible d'exécuter le binaire

Je suis sous Prestashop 1.7.1 et la version du module est là 3.2.0. 

J'ai cru comprendre qu'il y avais un problème de version 32 ou 64 bits ? 
Si quelqu'un peut m'éclairer dessus, afin de pouvoir résoudre le problème .. ma boutique se retrouve sans méthode de paiement .. 

Merci à tous, 

Jonathan 

Share this post


Link to post
Share on other sites

Il y a de nombreuses version du binaire pour divers operating systems (5 versions 64bits sous linux). Tu dois nous donner la version exacte pour que l'on puisse te guider.

Après une mise à jour à peut-être simplement réécris les permissions de ces fichier ils doivent être en 755.

Ou encore la mise à jour à écrasé le PATH de ceux ci

Share this post


Link to post
Share on other sites

Merci de votre réponse, 

Vous souhaitez avoir la version exacte de quoi ? 

En pièce-jointe, toute les fichiers que j'ai dans le document BIN

les permissions semblent être en 777. 

Merci 

Capture d’écran 2018-11-20 à 15.10.28.png

Edited by Grafyx89 (see edit history)

Share this post


Link to post
Share on other sites

La version exacte de l'operating system et de savoir dans ta liste lequel de response et request pointe (si lien symbolique) ou est EXACTEMENT le meme que ceux avec des noms.

 

ls -als  avoir les tailles, les dates et si accès ssh, file * pour connaitre le contenu exact

Il y a aussi ce binaire spécifique aux CentOS https://github.com/TrogloGeek/prestashop-tggatos-module/issues/80#issuecomment-379014642

Les binaires n'ayant pas changé (le code) depuis 2006, le plus simple est probablement de reprendre ces 2 fichiers request et response depuis ta sauvegarde avant mise à jour du module

https://github.com/TrogloGeek/prestashop-tggatos-module/issues/80#issuecomment-379014642
https://github.com/TrogloGeek/prestashop-tggatos-module/issues/80#issuecomment-379014642
Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

Bonjour Doekia, 

Pardon pour le retard, j'ai essayé en vin de comprendre. 
Pour tout te dire, j'ai mis à jour le module ATOS, car avant cette mise à jour, il y avais un soucis (déjà rencontré mais pas résolu sur ce forum) d'une redirection 301 quand le client réalisais une commande, ni le commercant, ni le client était averti de la commande, et il était redirigé vers un historique de commande vide et panier toujours plein. 

Je me suis dis, pourquoi pas mettre le module à jour ? Et là, "Impossible d'executer le binaire"

Pour te répondre, j'ai eu réponse de OVH, le serveur un linux 64bits

 

J'ai essayé de mettre le fichier "Bin" de ma sauvegarde du module d'avant qui "fonctionnais" en tout cas qui n'envoyais pas l'erreur "impossible d'executer le binaire" mais rien n'y fait .. celà ne change pas. 

Merci pour ton aide, 

Share this post


Link to post
Share on other sites

Le problème de redirection est lié au passage en https (et probablement un règle pourrie de redirection forcé - ils aiment bien conseiller ces directives comme des ploucs chez OVH)

Donc tu as repris tes sauvegarde mais as-tu comme je te le précise avant vérifié les permissions  (755 pour le répertoire bin et les fichiers qu'il contient)

Après, si rien n'y fait, je ne peux que te proposer une intervention payante pour régler ce problème. PM moi.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More