Jump to content
yusttas

Free Opengraph module for Prestashop 1.7

Recommended Posts

Link to github repository https://github.com/yusttas/jk_opengraph (stars are appreciated)

Adds opengraph tags to index, category, new products, best-sales, cms and product pages. Each of these pages has settings. Other pages uses index opengraph tags. 

Recommended settings for category, cms and product pages are  "use meta tags".

Product page opengraph tags are off to avoid duplication if your theme already uses opengraph tags, like default theme. You can turn it on (Use metatags recommended).

You can report any errors,bugs and problems here or in my github repository

jk_opengraph.zip

 

Edited by yusttas
Updated module to version 1.2.9 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

I have a problem with the Facebook App ID: 2147483647. When I want to change it to put mine, he back to 2147483647. I have change the .tpl but same problem. Thanks.

Share this post


Link to post
Share on other sites
10 hours ago, hudeen said:

I have a problem with the Facebook App ID: 2147483647. When I want to change it to put mine, he back to 2147483647. I have change the .tpl but same problem. Thanks.

1. When you say "When I want to change it to put mine, he back to 2147483647". Do you mean it changes back in my module settings? If so, then im not sure whats the problem. 

2. If it changes in my module settings, but shows up wrong when viewing source file or in Open Graph Object Debugger, then try to clear your shop cache.

3. If you decided to change app id directly in opengraph.tpl, then it should definataly work. If not, try to clear cache.

4. You can see information about your opengraph tags here https://developers.facebook.com/tools/debug/og/object/. Enter your website url and press fetch new scrape information. Check if fb app id is correct here

  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, hudeen said:

I have found the problem. Thanks for the app !

You’re welcome. If this problem is something i need to fix, please tell me :)

Share this post


Link to post
Share on other sites

I have change the app ID directly in the .tpl. Because in my back office when I change the app ID, it does not effect.

I hope my english is not so bad :)

Share this post


Link to post
Share on other sites
3 hours ago, hudeen said:

I have change the app ID directly in the .tpl. Because in my back office when I change the app ID, it does not effect.

I hope my english is not so bad :)

I updated module. Now you should be able to change app id without problem, no need to edit .tpl file. Re download and install module, or update jk_opengraph.php file with this code https://github.com/yusttas/jk_opengraph/blob/master/jk_opengraph.php

  • Like 1

Share this post


Link to post
Share on other sites

Nice, it's ok for me ! Thank you :)

If you have nice tips for SEO for https://hudeen.com, my website, i'm listen to you ;)

Share this post


Link to post
Share on other sites

Hi, first of all sorry for my bad english. I'm trying to connect the facebook catalogue to my prestashop website and I need to install open graph meta tags. When I install your module facebook keeps telling me to put the meta tags. What I have to do?

My provisional website: http://s773038918.mialojamiento.es

 

 

On 11/19/2018 at 1:14 PM, yusttas said:

Link to github repository https://github.com/yusttas/jk_opengraph (stars are appreciated)

Adds opengraph tags to index, category, new products, best-sales, cms and product pages. Each of these pages has settings. Other pages uses index opengraph tags. 

Recommended settings for category, cms and product pages are  "use meta tags".

Product page opengraph tags are off to avoid duplication if your theme already uses opengraph tags, like default theme. You can turn it on (Use metatags recommended).

You can report any errors,bugs and problems here or in my github repository

jk_opengraph.zip

 

 

Share this post


Link to post
Share on other sites
10 hours ago, Pelleque said:

Hi, first of all sorry for my bad english. I'm trying to connect the facebook catalogue to my prestashop website and I need to install open graph meta tags. When I install your module facebook keeps telling me to put the meta tags. What I have to do?

My provisional website: http://s773038918.mialojamiento.es

 

 

 

Where is facebook keeps telling you that? I tested your websites homepage opengraph tags here https://developers.facebook.com/tools/debug/og/object/ .  Everything looks fine, no errors.

Share this post


Link to post
Share on other sites
5 minutes ago, Pelleque said:

I still haven't been able to fix it

First of all, I noticed that on your product page open graph tags are included three times. Default prestashop theme includes open graph tags on product pages, so on my module product page tags should be turned off to avoid duplication. And for facebook pixel are you using some kind of module too? If so, I think this module includes opengraph tags too.

What page do you testing here https://developers.facebook.com/tools/debug/og/object/  ? I dont get those errors like you do

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, yusttas said:

First of all, I noticed that on your product page open graph tags are included three times. Default prestashop theme includes open graph tags on product pages, so on my module product page tags should be turned off to avoid duplication. And for facebook pixel are you using some kind of module too? If so, I think this module includes opengraph tags too.

What page do you testing here https://developers.facebook.com/tools/debug/og/object/  ? I dont get those errors like you do

This is the page: https://business.facebook.com/ads/microdata/debug

And yes, I already have a facebook pixel module. Right now I just reinstalled prestashop for some errors, what do I have to do to make the metadata work well?

 

Edited by Pelleque (see edit history)

Share this post


Link to post
Share on other sites

Strange that few people are interrested in this free module... To be honnest i will not take the "chance" to try this one

Share this post


Link to post
Share on other sites
7 minutes ago, Gregh23 said:

Strange that few people are interrested in this free module... To be honnest i will not take the "chance" to try this one

huh? Whats wrong with this module?

Share this post


Link to post
Share on other sites

I don't know but i'm sure i want to test it.

I don't know how it could react with others modules and my theme. I prefere wait and see :)

Share this post


Link to post
Share on other sites
Just now, Gregh23 said:

I don't know but i'm sure i want to test it.

I don't know how it could react with others modules and my theme. I prefere wait and see :)

Code is open source here https://github.com/yusttas/jk_opengraph . 10 people gave a star, and no open issues at the moment. Altough its been a year after I tested this module, it uses only one hook "header" to put tags in your websites head section, so there should be no compatibility issues with your theme, unless it not have this hook.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More