Jump to content
jgk-dk

Ordre oprettelse mislykkedes

Recommended Posts

Prestashop ver 1.4.6.2 - systemet melder ovennævnte fejl og er kommet indenfor de sidste 2 dage.

Nogen ide om hvad dette er.

 

www.gpa-danmark.dk

 

Share this post


Link to post
Share on other sites

Ingen

 

Er jeg blevet hacket?

Det eneste jeg har gjort er at lave varianter på nogle varer ellers intet unormalt

Edited by jgk-dk

Share this post


Link to post
Share on other sites

Kan det være Quickpay der laver fejl loggen siger på prestashop:

 

Ordre-oprettelse mislykkedes

QuickPay: Payment notice: Already paid

QuickPay: Validate error. Order already accepted

Share this post


Link to post
Share on other sites

Prøv så at kikke på Quickpay. 

Se om kurv nummeret optræder flere gange. Den er nøglen over til Quickley. Du skal nok kikke under payments -  initials. 

Er det det nyeste quickpay modul? Prøv evt at nulstille modulet. 

Edited by pertho

Share this post


Link to post
Share on other sites
4 Ordre-oprettelse mislykkedes Cart 28825 2 2018-11-16 15:52:00 Slet
24 2 QuickPay: Validate error. Order already accepted Cart 28825 0 2018-11-16 15:52:00 Slet
25 2 QuickPay: Payment notice: Already paid Cart 28825 0 2018-11-16 16:44:12

Share this post


Link to post
Share on other sites

Nu er det jo en gammel version af Prestashop.

Kan din host have opgraderet php-versionen til en version din shop  ikke kan klare? Du kan se php versionen under kongigurationsparametre. Den ligger vist under avancerede psrsmetre. 

Edited by pertho

Share this post


Link to post
Share on other sites
5 minutes ago, pertho said:

Nu er det jo en gammel version af Prestashop.

Kan din host have opgraderet php-versionen til en version din shop  ikke kan klare? Du kan se php versionen under kongigurationsparametre. Den ligger vist under avancerede psrsmetre. 

PHP version: 5.6.38

Share this post


Link to post
Share on other sites
5 minutes ago, pertho said:

O. Så er du kommet forbi det nummer som drillede.

Prøv at se om du kan gennemføre en ordre nu. Det burde du kunne efter min mening.

Hjælper desværre ikke

Share this post


Link to post
Share on other sites
3 minutes ago, Prestawise said:

Sådan som jeg ser det, er det pga. dine cart_ids allerede er brugt... Hvis du har adgang til phpmyadmin prøv at tjekke den tabel der hedder cart_ids og se om numrene stemmer overens.

Hvilke numre taler du om her?

Share this post


Link to post
Share on other sites

Prøv at find tabellen ps_cart åben settings og se hvad auto increment parameter står til.

Sammenlign det med det sidst brugte cart_id i tabellen ps_orders.

Så sætter du auto increment (i ps_cart) til det sidste brugte cart_id fra ps_orders + 1

HUSK AT TAGE BACKUP AF DIN DATABASE INDEN.

 

Share this post


Link to post
Share on other sites
9 minutes ago, Prestawise said:

Prøv at find tabellen ps_cart åben settings og se hvad auto increment parameter står til.

Sammenlign det med det sidst brugte cart_id i tabellen ps_orders.

Så sætter du auto increment (i ps_cart) til det sidste brugte cart_id fra ps_orders + 1

HUSK AT TAGE BACKUP AF DIN DATABASE INDEN.

 

 

5.png

Share this post


Link to post
Share on other sites
2 minutes ago, pertho said:

Den hedder nok kun orders hos dig. PS_ (= prefix som man kan sætte foran hvis man vil)

Er fundet nu begge har samme numre 

Share this post


Link to post
Share on other sites
1 hour ago, Prestawise said:

Prøv at find tabellen ps_cart åben settings og se hvad auto increment parameter står til.

Sammenlign det med det sidst brugte cart_id i tabellen ps_orders.

Så sætter du auto increment (i ps_cart) til det sidste brugte cart_id fra ps_orders + 1

HUSK AT TAGE BACKUP AF DIN DATABASE INDEN.

 

 

8.png

Share this post


Link to post
Share on other sites

Jeg har fået at vide fra hosting at de har opdateret MariaDB til version 10.2.18 - kan det være skylden?

Jeg ville gerne opdatere shoppen og fik at vide at 1.6.1.18 skulle være stabil og være uden problemer.

 

Share this post


Link to post
Share on other sites
On 11/17/2018 at 5:23 PM, jgk-dk said:

Ok men jeg kan ikke lide temaet - jeg ville gerne have den nuværende lidt endnu, er bekymret for opdateringen

 

Forstår ikke din holdning her.

Du har problemer med dit nuværende system. Hvis en opgradering kan hjælpe på det då er det vel underordnet om du kan lide theme eller ej.

Det er efter min mening vælg mellem pest og kolera = et system der virker eller et system uden ordrer.

Share this post


Link to post
Share on other sites
On 11/18/2018 at 8:03 PM, pertho said:

Forstår ikke din holdning her.

Du har problemer med dit nuværende system. Hvis en opgradering kan hjælpe på det då er det vel underordnet om du kan lide theme eller ej.

Det er efter min mening vælg mellem pest og kolera = et system der virker eller et system uden ordrer.

Nu var det jo ikke en opdatering jeg var ude efter som måske går galt, hosten fandt en fejl og så kunne man lave ordre men i dag kan den ikke load betalingsvindue og i loggen siger den at ordre oprettelsen mislykkedes

Share this post


Link to post
Share on other sites
10 hours ago, jgk-dk said:

Nu var det jo ikke en opdatering jeg var ude efter som måske går galt, hosten fandt en fejl og så kunne man lave ordre men i dag kan den ikke load betalingsvindue og i loggen siger den at ordre oprettelsen mislykkedes

Så må der være ændret noget hos din host igen, hvis det virkede og så stoppede med at virke igen.

Noget helt andet er, at det er sikkerhedsmæssigt uforsvarligt at køre 1.4. Du risikerer i den grad at blive hacket, og du mister med stor sandsynlighed en masse salg, fordi din shop ikke er responsiv. 

Share this post


Link to post
Share on other sites
6 minutes ago, jgk-dk said:

Hej

Jeg har prøvet at opgradere til 1.6.1.18 fra den nuværende det ville den ikke - er det nødvendigt at gå over en 1.5 version først

 

Jan

 

Umiddelbart nej.

Hvad skete der? Nogen fejlmeddelelse eller andet?

PS: Hvorfor "kun" 1.6.1.18? Nyeste version er 1.6.1.23.

Share this post


Link to post
Share on other sites
1 minute ago, pertho said:

Umiddelbart nej.

Hvad skete der? Nogen fejlmeddelelse eller andet?

PS: Hvorfor "kun" 1.6.1.18? Nyeste version er 1.6.1.23.

Ok så prøver jeg med den, ja den fortalte at man ikke kunne opgradere fra denne version og begyndte så at lave en ny installation...

 

Share this post


Link to post
Share on other sites

Hvordan prøver du at opgradere.

Kan du skrive lidt om hvad du gjorde?

Nu er det nogle år siden jeg havde en ps1.4.x.x. Så jeg kan ilkke huske om det var en 1 click update i den version under moduler. Hvis det er der  så er det den du skal bruge.

Pas dog på, for den vil sikkert opgradere til 1.7.4.x. Det kan man dog godt omgå. 

Share this post


Link to post
Share on other sites
On 11/21/2018 at 1:28 PM, jgk-dk said:

Hej

Jeg har prøvet at opgradere til 1.6.1.18 fra den nuværende det ville den ikke - er det nødvendigt at gå over en 1.5 version først

 

Jan

 

Det bliver lige lidt ud fra hukommelsen, da det nok er 3 år siden, jeg sidst opgraderede en version 1.4. Dengang var det således, at man skulle sikre, at man bruger det "nye" filsystem til billeder, da man ikke kunne ændre det efterfølgende. Igen ud fra hukommelsen, så er rækkefølgen; opgradering til højeste version af 1.4, da der skete vigtige ændringer her. Dernæst til 1.5 og så 1.6.1.23 (der er rettet sikkerhedsmæssige fejl i seneste version af 1.6, så brug endelig den). Men jeg har i nyere tid også prøvet at opgradere fra en tidlig version af 1.6 til en 1.6.1xx og det kunne ikke lade sig gøre, fordi der var sket væsentlige ændringer.

Så længe du tager backup inden du går i gang og mellem hver opgradering, har du altid noget at rulle tilbage til. Glipper det også, så kan du overveje en migrering af data vha. et modul. Det kræver dog så, at du sætter en helt ren shop op med diverse indstillinger og så migrerer kunder, ordrer, varer, cms sider osv. Denne metode er at foretrække frem for en ren start, da du bibeholder alle URLs og dermed SEO-rangeringer.

Men det er under alle omstændigheder nok ikke en lille opgave, du skal i gang med - og det kan drille rigtig meget, hvis du har rettelser i dine kernefiler (som mange ofte har i 1.4).

Share this post


Link to post
Share on other sites
On 11/22/2018 at 8:05 PM, Prestafan1234 said:

Det bliver lige lidt ud fra hukommelsen, da det nok er 3 år siden, jeg sidst opgraderede en version 1.4. Dengang var det således, at man skulle sikre, at man bruger det "nye" filsystem til billeder, da man ikke kunne ændre det efterfølgende. Igen ud fra hukommelsen, så er rækkefølgen; opgradering til højeste version af 1.4, da der skete vigtige ændringer her. Dernæst til 1.5 og så 1.6.1.23 (der er rettet sikkerhedsmæssige fejl i seneste version af 1.6, så brug endelig den). Men jeg har i nyere tid også prøvet at opgradere fra en tidlig version af 1.6 til en 1.6.1xx og det kunne ikke lade sig gøre, fordi der var sket væsentlige ændringer.

Så længe du tager backup inden du går i gang og mellem hver opgradering, har du altid noget at rulle tilbage til. Glipper det også, så kan du overveje en migrering af data vha. et modul. Det kræver dog så, at du sætter en helt ren shop op med diverse indstillinger og så migrerer kunder, ordrer, varer, cms sider osv. Denne metode er at foretrække frem for en ren start, da du bibeholder alle URLs og dermed SEO-rangeringer.

Men det er under alle omstændigheder nok ikke en lille opgave, du skal i gang med - og det kan drille rigtig meget, hvis du har rettelser i dine kernefiler (som mange ofte har i 1.4).

Mange tak for tilbagemeldingen - hvilket modul er det du omtaler

Jan

Share this post


Link to post
Share on other sites

Det er en god idé, at opgradere til 1.6. PrestaShop 1.6 har opraderingsfiler til databasen helt tilbage til PrestaShop 0.9. Start med at opgradere databasen (i en testshop!) og arbejd så videre med theme etc.

 

/Kjeld

Share this post


Link to post
Share on other sites

Modulet er til at migrere, så du skal lave en helt ny installation på et andet domæne eller subdomæne og så sætte denne shop op, hvorefter du flytter data. Jeg har ikke brugt det for 1.4, men tror ikke det er nødvendigt at opdatere, blot husk at tjekke det med filsystemet. For det ved jeg ikke, om modulet kan håndtere.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More