Jump to content

Recommended Posts

Bonjour a tous !

Voila j'ai décidé de passer a Ubuntu 18.04.

J'essaye d'installer prestashop 1.7 cependant je rencontre des problèmes lors de l'installation...

J'ai réussi a installer LAMP (enfin je pense vu que j'arrive sur la page d'installation) .

Mais a la dernière étape, prestashop plante... Je vous met une image pour que vous puissiez m'aider. Merci beaucoup pour vos futures réponses. Sam ^_^

 

L'erreur : 1: HTTP 200 - parsererror -

5be8ef226cfdf_Capturedu2018-11-1204-10-04.thumb.png.1946e87234549ca0291786587476f2fb.png

Share this post


Link to post
Share on other sites

Version exacte de prestashop?

Version exacte de PHP

PHP 7.2 et + est très mal supporté. Max php 7.1

  • Thanks 1

Share this post


Link to post
Share on other sites

J'ai la version 1.7.2.1 car j'ai un problème similaire sur la version 1.7.4.4 de prestashop.

Pour ce qui est de PHP j'ai effectivement la version 7.2.10...

J'ai décompresse prestashop dans le dossier /var/www/html, peut être ai-je mal procédé ?

Aussi peut être serait-il plus judicieux d'utiliser MySQL que MariaDB ?

Merci pour votre réponse :)

Share this post


Link to post
Share on other sites

Parse error, c'est PHP je te dis de mettre php 7.1 max mais tu veux envisager que c'est la bdd - penses ce que tu veux

Share this post


Link to post
Share on other sites

Je remet pas du tout ce que tu dit en question, et je suis d'ailleurs débutant donc ce serait même idiot de le faire.

Pour la base de donnée c’était une question !

Je vais donc changer la version de PHP de ce pas ! Merci !

Edited by Samos (see edit history)

Share this post


Link to post
Share on other sites

Apres avoir changé la version de PHP, ajouté les extensions, le problème persiste.

Si vous avez une idée je suis preneur, merci.

Capture du 2018-11-12 15-30-43.png

Version 1.7.4.4 de prestashop

Version 7.1.24 de PHP

Edited by Samos
PHP version (see edit history)

Share this post


Link to post
Share on other sites
4 minutes ago, ksaan said:

Bonjour, peut-être tester avec mysql 5 ?

Je vais essayer, je vous tiens au courant :)

Share this post


Link to post
Share on other sites

Le problème est qu'avec MySQL lors de la commande :

sudo mysql_secure_installation

Cette erreur s'affiche :

Error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Ce fichier n'existe pourtant pas...

Edited by Samos
Précision (see edit history)

Share this post


Link to post
Share on other sites
Il y a 12 heures, Samos a dit :

J'ai réussi a installer LAMP (enfin je pense vu que j'arrive sur la page d'installation) .

Bonjour,

Deja là ca pose un problème car si t'es pas certain ca sert a rien d'aller plus loin ;) 

Linux c'est pas a la portée de tous et quand on est débutant, c'est forcément plus difficile.

Si t'as pas envie de te prendre la tête, reinstall ton serveur avec Plesk (la licence est payante par mois mais au moins c'est nettement plus simple :) )

Si tu es sur un VPS ou Cloud Ovh, les licences sont a prix réduit donc une raison de plus pour sauter dessus :P 

  • Thanks 1

Share this post


Link to post
Share on other sites
4 minutes ago, magicbel said:

Bonjour,

Deja là ca pose un problème car si t'es pas certain ca sert a rien d'aller plus loin ;) 

Linux c'est pas a la portée de tous et quand on est débutant, c'est forcément plus difficile.

Si t'as pas envie de te prendre la tête, reinstall ton serveur avec Plesk (la licence est payante par mois mais au moins c'est nettement plus simple :) )

Si tu es sur un VPS ou Cloud Ovh, les licences sont a prix réduit donc une raison de plus pour sauter dessus :P 

J'ai envie d'apprendre, ça ne me dérange pas de galérer. :P 

J'ai quelques notion avec linux je connais les commandes de bases mais je n'ai jamais utilisé de bdd ou de serveur avec et j'ai envie de passer le cap. Il y a un début a tout comme on dit :)

En ce qui me concerne j'aimerais pour le moment travailler en local pour apprendre.

J'ai compris qu'il fallait être bien plus rigoureux que sur Windows et c'est pour cela que j'ai besoin d'aide... Merci en tout cas pour vos réponses :) 

Share this post


Link to post
Share on other sites

Les dernière version de MySQL sont réglées par défaut pour utiliser le socket en localhost (donc le pass est ignoré)

Si tu as changé ce mode opératoire, il te faut impérativement changer le user pour qu'il n'utilise pas le plugins

update mysql.user set plugin='' where user='xxx';
flush privileges;

 

Mais, parse error ne me semble pouvoir provenir que de php, donc tente une autre langue car je pencherai pour un bug des message traduit qui fasse planter le code

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites
1 hour ago, doekia said:

Les dernière version de MySQL sont réglées par défaut pour utiliser le socket en localhost (donc le pass est ignoré)

Si tu as changé ce mode opératoire, il te faut impérativement changer le user pour qu'il n'utilise pas le plugins

update mysql.user set plugin='' where user='xxx';
flush privileges;

 

Mais, parse error ne me semble pouvoir provenir que de php, donc tente une autre langue car je pencherai pour un bug des message traduit qui fasse planter le code

Je vais essayer, encore un grand merci.

A l'installation de MySQL m'affiche ceci :

5be9bd11adea8_Capturedu2018-11-1218-45-18.png.996c15186e0e91d08c1630d2d10e4223.png

Je ne comprend pas trop ce message, peut être a t-il rien a voir avec le sujet... Je le met au cas ou...

Edited by Samos
orthographe (see edit history)

Share this post


Link to post
Share on other sites

Fait moi peur, dis moi que tu utilise l'utilisateur root comme user pour ton prestashop !

Laisse root tranquille, c'est la base de linux, cet utilisateur n'est pas a exploiter!

Créée un autre utilisateur pour ta bdd

  • Haha 1

Share this post


Link to post
Share on other sites
10 minutes ago, doekia said:

Fait moi peur, dis moi que tu utilise l'utilisateur root comme user pour ton prestashop !

Laisse root tranquille, c'est la base de linux, cet utilisateur n'est pas a exploiter!

Créée un autre utilisateur pour ta bdd

Non l'utilisateur est 'sam' et j'ai un mdp. J'ai configuré tout ça dans le terminal mysql ou mariadb.

Par contre j'utilise la commande sudo, mais ça n'a rien a voir je pense :P 

 

Je compte repartir de zero en réinstallant ma distrib si quelqu'un a un tuto complet pour l'installation de prestashop... Oui c'est radical :P 

Edited by Samos
precision (see edit history)

Share this post


Link to post
Share on other sites

et tu n'as pas désactivé le champ plugin du user root? Car là ça ressemble beaucoup au message lorsque justement, le root ne peut plus se connecter automatiquement

Share this post


Link to post
Share on other sites
4 hours ago, doekia said:

et tu n'as pas désactivé le champ plugin du user root? Car là ça ressemble beaucoup au message lorsque justement, le root ne peut plus se connecter automatiquement

Je ne pense pas. :(

Dans quel fichier ?

Vous pensez que l'erreur pourrait venir d'ici ?

Share this post


Link to post
Share on other sites
4 hours ago, magicbel said:

https://hostadvice.com/how-to/how-to-install-prestashop-on-ubuntu-18-04-server/

Pas testé par contre mais bon, ca devrait tourner :) 

Par contre, bien verifier que le user est sudo proof avant (comme indiqué dans le tuto)

C'est le tuto que j'avais suivi, par contre qu'est ce qu'un sudo proof ? Comment savoir si mon user l'est ? J'utilise la commande sudo pour mes commandes...

L'autre prérequis est : "A VPS plan running Ubuntu 18.04 server ". Je me demande de quoi il s'agit...

J'ai réinstallé ma distrib et je compte reussir cette fois si :P

Merci pour vos conseils !

Share this post


Link to post
Share on other sites

Voila je reviens vers vous pour vous annoncer que j'ai réussi l'installation de prestashop 😀

Il s'agissait effectivement de PHP... La version 7.1 et 7.2 ne fonctionnaient pas chez moi j'ai installé la version 7.0 et tout fonctionne a merveille !

Merci beaucoup pour toute l'aide que vous m'avez apporté et vos précieux conseils ! 😁

Edited by Samos (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
On 12/11/2018 at 06:11, Samos said:

Bonjour a tous !

Voila j'ai décidé de passer a Ubuntu 18.04.

J'essaye d'installer prestashop 1.7 cependant je rencontre des problèmes lors de l'installation.

J'ai réussi a installer LAMP (enfin je pense vu que j'arrive sur la page d'installation) .

Mais a la dernière étape, prestashop plante... Je vous met une image pour que vous puissiez m'aider. Merci beaucoup pour vos futures réponses. Sam^_^

 

L'erreur : 1: HTTP 200 - parsererror -

5be8ef226cfdf_Capturedu2018-11-1204-10-04.thumb.png.1946e87234549ca0291786587476f2fb.png

Bonjour ! Pourquoi ne pas installer le Magasin via le panneau de configuration en 1 clic? Utilisez le panneau de FastComet.

Share this post


Link to post
Share on other sites

Quelle version EXACTE de prestashop installes-tu ?

Quelle est la version de PHP de ton système ? => racine de ton web (fichier phpinfo.php: <?php phpinfo(); )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More