Jump to content

Recommended Posts

Hi @ll,

wir haben von hier https://www.prestashop.com/forums/topic/734168-free-module-google-translate/ den google Translate installiert. Wir wollten das Modul wieder löschen, was aber nicht ging, also haben wir es per FTP gelöscht und und in Datenbank unter "ps_module_preference" den Eintrag "(4, 1, 'medgtranslate', NULL, 1);" gelöscht. Wir haben die ganze Datenbank durchsucht, weitere Einträge scheinen von diesen Modul nicht mehr vorhanden zu sein.

Nun aber werden im BO unter Positionen bei "footerdisplay" 10 Module angezeigt, obwohl nur 9 vorhanden sind.:huh: Installiert man den Translater neu, ist dieser unter ---> Positionen ---> Modul hinzufügen gar nicht mehr vorhanden :blink: und somit eine Änderung der Position nicht mehr möglich. Der Translater wird bei einer Neuinstallation im footer hinzugefügt und funktioniert auch, nur eben erscheint dieser nicht mehr bei den hooks im footerdisplay wo er eigentlich sein müsste.

Was haben wir falsch gemacht? Sind eventuell noch irgendwo Reste von diesem Modul vorhanden? 

Siehe Bild! Vor dem manuellen löschen konnte man das Modul noch hinzufügen. 

footerdisplay.png

Share this post


Link to post
Share on other sites

Erst einmal verstehe ich nicht so recht, wo jetzt eigentlich das Problem liegt. Dann, verstehe ich das richtig, wenn du den Modulordner löschst, ist das Modul da, wenn du es wieder installiert hast, ist es weg?

Auf jeden Fall lösche immer alle Caches.

Share this post


Link to post
Share on other sites
vor 25 Minuten schrieb rictools:

Erst einmal verstehe ich nicht so recht, wo jetzt eigentlich das Problem liegt. Dann, verstehe ich das richtig, wenn du den Modulordner löschst, ist das Modul da, wenn du es wieder installiert hast, ist es weg?

Auf jeden Fall lösche immer alle Caches.

 

Cache wird immer gelöscht. ;) Kompilieren brachte leider auch nicht den gewünschten Erfolg.

Das Problem ist, dass das Modul nach einer Neuinstallation nicht mehr wie oben im Bild zu sehen ist, bei "Modul hinzufügen" auftaucht so als wäre es nicht vorhanden. Somit kannst du auch nicht mehr die Position etc. ändern. ;)

Share this post


Link to post
Share on other sites

Hast du noch einmal die Deinstallation versucht? Da scheint sich ja irgendetwas mit einem alten Eintrag zu beißen. Ansonsten würde ich in den Override-Ordner schauen und ggf. in die tpl-Datei, in der das Modul angezeigt wird. Hast du mal Live Edit (auf der Seite Module -> Positionen) versucht?

Share this post


Link to post
Share on other sites
vor 5 Minuten schrieb rictools:

Hast du noch einmal die Deinstallation versucht? Da scheint sich ja irgendetwas mit einem alten Eintrag zu beißen. Ansonsten würde ich in den Override-Ordner schauen und ggf. in die tpl-Datei, in der das Modul angezeigt wird. Hast du mal Live Edit (auf der Seite Module -> Positionen) versucht?

 

Davon gehe ich wie eingangs geschrieben auch aus, irgendwo dürften da noch Reste von der letzten Installation vorhanden sein. Live Edit habe ich schon versucht, da wird leider der footer nicht angezeigt. 

Deinstallieren funktioniert einwandfrei, auch das löschen. Es funktioniert nach dem installieren auch wie es soll, nur eben dass es bei Modul hinzufügen nicht mehr auftaucht. Die sucherei hat mich schon stunden gekostet. In der DB ist von diesem Modul nichts mehr, müsste also an irgendeiner Datei liegen.

Share this post


Link to post
Share on other sites
vor 13 Stunden schrieb rictools:

Override-Ordner hast du gecheckt (evtl. nach Datum)?

 

Ja, da ist leider auch nichts. Hab sogar über alle Dateien ein Suchprogramm drüber laufen lassen, leider ohne Ergebnis. Sehr seltsam...

Das Modul brauche ich eh nicht mehr da ich ein kostenpflichtiges ins Auge gefasst habe das mir besser gefällt. Ich wollte nur vermeiden dass von diesem Modul eventuell Reste vorhanden bleiben, die irgendwann mal Probleme im Shop verursachen. Ich bin hartnäckig, irgendwann finde ich den Fehler. :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More