Jump to content

Recommended Posts

Bonjour,

Je viens chercher de l'aide ici, car c'est la cata depuis trois jours pour moi... Impossible de me connecter à mon espace admin de prestashop ! J'ai ce message qui s'affiche :

"The page you are looking for is temporarily unavailable.
Please try again later. 
3858fb5ac9289b7d979cd642cd1f5195 6e1b0f10e4a9f2df146067fc2d660f31 c4e308313192e3f20ef266c03efca50f"

Que puis-je faire pour que ce bug s'arrête ? C'est une boutique en ligne, du coup c'est assez problématique de ne pas pouvoir la gérer...

Je précise que bizarrement, on peut accéder à mon site en tant que visiteur, passer une commande... Tout fonctionne ! Sauf l'admin ! 0_0

Merci par avance pour vos réponses :)

Edited by laetitias81
  • Like 1

Share this post


Link to post
Share on other sites

Sujet déjà répondu plus d'une vintaine de fois depuis 10 jours...

La réponse dépend de votre version Prestashop

Share this post


Link to post
Share on other sites

Bonjour,

j'ai le même problème avec la version 1.7.4.2 (et aussi avec la 1.7.4.3) et MAMP version 4.5 (et également avec la version 5).

je n'avais pas de souci avec la 1.7.1 et MAMP 3

J'ai écumé les forums sans trouver la solution, bien que le non-accès au BO soit un problème récurrent. J'ai même passé en revu les .htacces, à un moment il était question d'un espace en trop.

MAMP 4.5 utilise la version PHP 7.2. j'ai switché en 7.1.12 (seule alternative proposée...) mais sans résultat.

Le front fonctionne, ainsi que Presta 1.6.1.22....

En mode débug, j'ai le message suivant (voir saisie écran).

Je ne suis pas développeur, donc les subtilités PHP et autres m'échappent, même si j'ai quelques notions (suis plus à l'aise avec le html et le css)

Bref, si quelqu'un voit où chercher...

Capture d’écran 2018-10-14 à 16.18.01.png

Share this post


Link to post
Share on other sites
On ‎13‎/‎10‎/‎2018 at 11:43 AM, laetitias81 said:

Bonjour,

Je viens chercher de l'aide ici, car c'est la cata depuis trois jours pour moi... Impossible de me connecter à mon espace admin de prestashop ! J'ai ce message qui s'affiche :

"The page you are looking for is temporarily unavailable.
Please try again later. 
3858fb5ac9289b7d979cd642cd1f5195 6e1b0f10e4a9f2df146067fc2d660f31 c4e308313192e3f20ef266c03efca50f"

Que puis-je faire pour que ce bug s'arrête ? C'est une boutique en ligne, du coup c'est assez problématique de ne pas pouvoir la gérer...

Je précise que bizarrement, on peut accéder à mon site en tant que visiteur, passer une commande... Tout fonctionne ! Sauf l'admin ! 0_0

Merci par avance pour vos réponses :)

 

Share this post


Link to post
Share on other sites

bonjour

avez vous trouvé votre réponse car j'ai le meme soucis depuis plusieurs jours, je ne suis pas habitué à ce forum et je n'ai pas trouve la reponse !

merci d'avance

celine

Share this post


Link to post
Share on other sites

2 solutions suivant votre version Prestashop.

En premier, supprimez le module inutile dans le répertoire du ftp: /modules/gamification

Ensuite, si vous êtes en 1.6 ou 1.7, ouvrez le fichier /classes/Tools.php et modifiez  (vers la ligne 3352)

protected static $is_addons_up = true;

Par:

protected static $is_addons_up = false;

Une fois cela fait, si vous aviez des alertes en rouge concernant les fichiers xml, supprimez tous les fichiers xxxxxx.xml du répertoire /config/xml/

 

Pour les 1.7 UNIQUEMENT, vous devez aussi remplacer cette même ligne dans le fichier src/Adapter/Addons/AddonsDataProvider.php ligne 44

Share this post


Link to post
Share on other sites

Liloocreations : Oui c'est bon pour moi, depuis ce matin !

J'ai fais ce qui est dit dans un autre post (après avoir fouillé partout...) : je me suis rendue sur ma bdd, et j'ai supprimé les documents "onboard" et "gamification" dans /modules : ça a marché :) 

 

J'ai quand même enregistrer ces fichiers en dehors de la bdd, au cas où il faudrait les remettre un jour... Mais bon en attendant, ça remarche,  OUF !

Share this post


Link to post
Share on other sites

Bonjour,

Merci pour les infos Eolia, je vais les mettre de côté pour l'instant, tout comme la version 1.7.xx

Ce matin sans que je fasse quoi que ce soit, le BO s'est connecté ?!...

Mes boutiques étant en 1.6.1 et fonctionnant sans souci (je touche du bois) toute évolution est reportée... à une date ultérieure ! :)

Dici là on sera peut-être en 2.0

Share this post


Link to post
Share on other sites

en tout cas un grand merci, car franchement vous ne seriez pas la pour aider , je ne sais vraiment pas comment j'aurais fait 

c'est top d'aider , merci

Share this post


Link to post
Share on other sites

Oui FTP pardon... Je ne suis pas douée là dedans !

Par contre... Nouveau soucis pour moi : j'avais donc fait ce que j'ai dis plus haut (enlever gammification et onboard) et voilà qu'après deux jours où tout allez bien... Ce matin ça ne marche à nouveau plus ! Même erreur ! Sauf que dans le FTP, je ne vois pas ces fichiers (logique je les ai déjà supprimés).

D'où peut venir ce nouveau bug ? :( 

Share this post


Link to post
Share on other sites

Vous avez bien modifié la classe Tools.php également ?

Share this post


Link to post
Share on other sites

Ah non, je vais relire alors les posts que j'avais vu, j'ai du passer à côté de cette info :/ 

Bizarrement, ça remarche à nouveau sans que je ne touche à quoique ce soit... Merci beaucoup en tous cas, je vais regarder ce que je dois faire sur tools.php :) Merci beaucoup ! 

Share this post


Link to post
Share on other sites
Le 15/10/2018 à 9:05 AM, Eolia a dit :

Ensuite, si vous êtes en 1.6 ou 1.7, ouvrez le fichier /classes/Tools.php et modifiez  (vers la ligne 3352)


protected static $is_addons_up = true;

Par:


protected static $is_addons_up = false;

Une fois cela fait, si vous aviez des alertes en rouge concernant les fichiers xml, supprimez tous les fichiers xxxxxx.xml du répertoire /config/xml/

 

Pour les 1.7 UNIQUEMENT, vous devez aussi remplacer cette même ligne dans le fichier src/Adapter/Addons/AddonsDataProvider.php ligne 44

 

Et le fait que ça marche/marche plus/remarche vient des serveurs d'addons. Le patch de Tools.php supprime le problème.

Share this post


Link to post
Share on other sites

Bonjour, 

Merci EOLIA, mais je voulais juste préciser que j'avais cherché avant de poster le problème mais je n'avais pas trouvé une réponse auparavant.

J'ai fait les manipulations et cela à l'air de fonctionner.

Share this post


Link to post
Share on other sites

Bonsoir, comme beaucoup en ce moment j'ai rencontré également ces problèmes de connection depuis plusieurs jours, j'ai effectué le patch requis dans les 2 fichiers (presta 1.7.3.0) comme indiqué par Eolia que je remercie au passage pour son engagement et son aide, malheureusement tous les problèmes ne semble pas être reglés, je suis obligé de vider le cache de mon navigateur (chrome) toutes les 10 min pour pouvoir me reconnecter sinon je reste bloqué sur la page de connection du BO :(

merci d'avance pour votre avis

 

Edited by brikobike

Share this post


Link to post
Share on other sites

Bonjour à tous.

J'ai également un problème de connexion.

Voilà j'ai acheté un nom de domaine avec phpnet. j'ai relié prestashop. J'ai donc reçu un mail de phpnet avec 2 URL , l'une pour ma boutique l’autre pour mon tableau de bord prestashop.

Tout fonctionnait car je me suis connecté et j'ai déjà travaillé sur ma boutique. Or j'ai du faire une mauvaise manip... car le lendemain on voulant continuer mon travail sur mon tableau de bord IMPOSSIBLE de me connecter.... J'ai beau essayer plusieurs emails et faire "mot de passe oublié" , prestashop dit "compte inexistant".

Je ne sais plus quoi faire ! Phpnet disent qu'ils ne peuvent pas m'aider. Et Prestashop personne ne répond..Capture.JPG.ab2c53785236012b55b61931cae664d5.JPG

Share this post


Link to post
Share on other sites

Allez dans la base de données, table ps_employee et vérifiez que c'est bien le bon mail.

Share this post


Link to post
Share on other sites

Il est impossible de supprimer le profil sur lequel on est en BO donc si vous avez plusieurs comptes employés testez avec un autre.

Autrement envoyez-moi un accès ftp par Message Privé et je vous recrée un compte Admin en 2 min^^

Share this post


Link to post
Share on other sites

Je ne vais certainement pas expliquer en public comment créer un compte admin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More