Jump to content
linda_petty@shelter.

1-Click upgrade addon fails with "Class 'ZipArchive' not found"

Recommended Posts

 

I am using Prestashop's "1-click upgrade" addon to upgrade from Prestashop 1.6.1.17 to 1.7.4.3.

it fails with "Class 'ZipArchive' not found"

I have installed Zip with 

 

sudo apt-get install php7.0-zip

but I get the same ZipArchive error

 

here is the error:-

[INTERNAL] /var/www/modules/autoupgrade/classes/ZipAction.php line 126 - Error: Class 'ZipArchive' not found #0 /var/www/modules/autoupgrade/classes/ZipAction.php(70): PrestaShop\Module\AutoUpgrade\ZipAction->compressWithZipArchive(Array, '/var/www/admin5...') #1 /var/www/modules/autoupgrade/classes/TaskRunner/Upgrade/BackupFiles.php(79): PrestaShop\Module\AutoUpgrade\ZipAction->compress(Array, '/var/www/admin5...') #2 /var/www/admin5431/autoupgrade/ajax-upgradetab.php(52): PrestaShop\Module\AutoUpgrade\TaskRunner\Upgrade\BackupFiles->run() #3 {main}

at line 126 in ZipAction.php the statement is 

 $zip = $this->openWithZipArchive($toFile, \ZipArchive::CREATE);

Any ideas on how to resolve this would be appreciated.


 

 

 

Edited by linda_petty@shelter. (see edit history)

Share this post


Link to post
Share on other sites

I have same problem, but my web is online. I guess restart my computer is not a solution then?

Share this post


Link to post
Share on other sites
8 hours ago, Zeryk said:

I have same problem, but my web is online. I guess restart my computer is not a solution then?

I am afraid you miss the point: the php module ZIP is a required for Prestashop. In the case of llnda that was not installed and after she installed it she needed a restart to make the installation effective.

But the error message is that the Prestashop ZipArchive class is not found. Of course that can be caused by the absence of the PHP module. But the problem can also be with your Prestashop installation. You might start with looking whether the relevant file ('/tools/pclzip/pclzip.lib.php') is there.

Share this post


Link to post
Share on other sites

problem solved with activation of ZIP library . had to request the provider to do so. thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More