Jump to content
Sign in to follow this  
Heathcliff

Bug paypal très bizarre !

Recommended Posts

Je précise que tous les paramètres paypal sont bons ;)
Si je fais une commande "normale", pas de pb, le bon montant est affiché dans paypal, avec les frais de livraisons etc etc...
Par contre, si j'utilise un bon de réduction, alors bizarrement paypal m'applique des frais de ports en plus : ceux qui sont marqués dans le tableau "calcul des frais de livraison --> plages des couts et des prix" (alors que "Cliquez ici pour autoriser le remplacement des paramètres des Préférences répertoriés ci-dessus par les valeurs de livraison correspondant aux transactions" est bien coché...)
Biens-sur, si je mets 0 partout dans le tableau, j'ai bien le bon total, mais les frais de port apparaissent à 0 (bon on s'en fout un peu c'est vrai ;), alors que sans bon de réduction, les frais de port apparaissent.

c'est très étrange ! je précise que j'ai remplacé la ligne :

$totalAmount = floatval($order_total_products) + floatval($shipping_fees);

par
$totalAmount = floatval($order_total_products);


dans PDF.php afin d'avoir la réduction non pas sur le total mais sur les articles (manip proposée sur le forum et qui marche bien).
cela peut'il venir de la ?
j'ai du mal a saisir ce qui cloche...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More