Jump to content

Recommended Posts

Hello,

I feel ridiculous, but I'm getting 500 error on two different hosting companies while trying to install Prestashop 1.7.4.3 and 1.7.4.2

The error log is: [Mon Oct 08 13:11:48 2018] [warn-ioncube] mmap cache can't open /home/..../var/cache/prod/appParameters.php - Permission denied

I tried the suggestions regarding this type of error:
I made 777 permissions on /var and /cache directory including subdirectories and files.
I tried to use United States settings during the installation.

But still without success. 

 

2018-10-08 13_24_30-PrestaShop Installation Assistant.png

Share this post


Link to post
Share on other sites

Hi,

Sorry, I have no solution and I'm getting 500 errors on two different hosting companies while trying to install Prestashop 1.7.4.3 and 1.7.4.2 , too.
In 1 case, the install process stops with an error. With the other hosting, the front works well but the I can't make the admin work. Just error 500.
Now I know about the renaming of the admin dir. But that part doesnt work very well.
Tried PHP 5.4, 7.0 and 7.1. It makes no difference. Enough memory. Enough script exc time.
Uploaded the zip file and index. Uploaded the complete unzipped Prestashop, too.
Changed languages on different occasions. But after about 12 times trying to install it I am out of ideas.
Changed permissions to 755, too.

I do get it fully installed however, admin dir renamed automatically in the end, on my local Xampp.

Share this post


Link to post
Share on other sites

I know the answer to this.. but your gonna hate it. Cpanel has a bug with PHP-FPM it is not able to  allow Prestashop  the php requirements it needs.

I have been thru 5 hosts  all cpanel and whm. I did not even get this installed until I bought a Plesk server.  The 500 error is solvable but the 403 afterwards is not.

This will not always be the issue if you can wait it out do so. CPanel is aware  of the PHP-FPM bug and is aiming to fix BUT they are still resistant against allowing  one of the switchs needed for prestashop to work to be on the PHP-FPM control panel.

Those two variables marked in red are impossible right now to set correctly for Prestashop on a cpanel whm setup due to their bug.

http://prntscr.com/l5joad

 

The really kick a__ thing about the bug is if your on shared hosting and you set a custom php.ini to match prestashop rules  it will screw up everyone on your shared hostings php! FUN! IT Hosting support people love when ya do that. Call them and tell them what you did they will love to fix the other 3 containers by breaking yours!

Edited by jstillings1 (see edit history)

Share this post


Link to post
Share on other sites

Hi,

Thank you for your help and advise.

Since I cant access the back end, I set debugging to True in '_PS_MODE_DEV_',

This does not give any extra information. It just says:
---
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, null@myfirsthosting.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

---

So, it recognises the page. Otherwise it would have thrown a 404.

The access log only says HTTP 500. But no further information on why or what.

The Hosting admin only tells me there has been a PHP WARN. A script took longer then 5 minutes to execute.

max_execution_time and  max_input_time are 120 secs. Cant go any longer with the Hosting I am on.

Assigned memory is 256 M.

allow_url_fopen = ON

 

Yes, this is on shared hosting...

 

Tried installing 1.6 first and updating to 1.7. But that doesn't work because of the server error  jqXHR using 1-click upgrade.

 

It probably is some php or mysql error.

 

 

Share this post


Link to post
Share on other sites

I get the same error, and wheh I check the logs, here is what is given:

PHP message: PHP Warning: Invalid argument supplied for foreach() in ../classes/shop/Shop.php on line 347" while reading response header from upstream,
If it's a bug without no solution for the moment, which version of prestashop does support php-fpm correctly ?

 

Share this post


Link to post
Share on other sites

Hi,

In my case, the problem was solved.

The admin folder has it's own htaccess file.

In this file, the Multiviews Options were blocked out:

<IfModule mod_negotiation.c>
    #Options -MultiViews
</IfModule>

 

This did the trick. I can access the admin pages now.

Thanks to the the people of the shared hosting. They helped me out here.

Share this post


Link to post
Share on other sites
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More