Jump to content
Lausli

(1/1) RuntimeException Failed to start the session: already started by PHP.

Recommended Posts

Hallo, ich habe jetzt mal "spaßeshalber" Prestashop 1.7.x per Autoupgrade installiert. Nach dem Login ins Dash kommt eine mehr oder weniger aussagekräftige Fehlermeldung, dass etwas schief gelaufen ist.

Also habe ich mir den Debug-Modus eingeschalten und muss sagen: Sagt mir jetzt nicht viel mehr.

Whoops, looks like something went wrong.
(1/1) RuntimeException
Failed to start the session: already started by PHP.

in NativeSessionStorage.php line 137
at NativeSessionStorage->start()
in Session.php line 59
at Session->start()
in SessionTokenStorage.php line 78
at SessionTokenStorage->hasToken('https-ANONYMOUS_USER')
in CsrfTokenManager.php line 72
at CsrfTokenManager->getToken('ANONYMOUS_USER')
in Router.php line 49
at Router->generate('admin_product_catalog', array())
in Link.php line 727
at LinkCore->getAdminLink('AdminProducts')
in AdminController.php line 1999
at AdminControllerCore->getTabs('141', 2)
in AdminController.php line 2000
at AdminControllerCore->getTabs('134', 1)
in AdminController.php line 2000
at AdminControllerCore->getTabs()
in AdminController.php line 1868
at AdminControllerCore->initHeader()
in Controller.php line 251
at ControllerCore->run()
in Dispatcher.php line 428
at DispatcherCore->dispatch()
in index.php line 99

 

Laut Github 
https://github.com/FriendsOfSymfony/FOSFacebookBundle/issues/261

kann ich das Problem aber nicht lösen. Jemand von euch eine Idee?

root@mail:~# php -v
PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.30-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies

root@mail:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.5 (stretch)
Release:        9.5
Codename:       stretch


.

issue-prestas-1-7.png

Share this post


Link to post
Share on other sites

Es ist wohl nach wie vor keine gute Idee, von Prestashop 1.6 auf 1.7 upgraden zu wollen ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More