Jump to content

Recommended Posts

Bonjour,

Je débute sur Prestashop et je galère un peu !
Je suis sous 1.6, hébergé chez online.net. J'ai le theme JMS_Cake.

Dans le back office, j'ai les erreurs suivantes :

Lorsque je clique sur le module JMS Slider :
Notice à la ligne 74 du fichier /flex/storage/lasourisdesbois.com/site/www/cache/smarty/compile/4b/6e/0a/4b6e0a5f7a9c7fe1c41c855465390071ce83c6a7.file.list.tpl.php
[8] Undefined index: iso_lang
ce message apparait 3 fois

Lorsque je clique sur JMS settings, j'ai ça :
Notice à la ligne 700 du fichier /flex/storage/lasourisdesbois.com/site/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Undefined index: JMSADV_HOMEPAGE

Je pense que ça a commencé quand j'ai voulu régler un problème sur le front office :  j'avais un petit bouclier sur chrome qui disait que c'était pas sécurisé (alors que je suis en https). J'ai modifié toutes les occurences http:// par https:// dans le thème mais sans succès. J'ai ensuite vu que c'était dans un module jmsmapslocation : j'ai changé http en https dans les fichiers tpl et php et depuis je n'ai plus le bouclier. Mais j'ai les erreurs citées au dessus !

Please help :o)

Merci beaucoup

yan

Share this post


Link to post
Share on other sites

Non, ces erreurs étaient déjà là mais vous n'aviez pas activé le mode debug (ce qui est le cas à présent et vous voyez ces erreurs)

Ce sont des notices donc pas grave mais vous devriez demander à son développeur de les corriger quand même (variables appelées mais non définies)

 

Share this post


Link to post
Share on other sites

Ah ouf ! je me disais que j'avais mis un sacré bazar sans faire grand chose. Merci beaucoup pour votre réponse :o)

Si je peux me permettre, mon erreur de front office avec le bouclier a bien disparu mais en fait j'ai un petit point d'exclamation qui apparait sur un cadenas maintenant. Il marque "connexion non sécurisée". Ce n'est pas très rassurant pour d'éventuels acheteurs. Comment faire pour faire disparaitre ce cadenas.

Merci encore !!

Share this post


Link to post
Share on other sites

corrigez toutes vos urls en http (regardez votre console F12)

Share this post


Link to post
Share on other sites

ok c'est ce que j'avais fait mais uniquement dans le thème jms_cake.
Je peux faire un "remplacer par" sur tout le répertoire prestashop ou bien c'est risqué ?

Franchement merci pour votre réactivité, c'est top.

Share this post


Link to post
Share on other sites

ce n'est pas sur le ftp (ou alors dans les tpl {$base_dir} à la place de {$base_dir_ssl} ) mais en base de données souvent le problème car les modules ont enregistré les chemins en dur en http

Share this post


Link to post
Share on other sites

Dans ce cas, je me connecterai à la base de données pour voir (et je ferai une sauvegarde avant de toucher à quoi que ce soit :o)

Merci²

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More