Jump to content
Heatnet

PHP versie

Recommended Posts

 

 


Mijn provider: Mijndomein.nl meldde onlangs:
Uit een scan blijkt dat je nog PHP 5.6 gebruikt voor je website(s). De ontwikkelaars van PHP 5.6 brengen geen updates meer uit voor deze versie. Je website(s) worden daardoor onveilig en dat heeft gevolgen voor jouw bezoekers en het webhostingplatform van Mijndomein. Daarom stopt de ondersteuning per 1 november 2018 voor PHP 5.6 bij Mijndomein
Doe je niets, dan werken je websites na 1 november 2018 niet meer.
Zet daarom zo snel mogelijk jouw website(s) om naar PHP 7.1. Werkt je website op PHP 7.1 dan kan je proberen of je website ook werkt op PHP 7.2. Hoe nieuwer de versie, hoe sneller hij namelijk werkt.

Nu werk ik tot volle tevredenheid met Prestashop 1.4.8.2 en wil naar 1.7 om te voldoen aan die eisen. Maar ik heb een tamelijk uitgebreide webshop.

  • HOE kan ik het beste van 1.4.8.2 naar Prestashop 1.7 ? (bij de diverse stappen van de ene naar de andere versie blijken nogal eens gegevens te verdwijnen, dus daarom het ik geen gebruik gemaakt van updates)
  • Is er een methode om de versie 1.4.8.2 toch geschikt te maken voor PHP7.1
  • Welke files moet ik dan bewerken?
  • Ik ben daarom van plan om al mijn sites te verhuizen naar Strato. Wat is de beste manier?

 

Ik zal toch niet de enige zijn met zo'n probleem.......

 

 

Share this post


Link to post
Share on other sites

Van een dergelijke "oude" versie van prestashop naar 1.7 zou ik adviseren een professionele partij in de hand te nemen.

Je kan evt. ook een kopie van je shop maken op een dev omgeving en daar dan gaan testen. Er zijn diverse tools om prestashop te upgraden bv https://addons.prestashop.com/nl/migratie-backup/8934-prestashop-naar-prestashop-verhuishulpmiddel.html

Ik zou in ieder geval niet je liveshop gaan upgraden naar 1.7, dat gaat waarschijnlijk heel veel hoofdpijn en irritatie met zich meebrengen.

 

Share this post


Link to post
Share on other sites

Dank voor je reactie!!

Ik wil nu de "oude" webshop in z'n geheel verhuizen naar een andere provider die dit probleem neit veroorzaakt.

Heb al de hele shop gedwonload en moet nu dus ook de database verhuizen. Heb je een idee hoe ik de database kan "verhuizen"? Misschien een domme vraag.......

Share this post


Link to post
Share on other sites

dat probleem gaat overal gelden verwacht ik. Er komen geen updates meer voor die versie, dus of je nu bij hosting A zit of hosting B maakt niet uit.

Database kan je oveigens ook gewoon downloaden via Phpadmin.

Al met al is niet alleen de Php versie waar je op draaien wil dus sterk verouderd, ook de webshop is aan vernieuwing toe, maar dat merkte je zelf al op in je eerste post.

Er zijn wel handleidingen te vinden op dit forum hoe je je website totaal verhuisd. O.a. hoe je site cloned: https://www.prestashop.com/forums/topic/313999-tutorial-how-to-clone-your-shop-for-upgrades/

Deze werkwijze is exact hetzelfde als een verhuizing als het ware

https://www.youtube.com/watch?v=uFUCk9YuC9E

Share this post


Link to post
Share on other sites

Nogmaals bedankt voor je reactie!

Soms ligt de oplossing voor de hand, maar je moet wel even weten waar je deze moet vinden.

Je hebt me weer een stapje verder geholpen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More