Jump to content
Ballet15

Primera carga de artículo lenta, resto bien

Recommended Posts

Buenas tardes,

Tengo un problema con mi tienda prestashop plantilla Leo. Cuando abro un artículo por primera vez ( o al menos a mi me parece que es cuando lo hace), en cualquier navegador, la carga de ese artículo es muy lenta (28 segundos una de las veces cronometradas), a partir de ésta, el tiempo de carga para abrir otro artículo o el mismo es normal (un segundo y medio). 

Al principio pensé en un tema de optimización de imágenes pero me extraña al cargar bien los siguientes. He pasado la página por el google speed insights y los valores que ofrece son óptimos.

Agradecería un montón ayuda.

Gracias!

 

Share this post


Link to post
Share on other sites
En 17/9/2018 a las 10:56 PM, gusman126 dijo:

usa esta herramienta para ver que esta pasando.

http://www.webpagetest.org/

Hola! adjunto los datos que reporta, no sé si con eso podrás ayudarme....

Tampoco sé si dará el resultado buscado, pues el problema no está en la carga de la home. Entras bien pero cuando le das a un artículo (sea desde la home o desde categorías) se queda pensando llegando a tardar 40 segundos en cargar...a partir de este primer artículo, si pulsas sobre otros artículos va bien.

Lo he probado con diferentes productos y optimizado las imágenes en función a resultados de google speed insight pero sigue pasando.

Gracias!!!

 

Edited by Ballet15 (see edit history)

Share this post


Link to post
Share on other sites

Buenas tardes,

tras hablar con el desarrollador de la plantilla, me ha explicado que no es cosa de la misma, el problema parecía estar en el caché del host. 

Gracias y un saludo

Share this post


Link to post
Share on other sites

Buenas tardes,

Al final no sé ha solucionado el problema y no sé como atacarlo...si alguien me pudiera echar una mano o al menos encaminarme...

El host (Loading) dice:

Hemos activado el modo debug de rendimiento de Prestashop para ver qué provoca la lentitud y han salido dos módulos:
productscategory
blockwishlist
Han tardado en cargar unos 103437 ms

También parece que hemos podido reproducir el error. Cuando se elimina el contenido de /httpdocs/themes/ap_gownstore/cache/ y esa carpeta está vacía, al acceder a un producto tarda mucho. Una vez esa carpeta ya tiene varios ficheros la web va bien.

El desarrollador (leo) dice que esos módulos no los tocan, que son nativos de prestashop y que entonces sucedería en todas las webs...

¿Se le ocurre a alguien algo? Al menos por donde puedo seguir tirando...

Gracias!!!

Share this post


Link to post
Share on other sites

Hola Ballet15. Llegaste a solucionar el problema de carga? tengo el mismo problema y sobre todo en movil, también tengo el host en Loading.es

Gracias.

 

Share this post


Link to post
Share on other sites

Lo que indicáis es, hasta cierto punto normal. La caché es precisamente para eso: la primera vez que se accede a un artículo se generan los archivos de la caché para ese artículo. Y eso tarda bastante. En sucesivas entradas, si el contenido ya está generado en caché, lo carga directamente de ahí y eso es mucho más rápido que generarlo de nuevo.

Lo que ya no es tan normal es que en generar la caché de un producto tarde más de 30 segundos,  aunque en última instancia va a depender del contenido cargado (por ejemplo, si el producto tiene muchas combinaciones), de la velocidad del servidor donde está alojada la web y de los recursos que  ésta tenga asignados.

Share this post


Link to post
Share on other sites

Buenas tardes,

@Trade1, pues tengo una noticia buena y una mala, la buena es que lo solucioné, la mala es que lo toqué todo y ya no recuerdo cual fué la tecla exacta...

Quité la previsualización de artículos (no creo que influyera pero fue una de las teclas y así lo dejé). En cuanto a la caché, la respuesta que me dieron desde loading no me arregló nada, pero entré en la configuración y gracias a tutoriales pude optimizarlo, creo que fue esto lo que me ayudo, de todas forma reviso la configuración y te pego como me ha quedado.

@Prestafan33, totalmente cierto, pero por lo menos en la mía era el segundo caso, tiempos de carga por encima de los 40segundos...¿se puede saber con alguna herramienta los recursos asignados?

Un saludo!

Share this post


Link to post
Share on other sites

Los recursos asignados en el servidor dependen de lo que tengas contratado. En los hostings compartidos más baratos normalmente no te lo dicen, en otras opciones de alojamiento superiores sí que te dicen cuántos núcleos de CPU y cuánta RAM tiene asignado tu hosting. Y en los VPS (servidores privados virtuales) eres tú quien configura los recursos del servidor que necesitas, y puedes ampliarlos si lo necesitas (pagando más, claro).

Share this post


Link to post
Share on other sites
14 hours ago, Ballet15 said:

Buenas tardes,

@Trade1, pues tengo una noticia buena y una mala, la buena es que lo solucioné, la mala es que lo toqué todo y ya no recuerdo cual fué la tecla exacta...

Quité la previsualización de artículos (no creo que influyera pero fue una de las teclas y así lo dejé). En cuanto a la caché, la respuesta que me dieron desde loading no me arregló nada, pero entré en la configuración y gracias a tutoriales pude optimizarlo, creo que fue esto lo que me ayudo, de todas forma reviso la configuración y te pego como me ha quedado.

@Prestafan33, totalmente cierto, pero por lo menos en la mía era el segundo caso, tiempos de carga por encima de los 40segundos...¿se puede saber con alguna herramienta los recursos asignados?

Un saludo!

Gracias Ballet15 por la información, cuando puedas me dices como tienes la configuración del cache.

Gracias.

 

Share this post


Link to post
Share on other sites

Buenas tardes,

Perdona por la tardanza pero no he podido pasarme antes. Adjunto captura, espero que sea vea bien o por lo menos se intuyan los campos.

Un saludo!

 

caché.JPG

Share this post


Link to post
Share on other sites
7 minutes ago, Ballet15 said:

Buenas tardes,

Perdona por la tardanza pero no he podido pasarme antes. Adjunto captura, espero que sea vea bien o por lo menos se intuyan los campos.

Un saludo!

 

caché.JPG

Gracias Ballet15 por compartir.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More