Jump to content
ivanchu83

TECHNICAL ERROR: Details: Error thrown: [object Object] Text status: parsererror

Recommended Posts

Hola estoy actualizando una web ya existente, en una carpeta aparte directamente en el server, actualice de 1.6 a 1.7, todo ha ido bien, pero al instalar una plantilla da el siguiente error.

He leido algo de transportista pero los he borrado y sigue saliendo.

Alguna idea de que podria ser?

TECHNICAL ERROR:

Details:
Error thrown: [object Object]
Text status: parsererror

 

Cuando lo pongo en modo depuracion me sale el siguiente error

ContextErrorException

Notice: Undefined index: path_ssl

Edited by ivanchu83 (see edit history)

Share this post


Link to post
Share on other sites

Buenas compañero, tiene pinta algo relacionado con el ssl, comprueba si tienes activado el certificado de seguridad ssl Parametros de la tienda>Configuracion >activar SSL? en el back office, si tienes algun modulo que no sea compatible con la version 1.7 o incluso si la plantilla es totalmente compatible.. No se facilitanos mas información.... Comprueba tambien, activando el modo debug haber si reporta otro error mas descriptivo en todo caso https://victor-rodenas.com/2016/12/09/activar-el-reporte-de-errores-en-prestashop-1-7/

Share this post


Link to post
Share on other sites

Muchas gracias por responder. Si tengo activado el ssl, aunque me dice el navegador que no es completamente segura. Al ver la web me pone no es segura en el backoffice si me pone segura.

Al darle inspeccionar en la web me sale tambien estos errores en consola, ya que en modo depuracion no me lanza ningun error.

Error en el mapeo fuente: request failed with status 404 URL del recurso: https://prueba.puntohosteleria.com/themes/laber_complex_home1/assets/css/theme.css URL del mapa fuente: theme.css.map[Saber más]
No se puede cargar la URL: El dominio de esta URL no está incluido en los dominios de la aplicación. Para poder cargar esta URL, añade todos los dominios y subdominios de tu aplicación al campo de dominios de la aplicación en la configuración de tu aplicación.
La direccion es esta
Llevo varios dias bloqueados intentando encontrar por ahi solucion pero nada de nada.
En la version 1.6 si va y no lanza ese error, la plantilla tiene para version 1.6 y 1.7, se instala sin problemas y los modulos no dan errores, parece funcionar todo bien, pero al cargar la web da ese error y luego ya todo funciona bien.
 
saludos

 

Share this post


Link to post
Share on other sites

Hola

debes pasar toda la web a https://

tienes   en  el código fuente de la página por ejemplo   :

http://   tienes varios

Cambialo todo

Saludos

Edited by aixos (see edit history)

Share this post


Link to post
Share on other sites

Bue

hace 4 horas, ivanchu83 dijo:

Muchas gracias por responder. Si tengo activado el ssl, aunque me dice el navegador que no es completamente segura. Al ver la web me pone no es segura en el backoffice si me pone segura.

Al darle inspeccionar en la web me sale tambien estos errores en consola, ya que en modo depuracion no me lanza ningun error.

Error en el mapeo fuente: request failed with status 404 URL del recurso: https://prueba.puntohosteleria.com/themes/laber_complex_home1/assets/css/theme.css URL del mapa fuente: theme.css.map[Saber más]
No se puede cargar la URL: El dominio de esta URL no está incluido en los dominios de la aplicación. Para poder cargar esta URL, añade todos los dominios y subdominios de tu aplicación al campo de dominios de la aplicación en la configuración de tu aplicación.
La direccion es esta
Llevo varios dias bloqueados intentando encontrar por ahi solucion pero nada de nada.
En la version 1.6 si va y no lanza ese error, la plantilla tiene para version 1.6 y 1.7, se instala sin problemas y los modulos no dan errores, parece funcionar todo bien, pero al cargar la web da ese error y luego ya todo funciona bien.
 
saludos

 

Buenas de nuevo, si ademas de lo que te a dicho el compañero axios de activar todas las paginas ssl, aunque por lo que veo son solo imagines del slider las que tienes que añadirles el https a las urls de las imagenes publicadas...

Comprueba que los archivos de las rutas siguientes no estan corruptos o incompletos, o falta de permisos:

https://prueba.puntohosteleria.com/themes/laber_complex_home1/assets/js/theme.js

https://prueba.puntohosteleria.com/themes/laber_complex_home1/assets/css/theme.css

 

Edited by JavierP (see edit history)

Share this post


Link to post
Share on other sites

Hola de nuevo muchas gracias por contestar.

Como paso todas las paginas o las imagenes a https? en la opcion que viene en prestashop de activar todas las paginas la tengo activa.

gracias

Share this post


Link to post
Share on other sites

Buenas compi de nuevo, te e enviado un privado. Esa opcion tienes que modificarla en el modulo de slider k tengas instalado.

Saludos

JavierP

Share this post


Link to post
Share on other sites

Ya lo solucione, debia ser algun modulo nativo de prestashop, posiblemente alguno de redes sociales, el caso que los desactive todos los que no estaban en uso y se quito el aviso de error.

muchas gracias por vuestro tiempo

  • Thanks 1

Share this post


Link to post
Share on other sites

Hola, a mi me ocurre lo mismo, he borrado todos los transportistas y me sigue dando ese error, ¿que puedo hacer?

Share this post


Link to post
Share on other sites

Hola,

Muchas gracias, pero no llego a entender lo que tengo que hacer, ¿tengo que reemplazar controllers/admin/AdminCarrierWizardController.php?

Quedo pendiente

Share this post


Link to post
Share on other sites

There are a missing ; after $range->save() on line 727

Share this post


Link to post
Share on other sites
Posted (edited)

Do this before click on submit button, before see the message error


Open Developers Tools (CTRL + MAJ + J) of your browser, go to Network tab, filter with XHR, click on each line with index.php?controller=AdminCarrierWizard and tell me what you see in Response tab.

Capture d’écran 2019-04-04 à 16.44.44.png

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

This request has no error.

You have to find the request who display the alert message.

Retry with click on Siguiente and you will see another request on the list, click on it and take a screenshot

If you read {"has_error":false} this is not the right request, you have to find a request with different response

Share this post


Link to post
Share on other sites

Hello, I do not see the error, but if you see it in the capture if it is showing up, I can not locate it, how do I do it?

Share this post


Link to post
Share on other sites

He vaciado las tablas que me han dicho en el foro, y sigue dando el error

ps_carrier 
ps_carrier_group
ps_carrier_lang
ps_carrier_shop
ps_carrier_tax_rules_group_shop
ps_carrier_zone

 

Share this post


Link to post
Share on other sites
Posted (edited)

See my video record to understand how to identify request with error

 

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

We find the problem and it come from a module hooked in displayBackOfficeHeader

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/5/2019 at 1:06 PM, Janett said:

We find the problem and it come from a module hooked in displayBackOfficeHeader

I have the same problem but nothing is hooked to displayBackOfficeHeader. How did you solve this?

I tried replacing the file controllers/admin/AdminCarrierWizardController.php but I'm not able to fix this.

I filled the whole carrier prices but for some reason I can't do this with 3 zones.

Edited by DistribucionesPlata (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

If you can’t apply fix on AdminCarrierWizardController.php you can delete this carrier in BO and create a new one.

Problem come from bad saving of RangePrice in AdminControllerWizardController.php

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

For some reason, it doesn't let me delete the carrier in BO. It goes to the edit page instead. Very strange. I'm going to replace it again with the original AdminControllerWizardController.php and see what happens.

Edit: still the same. I can't delete the carrier.

Edited by DistribucionesPlata (see edit history)

Share this post


Link to post
Share on other sites

Disable this carrier and create a new one.

This carrier is associated to a module ?

Share this post


Link to post
Share on other sites

What is the module name associated to this Carrier ?

Share this post


Link to post
Share on other sites

Correos Oficial v5.0.3 - by Ydral

Basically generates the shipping barcodes and tracking for each order and let you install the different shipment methods for this carrier.

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know why this worked but I edited ANOTHER DIFFERENT shipment method range for the same zone that throws the error and then I edited the one that was giving me problems before and it didn't throw the error 🤷‍♂️

But only worked for one zone.

I'm going to try delete all ranges and start again since it won't let me delete the carrier.

Edit: I deleted all the ranges and started again and now doesn't throw the error.

Edited by DistribucionesPlata (see edit history)

Share this post


Link to post
Share on other sites

The problem started again when I added the last ranges for the carrier. I suppose it is because I have a lot of different zones and ranges. But I have decided to delete the last ranges because I need it to start with this carrier ASAP and try to fix this in the future updating Prestashop.

Thank you for your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More