Jump to content


Recommended Posts

Hi there,

Please could someone assist.  I'm not an expert on Prestashop, but I've managed to keep my shop running for a few years on the basics, and the help supplied in this forum.  The issues today  seem to be a slightly higher grade, and I am a bit lost.  I am unsure if all the following issues are related (I'm hoping they are), perhaps there is a simple fix that I can apply?  Everything seemed fine yesterday and today it feels like the site is almost at a standstill.  I switch between Chrome and Firefox, as certain things work better on one than the other, but now both are going nowhere.

I was busy with an order yesterday from my backoffice.  Although I did not complete the order, I did add the required products in the required quantities.  The order is usually saved as an abandoned cart, and I'm able to continue with it at a later stage.  I went in this morning to complete the order, by selecting the abandoned cart for the customer which now has a zero value (it showed the value of the order yesterday).  The cart does not load and I am unable to add the products on the order screen in the backend in order to complete the order.  After selecting the product and quantity, and clicking on add to cart, the Preston icon in the top left of the screen spins, but no change is applied.  The cart remains empty - products are not added.  I visited the forums and found a topic that suggested I clear the cache, which I did - and still no change.  So right now I am unable to process orders from the backend.  I also checked under Customers => Shopping Carts and ALL of these have a 0 value - including those that were converted into orders (which is also not normal).

I thought of processing the order on my profile from the front end by logging in as a customer, and then adding the customer's details for the delivery and invoice addresses.  I can't sign into the front end.  Login information is accepted, but loops back to the login page.  (This means that none of my customers are able to sign in either - eek!!).  So I tried another angle.  I searched for the product to add to cart so that I could add to the cart first, and perhaps log in on completion of the order.    The search does not pick up the product.  The page shows Showing 1 - 18 of 43 items, but no products are displayed.  It does show the page numbers as well, so that I can click through to see products 19 - 36, but still no products show.  Also, my cart stays empty even if I try to add products and then when I click to view cart, its blank. 

Products do show under certain categories, but some categories don't show any products when they should. (Example page still shows that 63 products are listed under the category, even though no products are listed).

I activated the console by using F12 in both Firefox and Chrome.  ON FIREFOX, it shows TypeError: document.getElementById(...) is null and also Blocked loading mixed active content “http://www.simplyeverything.co.za/index.php?controller=statistics” as the errors., IN CHROME, the error shows as Uncaught TypeError: Cannot read property 'removeAttribute' of null.  The googling I've done on these errors means very little to me, as I don't understand javascript and am not sure which files I would have to amend.

The mixed active content made me think of the enabling of https, which I enabled about a week ago - but since all images should still have the error of http:// instead of https://, it does not explain why some products would show under categories, and others not.

I did not change anything in the settings of the site yesterday - I only worked to catch up on admin and orders.  My hosting company did do a server upgrade yesterday - I thought this might be the issue.  They re-imported the site to the new server again this morning, after my complaint.  No change.  Even resolving my domain to the previous server does not change anything.  

The error log in my cpanel does not show any errors, except for the denys on IP addresses that I've blocked.

If anyone has experienced this issue, or is able to help, it would be greatly appreciated :).  Thank you.

PS... wasn't sure if any additional information would be required - please let me know if I need to supply details.  Thanks :)


Link to comment
Share on other sites

[I figured it out... it was a quick fix thankfully...

Added allow_url_fopen = on into my php.ini file

Haven't tested everything, but looks like cart is working again.

Anyone know what this code is used for please?]


This 'solution' was not the solution, unfortunately.  Turns out the website had resolved to the old server.  So still have the above problem.

Edited by Simply123
Not resolved (see edit history)
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...