Jump to content
matmatoo

payment.php 500 Internal Server Error

Recommended Posts

Hi everyone!

Me again.. sorry!

So, I have configured both wiretransfer and cheque payment facilities in PrestaShop (they come standard in the download), but when I click the payment method, and it goes onto the filename "payment.php", it comes back with a 500 Internal Server Error?

It goes on to say:

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@***.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


Can anyone help me with this?

Thanks
Matt

Share this post


Link to post
Share on other sites

OK, sorry... I accidently posted this in the wrong forum, can someone please move it for me? I dunno now.

Sorry!
Matt

Share this post


Link to post
Share on other sites

yeah im having same issue with clean install of current stable version...

found this solution....
!!SOLVED!!

I read on wiki pages Install tutorial:
http://www.prestashop.com/wiki/Getting_Started/#Install_PrestaShop
and at the #6 is:
While you have your FTP connected to your Web hosting server, make sure the following PrestaShop folders have ‘write’ permissions (also known as “CHMOD 777” – explanation of file permissions here) but do not apply these permissions recursively (to their subfolders)

And I follow this instruction and change the root PrestaShop folder to CHMOD777 next checking that subfolders have standard permission, they had (so I change CHMOD correctly – not recursively).
But now I change my root forlder of PrestaShop to CHMOD755 and now everythings works fine!
Is my server strange or is “CHMOD777” a bug in tutorial?

Share this post


Link to post
Share on other sites

this solution is not working for me.

note my presta install is the htdocs root folder of the webserver.

any ideas?


yeah im having same issue with clean install of current stable version...

found this solution....
!!SOLVED!!

I read on wiki pages Install tutorial:
http://www.prestashop.com/wiki/Getting_Started/#Install_PrestaShop
and at the #6 is:
While you have your FTP connected to your Web hosting server, make sure the following PrestaShop folders have ‘write’ permissions (also known as “CHMOD 777” – explanation of file permissions here) but do not apply these permissions recursively (to their subfolders)

And I follow this instruction and change the root PrestaShop folder to CHMOD777 next checking that subfolders have standard permission, they had (so I change CHMOD correctly – not recursively).
But now I change my root forlder of PrestaShop to CHMOD755 and now everythings works fine!
Is my server strange or is “CHMOD777” a bug in tutorial?

Share this post


Link to post
Share on other sites

I tried this last night but it didn't work, it still is saying INTERNAL SERVER ERROR.

:(

Share this post


Link to post
Share on other sites

locatefile module/paypal/api/paypal_connect.php

 

change line 85 to @curl_setopt($ch, CURLOPT_VERBOSE, false);

 

[]

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More