Jump to content
dregcla

defines.inc.php (Prestashop 1.4)

Recommended Posts

Bonjour,

 

En utilisant "defines.inc.php" pour le mettre en mode debug, j'ai donc passé du mode false à true : Résultat, je me retrouve avec une page http 500 sur mon BO et mon magasin shop ?

Je repasse donc en false et trouve toujours cette page http 500 sur mon BO (prestashop 1.4) et mon magasin de vente ???

Auriez-vous une solution ?

Merci d'avance

Share this post


Link to post
Share on other sites

Très probablement que tu as fait une faute de syntaxe dans ce que tu as modifié

 

Share this post


Link to post
Share on other sites
Il y a 2 heures, doekia a dit :

Très probablement que tu as fait une faute de syntaxe dans ce que tu as modifié

 

Bonjour et merci Doekia !

Grâce à toi, j'ai fini par trouver le "réel" pourquoi de cette page 500 sur mon BO et SHOP en production...

Cela pourra servir d’expérience éventuellement à d'autres...

En faite, en passant le Defines.inc.php en TRUE, comme expliqué plus haut la page blanche 500 est arrivée.

1- J'ai alors remis "false" afin dans l'espoir de retrouver mon BO et  mon SHOP, recopiant alors "false" sans erreur j'en suis certain

2- Résultat, page 500, puis ta réponse me parvient, d'aller vérifier la syntaxe...

3 - Je me dis alors, passe à tout hasard par le debug config.inc.php en passant de "off" à "on" et voici qu'il me demande d'aller dans le defines.inc.php à la ligne 157... Ligne 157 étant la dernière du fichier se terminant par ">"

4 - Et là, miracle... Je me souviens, qu'il y a plusieurs mois avoir eu une réponse de ta part également pour un autre fichier php que j'avais touché et tu m'avait dis : Va mettre un "?" devant le ">".... Et miracle tout à re-fonctionné ! 

ET IDEM POUR MON FICHIER "DEFINES" CE JOUR !

Merci, merci, et j'espère que cette info importante cela pourra servir pour d'autres

 

Régis

(Etant en version 1.4, je pense qu'il aurait mieux valu que je debug avec mon config.inc.php

Share this post


Link to post
Share on other sites

Puis-je profiter encore de ton aide ?

 

En faite, si j'ai été dans ce fichier aujourd'hui , c'est que je galère depuis plusieurs jours pour trouver la solution dans mon BO, mais cette fois-çi avec ma page MODULE, qui n'affiche plus les modules ???

Cela a commencé lorsque j'ai voulu installer un module sur le RGPD, je l'ai alors supprimé sur mon FTP mais c'est toujours pareil ?

 

En passant en mode debug, voici le message d'erreur :

Fatal error: Call to undefined method Tools::getCurrentUrlProtocolPrefix() in /var/www/default_vds/shop/classes/Module.php(408) : eval()'d code on line 66

 

Et voici un extrait ci-dessous de mon fichier Modules.php line 66 (La ligne 66 correspondant à : public $_errors = false;

    /** @var string Fill it if the module is installed but not yet set up */
    public $warning;

    /** @var string Message display before uninstall a module */
    public $beforeUninstall = NULL;

    public $_errors = false;

    protected $table = 'module';

    protected $identifier = 'id_module';

    static public $_db;

 

Je précise que sur mon serveur dédié (easy-hebergement), la Ram consommée est à 65% et que la memory_limit dans mon fichier php.ini est par défaut de 196 Mo

Merciiiiiiii

Share this post


Link to post
Share on other sites

Il n'existe a ma connaissance qu'un seul module RGPD compatible 1.4 - c'est le module de @Eolia que j'ai porté

Supprime le module que tu as installé et tout devrait rentrer dans l'ordre.

 

Par ailleurs, si ce n'est toi qui à "vérolé" ton defines.inc.php (d'ailleurs en 1.4 le debug ne s'active pas par là), c'est donc que tu utilises un éditeur boiteux ou mal configuré qui confond php et html et corrompt tes fichiers en ajoutant des marquages non-sens.

Share this post


Link to post
Share on other sites

Bonsoir Doekia,

 

Je viens d'acheter le module RGPD 1.4, celui de @Eolia.

Maintenant j'aimerais l'installer, seulement je suis toujours avec mon problème de page MODULE vide dans mon BO !

Je n'arrive pas à les retrouver !  J'ai enlevé dans mon FTP, dans le fichier SHOP/MODULE, le fichier RGPD  1.7 que j'ai voulu installer sur du 1.4 :( et a tout planté, mais cela ne change rien.

Cela fait maintenant 2 semaines que je ne peux plus rien faire sur mes modules

Si tu peux m'aider, ton aide sera la bienvenue :)

Régis

Share this post


Link to post
Share on other sites

Bonsoir Doekia,

J'ai enfin trouvé le module qui m’embêtait et j'ai donc retrouvé ma page module !!! 

Tout est revenu dans l'ordre, ouf !

J'ai acheté le RGPD 1.4, je l'ai décompressé avec winzip.

Et là je suis au point mort pour l'installer car je n'ai pas de doc sur l'install ou alors pas vu où ?

Si jamais tu peux m'aider ?    Merci.    Régis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More