Jump to content

Recommended Posts

Ola,

 

When installing a fresh version of PS 1.7.4.1 I received a warning

Quote

To get the latest internationalization data upgrade the ICU system package and the intl PHP extension


That server was running CentOS6, cPanel 71, PHP7.2 and ICU 50.1.2.

 

I have now moved servers to CentOS7, cPanel 72, PHP 7.2 but I see the inherent ICU is 50. If I upgrade the package to 62.1 the warning goes away - HOWEVER, upgrading to 62.1 is not supported by cPanel. See link below

 

https://forums.cpanel.net/threads/install-php71-php-intl-with-a-more-recent-version-of-icu.620979/

 

Can someone tell me what PS is looking for? What system is required (that is supported) to ensure that no warning messages appear.

 

Thanks

 

 

  • Like 1

Share this post


Link to post
Share on other sites

This isn't a Prestashop error.

 

The error is because the version of your intl PHP extension is outdated. You need to manually upgrade your intl.

 

 

Share this post


Link to post
Share on other sites
On 22. 9. 2018 at 8:56 PM, Rebel Tech said:

This isn't a Prestashop error.

 

The error is because the version of your intl PHP extension is outdated. You need to manually upgrade your intl.

 

 

This is not true. Because I have installed the recomended PHP version.

Share this post


Link to post
Share on other sites
12 hours ago, vlskrbek said:

This is not true. Because I have installed the recomended PHP version.

What version of ICU are you running?

 

 

Share this post


Link to post
Share on other sites

Same problem; 
php -i display : 
 

Internationalization support => enabled

version => 1.1.0

ICU version => 60.2

ICU Data version => 60.2

ICU TZData version => 2017c

ICU Unicode version => 10.0


There is the version 62.1 here : 

http://www.fr.linuxfromscratch.org/view/blfs-svn/general/icu.html

I downloaded it in my ~ folder. I did all instruction an typed :

 

cd source                                    
./configure --prefix=/usr                    

make
make install

 

I got a lot of compilation lines.... I restarted apache but My version still be 60.2

Should i put the install repository in an other folder ?

Share this post


Link to post
Share on other sites
On 29. 9. 2018 at 2:04 PM, Rebel Tech said:

What version of ICU are you running?

I have xampp on windows.

Prestashop 1.7.4.2

PHP 5.6.37

and ICU included in PHP is version 57.1

 

The technical requirements for Prestashop 1.7 say only the version of PHP and suported version is PHP 5.4 and later.

The problem is that the ICU version is not mentioned and the ICU is included in PHP. So the warning is a little out of specification.

They should say that the supported version is PHP 5.4 and later but for internationalize you need ICU version at least xx and it is included in PHP yyy.

But nobody said it therefore we asked. Thats all.

The question is really that you wrote in the begining:

---

Can someone tell me what PS is looking for? What system is required (that is supported) to ensure that no warning messages appear.

---

Does anybody know the answer?

 

Best Regards

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

That's actually Symfony's requirement. The code compares the version from

/vendor/symfony/symfony/src/Symfony/Component/Intl/Resources/data/version.txt

against the server's ICU version.

I cannot be bothered to alter the server on every minor PrestaShop version, so I guess I'll give up on " the latest internationalization data".

Just for reference, PrestaShop wants the following ICU versions:

1.7.4.x  -  62.1

1.7.3.x  -  60.1

1.7.2.x  -  59.1

1.7.1.x  -  58.2

1.7.0.x  -  57.1

  • Thanks 1

Share this post


Link to post
Share on other sites

Diky za info.

Pokud to tak je. Tak jediné co je potřeba je toto napsat do dokumentace. To je vše. 

Víte někdo kdo ji má na starosti nebo kdo ji může upravit? 

Share this post


Link to post
Share on other sites

Ok,  so how do we upgrade to ICU version 62.1 ???

We have Ubuntu 18 with php7.1-intl,  nginx

Can someone please link to a definitive answer? 

Edited by remoteONE (see edit history)

Share this post


Link to post
Share on other sites

buenas tardes tengo el mismo problema "Para obtener los últimos datos de internacionalización, actualice el paquete del sistema ICU y la extensión PHP intl"

la version de prestashop es la 1.7.5.2 y xampp xampp-win32-5.6.32-0-VC11-installer...en win 7 pro 64 bits....

Share this post


Link to post
Share on other sites

Sometimes you can ignore the ICU check. In my case, I have prestashop 1.7.6.1 and the required ICU is 64.1 but I have ICU 64.2 (the latest). Prestashop doesn't check greater version. I dont think I should downgrade my ICU. I think this should be considered a bug. PHP version came bundled with its own ICU's version. 

 

Edited:

 

I think the best way to check system requirement is to use this recommended tool by Prestashop: https://github.com/PrestaShop/php-ps-info/releases

This tool is recommended by Prestashop as mentioned in the official documentation: https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/

Edited by arafatx (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More