Jump to content

{SOLUCIONADO} No sale lista de productos en correo confirmación de pedido cliente en Prestashop 1.7


ecuc
 Share

Recommended Posts

Buenas, tengo un pequeño problema por si a alguien también le ha surgido.

Estaba haciendo prueba en una tienda de testeo que tenemos, cuando nos hemos fijado que a la hora de realizar la compra, el correo que nos llega como cliente con la confirmación del pedido no nos devuelve el listado de productos de la compra realizada.

Encontré esta publicación que trataba el mismo problema, pero por lo que he visto es con una versión de Prestashop 1.6.0.8, mientras que nosotros estamos trabajando con la 1.7.3.3.

https://www.prestashop.com/forums/topic/354565-no-sale-lista-de-productos-en-correo-confirmacion-de-pedido-cliente/

Si alguien sabe como podría avanzar con esta incidencia, lo agradecería.

Saludos

Edited by ecuc
RESOLVE (see edit history)

Share this post


Link to post
Share on other sites

Vale, leyendo bien la publicación, me he autoresuelto el problema. Mi problema era que no tenía en /mails/es los ficheros de order_conf_cart_rules y order_conf_product_list, tanto los .tpl como los .txt, y lo recomendable era copiar los de /mails/en.

El problema era que solo tenía la carpeta de los correos en Español, así que si, a alguien le surje este mismo problema, solo teneís que añadir estos ficheros que os adjunto a la carpeta de /mails/es

Saludos

order_conf_cart_rules.tpl

order_conf_cart_rules.txt

order_conf_product_list.tpl

order_conf_product_list.txt

  • Like 2

Share this post


Link to post
Share on other sites

  • 1 year later...
  • 1 month later...

Muchas gracias, a mí me daba error en estas dos traducciones y me ha tenido indagando todo el día. Haciendo esto funciona, lo que ocurre es que las copias de idioma "en" logicamente están en inglés así que sí, lo reconoce como traducido pero están realmente sin traducir… No sé si alguien conoce alguna manera para traducir manualmente un "cuerpo" que la plantilla por defecto de prestashop parece haberse saltado…

Y además de este problema, a mi no me enlaza los "asuntos" a los "cuerpos" del mail. No sé cómo hacerlo. En algunos sitios he visto que cambiando lang.php pero ya lo he hecho, están todos traducidos dentro, os dejo pantallazo del lang y sin embargo me dice lo que véis en el otro pantallazo. A ver si alguien sabe.

Gracias!

Captura de pantalla 2020-03-09 a las 17.57.13.png

Captura de pantalla 2020-03-09 a las 17.59.55.png

Edited by ArtesAna (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More