Jump to content
NANTmoteurs

Page catégorie passé en Noindex sans action de ma part [résolu]

Recommended Posts

Bonjour,

Depuis quelques jours sur mon Prestashop 1.6.1.7, j'ai de plus en plus de catégorie qui passe en Noindex sans aucune action de ma part. Je n'ai pas modifié récemment de fichier. ( le fichier header.tlp en autre)
J'ai des doutes concernant la navigation à facette, car toute les pages touchés on une navigation à facette et j'ai mis à jour le module il n'y as pas longtemps. Cela peut il venir de là ?

Les pages catégories relevé dans la couverture de l'index  comme noindex on toute  <meta name="generator" content="PrestaShop" /><meta name="robots" content="noindex,nofollow" />

J'ai bien vérifié mon fichier Header.tlp et il me parait correct

Il contient 

{/if}
        <meta name="generator" content="PrestaShop" />
        <meta name="robots" content="{if isset($nobots)}no{/if}index,{if isset($nofollow) && $nofollow}no{/if}follow" />
        <meta name="viewport" content="width=device-width, minimum-scale=0.25, maximum-scale=1.6, initial-scale=1.0" />
        <meta name="apple-mobile-web-app-capable" content="yes" />
        <link rel="icon" type="image/vnd.microsoft.icon" href="{$favicon_url}?{$img_update_time}" />
        <link rel="shortcut icon" type="image/x-icon" href="{$favicon_url}?{$img_update_time}" />
        {if isset($css_files)}

A ce rythme là toutes mes catégories vont être désindexé... 

Merci d'avance pour votre aide !

EDIT: c'est bien la mise à jour du module navigation à facette ( de v.2.2.0 vers 2.2.1) qui à mis en noindex toutes mes catégories. J'ai donc ré-installer la version 2.2.0 et tout est rentré dans l'ordre, les catégories avec navigation à facette sont repassé en  "content="index,follow""

 

Edited by NANTmoteurs
[résolu] (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai justement le même problème enfin les mêmes effets.

Je ne sais pas si cela vient de la mise à jour car je n'ai pas vu qu'il y avait une mise à jour.

 

Mais j'ai bien la version 2.2.1 de navigation à facettes. 

 

Comment fait-on pour remettre l'ancienne version ?

 

Merci d'avance.

Share this post


Link to post
Share on other sites

Bonjour, 

 

Je remarque le même problème. 

et quasi sur toutes mes pages catégories .

Et comme je n'y connais rien en noindex ou autres .....

J'ai reçu des messages sur la console google. 

Pour la version du module de navigation à facette, je suis en 2.2.1. Comment repasser en 2.2.0 svp ?

 

Pourriez vous m'indiquer la démarche à faire , et aussi comment voir si ce code est installé "content="index,nofollow"" ? 

 

Merci par avance

Edited by Les Bijoux de JADE (see edit history)

Share this post


Link to post
Share on other sites

@bijouxgiuliana, j'ai simplement téléchargé ma version de prestashop ( https://www.prestashop.com/fr/versions-precedentes) et remplacé à l'aide de mon FTP les deux fichier mis à jour ( pour rappel je suis en 1.6.1.7) qui sont blocklayered.php et  config.xml . Tu peux voir les fichier qui compose le module sur https://github.com/PrestaShop/blocklayered


@Les Bijoux de JADE pour "voir" la balise, il te suffit sur chrome d'aller sur ta page de faire un clic droit et de sélectionner  afficher le code source de la page, un onglet va s'ouvrir , ensuite ctrl F pour ouvrir une barre de recherche et recherche "robot" ou "index" ou "noidex".

Edited by NANTmoteurs (see edit history)

Share this post


Link to post
Share on other sites

Bonjour @NANTmoteurs     

En effet, j'ai bien ce meta name="generator" content="PrestaShop" /><meta name="robots" content="noindex,nofollow"

sur quasiment toutes mes pages catégorie

Que dois je faire pour l'enlever ? je suis sous Presta - 1.6.1.16

 

Merci 

Share this post


Link to post
Share on other sites

@Les Bijoux de JADE, comme indiqué au dessus:

j'ai simplement téléchargé ma version de prestashop ( 
https://www.prestashop.com/fr/versions-precedentes) et remplacé à l'aide de mon FTP les deux fichiers mis à jour ( pour rappel je suis en 1.6.1.7) qui sont blocklayered.php et  config.xml . Tu peux voir les fichier qui compose le module sur https://github.com/PrestaShop/blocklayered

Edited by NANTmoteurs (see edit history)

Share this post


Link to post
Share on other sites

Merci pour le lien github... quand on voit l'historique, on se demande bien pourquoi cette soudaine envie de commiter des maj établies il y a une éternité,  initiative qui nous a mis dans le mur !

Share this post


Link to post
Share on other sites

J'ai eu le cas pour un client italien il y a 2 ou 3 semaines. En fait, il suffit de passer à "oui" les 4 dernières questions dans le panneau de config du module à facettes ("Autoriser les robots d'indexation (Google, Yahoo!, Bing, etc.) pour le filtre Condition")

  • Thanks 3

Share this post


Link to post
Share on other sites

Merci @NANTmoteurs,

 

Je vais essayer mais là j'ai besoin d'un développeur car tous les voyants sont au rouge dans la search console et mes pages disparaissent de google alors que finalement j'ai supprimé la navigation à facettes.

Je suppose qu'il y a une rubrique pour trouver un développeur ?

 

 

 

 

 

Share this post


Link to post
Share on other sites

Merci @NANTmoteurs,

 

Je vais essayer mais là j'ai besoin d'un développeur car tous les voyants sont au rouge dans la search console et mes pages disparaissent de google alors que finalement j'ai supprimé la navigation à facettes.

Je suppose qu'il y a une rubrique pour trouver un développeur ? 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

@bijouxgiuliana
Serach console a un décalage de plusieurs jours donc pas de stress c'est normal :)

Par contre je ne suis pas sure de la pertinence d'indexer les pages avec des filtres, je n'utilise pas ce module mais j'ai peur d'un mauvais effet. 
D'ailleurs au moment ou j'écris ces lignes je me rends compte que j'ai un index sur les filtres avec AS4 également pourtant j'étais sure de pas l'avoir avant :o 
J'ai bien fait de lire ce sujet :)

 

[Edit] J'ai une canonical sur la catégorie [/edit]

 

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, 

Dans la configuration du module à facettes, il suffit de cocher tout en bas "Autoriser les robots d'indexation (Google, Yahoo!, Bing, etc.) pour le filtre Catégorie"

et ça fonctionne ensuite, pas besoin de revenir à une ancienne version du module.

  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour a tous, désolé de relancer ce sujet, mais dans la configuration du module a facette, je ne trouve nul part "Autoriser les robots d'indexation (Google, Yahoo!, Bing, etc.) !!!

Share this post


Link to post
Share on other sites
3 hours ago, brikobike said:

Bonjour a tous, désolé de relancer ce sujet, mais dans la configuration du module a facette, je ne trouve nul part "Autoriser les robots d'indexation (Google, Yahoo!, Bing, etc.) !!!

Bonjour, j'ai bien la case à cocher,

ma version de prestashop est la 1.6.1.23 et ma version du module à facettes est la 2.2.1

Share this post


Link to post
Share on other sites

Pour ma part je suis sous 1.7.5 et module 2.2.1 mais aucune case a cocher avec cette option :(, je vais voir pour réinstaller le module

merci

Share this post


Link to post
Share on other sites
Just now, brikobike said:

Pour ma part je suis sous 1.7.5 et module 2.2.1 mais aucune case a cocher avec cette option :(, je vais voir pour réinstaller le module

merci

ci-jointe ma vue, dernier onglet

Capture d’écran 2019-04-02 à 23.52.46.png

Share this post


Link to post
Share on other sites

C'est etonnant, c'est la même version du module, est ce prestashop 1.7.5 qui créer cette différence d'affichage :(, si d'autre utilisateurs de 1.7.5 peuvent confirmer ce serais sympa, ça m'eviterais de réinstaller le module et d'avoir a refaire tous mes filtres.

facette.png

Share this post


Link to post
Share on other sites

 

I leave the comment in English since I do not speak French: It happens to me just like @brikobike. I have version 1.7.4.3 of prestashop and 2.2.1 of faceted navigation. How can it be changed without reinstalling the module? I have too many filters to start over! Thank you

Citation

 Je laisse le commentaire en anglais puisque je ne parle pas français : Ça m'arrive comme à @brikobike. J'ai la version 1.7.4.3 de prestashop et 2.2.1 de navigation à facettes. Comment le changer sans réinstaller le module ? J'ai trop de filtres pour recommencer ! Je vous remercie

 

Edited by Mediacom87
Traduction du message (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Pour ma part je suis sous 1.7.5.0 avec le module 2.2.1 mais je n'ai pas toutes ces options en bas de page :( si d'autres personnes utilisant cette configuration peuvent confirmer.  merci

 

Edited by brikobike (see edit history)

Share this post


Link to post
Share on other sites
It does not appear to me either. I have tried the top 3 indexing options but it has not worked.
Citation

Il ne me semble pas non plus. J'ai essayé les 3 meilleures options d'indexation mais cela n'a pas fonctionné.

 

Edited by Mediacom87
Traduction du message (see edit history)

Share this post


Link to post
Share on other sites
Il y a 4 heures, Adrian a dit :

 

I leave the comment in English since I do not speak French: It happens to me just like @brikobike. I have version 1.7.4.3 of prestashop and 2.2.1 of faceted navigation. How can it be changed without reinstalling the module? I have too many filters to start over! Thank you

 

Il y a 2 heures, Adrian a dit :

It does not appear to me either. I have tried the top 3 indexing options but it has not worked.

Merci de faire l'effort au minimum de traduire vos messages si vous souhaitez participer dans un forum qui ne correspond pas à votre langue.

Ceci est le premier avertissement, après j'effacerais les messages si vous ne respectez pas les règles du forum.

 

Share this post


Link to post
Share on other sites

 

J'ai déjà prévenu que je ne connaissais pas le français et que le traducteur le faisait mieux si je le passais en anglais, c'est pourquoi j'ai décidé de le faire. Je ne crois pas non plus que ce soient les moyens de donner un avertissement, de se détendre un peu. Désolé si cela vous a dérangé.

 

 

PS: En ce qui concerne le problème, je vois que vous ne pouvez rien contribuer.

Share this post


Link to post
Share on other sites
à l’instant, Adrian a dit :

J'ai déjà prévenu que je ne connaissais pas le français et que le traducteur le faisait mieux si je le passais en anglais, c'est pourquoi j'ai décidé de le faire. Je ne crois pas non plus que ce soient les moyens de donner un avertissement, de se détendre un peu. Désolé si cela vous a dérangé.

Si le traducteur fait mieux, pas de problème excepté que c'est a toi de faire les copier coller vers/du traducteur, pas à nous. Si tu veux une réponse c'est probablement ici. Si tu veux te détendre tu vas sur une site de lolkat!

il y a 5 minutes, Adrian a dit :

PS: En ce qui concerne le problème, je vois que vous ne pouvez rien contribuer.

Le topic lui-même est la contribution. La réponse à ton problème. Si tu le lis/traduis tout y est. Il devient de plus en plus difficile de fournir des réponses pour les gens qui n'arrivent pas à lire leurs écran. Se perdent quand il y à plus de deux options à cocher. La version 2.2.1 du module contient les options, la version 3.0.5 ne les contient pas mais celle-ci n'injecte pas le noindex.

  • Like 1

Share this post


Link to post
Share on other sites
43 minutes ago, doekia said:

La version 2.2.1 du module contient les options, la version 3.0.5 ne les contient pas mais celle-ci n'injecte pas le noindex.

Comment expliquer que sur ma boutique 1.7.5.0 avec le module 2.2.1 ces options n'apparaissent pas :( ?

Share this post


Link to post
Share on other sites
il y a 13 minutes, brikobike a dit :

Comment expliquer que sur ma boutique 1.7.5.0 avec le module 2.2.1 ces options n'apparaissent pas :( ?

Troubleshooting, reverse engineering, analyse écosystème, ...

Share this post


Link to post
Share on other sites

 

Dans 2.2.1 les options n'apparaissent pas. Et dans les réponses précédentes, la solution avec cette version n'apparaît pas.

Désolé si vous avez dérangé mon commentaire, mais je ne pense pas que ce soit un moyen de donner un avertissement.

Share this post


Link to post
Share on other sites
1 hour ago, doekia said:

Troubleshooting, reverse engineering, analyse écosystème, ...

Si j'avais été seul dans ce cas je penserais que je suis un cas isolé et que ma boutique a un problème, mais cela ne semble pas être le cas, d'autres utilisateurs ont les mêmes symptomes

Share this post


Link to post
Share on other sites

 

 

I have solved it by going to the category pages and giving "index search engine". Change it to "yes".

Je l'ai résolu en allant dans les pages de catégories et en donnant "moteur de recherche d'index". Changez-le en "oui".

Je le mets aussi en anglais SI VOUS NE COMPRENEZ PAS. J'espère que vous ne faites pas attention à nos chers modérateurs. 😉

 

 

Share this post


Link to post
Share on other sites

Merci Johann pour cette solution, simplissime qui fonctionne très bien

Quote

J'ai eu le cas pour un client italien il y a 2 ou 3 semaines. En fait, il suffit de passer à "oui" les 4 dernières questions dans le panneau de config du module à facettes ("Autoriser les robots d'indexation (Google, Yahoo!, Bing, etc.) pour le filtre Condition")

Bonne journée

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More