Jump to content
marco80

[Risolto] Problema maiuscole in funzioni prodotto

Recommended Posts

Buongiorno, come da titolo volevo sapere se c'era un modo per eliminare le maiuscole a inizio parola nelle funzioni del prodotto. Mi spiego meglio, utilizzo la versione 1,7 starter theme. Nella scheda del prodotto quando aggiungo una funzione al prodotto la vedo correttamente come scritta ( ad esempio Data partenza) , sul sito la funzione mi appare con la prima lettera sempre in maiuscolo. Quindi Data partenza diventa Data Partenza .. Quota di partecipazione diventa Quota Di Partecipazione. 

Esiste un modo per poter far prendere i caratteri effettivi che si inseriscono nel campo Funzioni eliminando questo problema della maiuscole a inizio parola??

Grazie mille a chi mi aiuta!! 

Share this post


Link to post
Share on other sites

Ciao,

 

devi semplicemente ritoccare il theme.css quá in.... Theme/classic/assets/css/theme.css:

 

.product-features>dl.data-sheet dd.value, .product-features>dl.data-sheet dt.name

text-trasform: unset;

modifica da capitalize a unset

 

ciao

 

Ps: poi pulisci le cache e rigenera il template

 

Edited by Fabry (see edit history)

Share this post


Link to post
Share on other sites

 

1 hour ago, Fabry said:

Ciao,

 

devi semplicemente ritoccare il theme.css quá in.... Theme/classic/assets/css/theme.css:

 

.product-features>dl.data-sheet dd.value, .product-features>dl.data-sheet dt.name

text-trasform: unset;

modifica da capitalize a unset

 

ciao

 

Ps: poi pulisci le cache e rigenera il template

 

 

 

Ciao Fabry, funziona!!!!   Grazie mille per l 'aiuto !! 

Share this post


Link to post
Share on other sites

Ciao Fabry,

Ho provato a modificare il codice come hai segnalato e ricaricato la pagina ma il problema delle maiuscole persiste (vedi screenshot). Non ho capito cosa intendi per "rigenera il template".

Qualche idea? Versione prestashop 1.7.5.1

Grazie molte

Dettagli-prodotto.jpg

Share this post


Link to post
Share on other sites

Ciao Frabry,

ho seguito le tue istruzioni sulla modifica del theme.css, compresa poi la pulizia della cache e la rigenerazione del template.

Purtroppo non ha funzionato.

Hai qualche ulteriore suggerimento?

Grazie.

Antonio

Share this post


Link to post
Share on other sites

Ciao Antonio...ok

se hai la 1.7 e lo starter theme deve funzionare...se mi mandi il link del sito si capisce il problema cmq.

questo parametro nel css regola la prima lettera della parola.....per tanto da Spessore Mn avrai Spessore mn....ma se nelle traduzioni hai tradotto con Spessore Mn non avrá effetto:-)..controlla le traduzioni!

 

ciao

Share this post


Link to post
Share on other sites

Ciao Fabry,

mi scuso di scrivere dopo così tanto tempo.

Utilizzo la versione 1.7.6.2.

Utilizzo il tema classic Versione 1.0.0.

Il link è www.fiorame.it

Utilizzo solo la lingua italiana.

Attualmente il file è quello originale di Prestashop senza nessuna modifica.

Se tu non dovessi trovare nulla di anomalo proverò a modificare nuovamente il file, che per qualche motivo io non abbia commesso qualche errore.

Grazie in ogni caso per avermi risposto.

Antonio 

Share this post


Link to post
Share on other sites

Scusate se mi intrometto, ma perché chiamarle Funzioni? non sarebbe più chiaro Caratteristiche?

Ciao

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More