Jump to content
patdec

Problème d'installation de module

Recommended Posts

Bonjour,

 

quand j'essaie d'installer un module via le bouton "Installer un module", j'obtiens systématiquement le message d'erreur: "Ce fichier ne semble pas être un fichier .zip de module valide."

Si je décompresse mon archive manuellement dans le dossier "modules", je peux ensuite installer mon module normalement.

Comment puis-je débugger ce problème d'installation automatisé ? J'ai besoin que mon module s'installe via le lien et non par FTP.

 

Merci de votre aide.

Sélection de modules • Toc.png

Edited by patdec (see edit history)

Share this post


Link to post
Share on other sites

Ton fichier est un zip ou un tar.gz ? car Prestashop a décidé de ne plus supporter le tar.gz (qui était supporté depuis plus de 10ans nativement)

Après il est possible que ton problème soit lié à des permissions d'espace temporaire sur ton hébergement

Share this post


Link to post
Share on other sites

Bonjour,

j'ai le même problème.

J'ai vérifié mon zip et les permissions, mais rien n'y fait, j'ai toujours l'erreur.

Patdec, tu l'as toujours aussi?

Merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites

Bonjour,

 

oui j'ai enfin réussi à installer mon module. Chez moi le problème venait du fait que le nom utilisé par le dossier qui contient les fichiers du module était différent de celui du nom du module.

Il faut impérativement que le nom du dossier (et peut être de l'archive zip) soit identique à celui du module.

Share this post


Link to post
Share on other sites

D'où il vient ce "module" c'est une obligation depuis toujours d'avoir nom du dossier == nom du fichier .php à l'intérieur ?

Share this post


Link to post
Share on other sites

Depuis toujours, je ne sais pas. Mais effectivement si le nom du module est "nom_module" alors le dossier  doit avoir pour nom "nom_module" et ce dernier doit contenir un fichier intitulé "nom_module.php" qui contient la config de base.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

patdec

pour ma part j'ai bien vérifié au niveau du nom de module/répertoire et j'ai toujours le problème.

je prends toute nouvelle piste!!

Merci d'avance pour votre aide

Share this post


Link to post
Share on other sites

Bon, si ça peut servir à quelqu'un : utiliser directement le zip de windows 10 (clic droit/envoyer vers dossier compressé) pour faire vos archives, et non pas winzip ou winrar...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More