Jump to content

Recommended Posts

Bonjour,

dans le tableau de bord, onglet préférence, quelque soit le choix, je tombe sur une page blanche avec le message d'erreur HTTP ERROR 500.

La question du jour: est ce que quelqu'un pourrait me venir en aide pour m'expliquer comment corriger le message d'erreur identifié,

Erreur fatale: Echec de la désérialisation du schéma de configuration, sha1 du fichier était da39a3ee5e6b4b0d3255bfef95601890afd80709 dans /.........../..........www/tools/htmlpurifier/HTMLPurifier.standalone.php à la ligne 2702

Cette erreur est arrivé suite à l’enregistrement d'un choix dans les préférences.

J'ai identifié la ligne en question,(en gras ci-dessous) mais je ne trouve pas ce qui cloche;

 

    * @return HTMLPurifier_ConfigSchema

     */

    public static function makeFromSerial()

    {

        $contents = file_get_contents(HTMLPURIFIER_PREFIX . '/HTMLPurifier/ConfigSchema/schema.ser');

        $r = unserialize($contents);

        if (!$r) {

            $hash = sha1($contents);

            trigger_error("Unserialization of configuration schema failed, sha1 of file was $hash", E_USER_ERROR);

        }

        return $r;

    }

 

    /**

     * Retrieves an instance of the application-wide configuration definition.

     * @param HTMLPurifier_ConfigSchema $prototype

     * @return HTMLPurifier_ConfigSchema

     */

    public static function instance($prototype = null)

    {

        if ($prototype !== null) {

            HTMLPurifier_ConfigSchema::$singleton = $prototype;

        } elseif (HTMLPurifier_ConfigSchema::$singleton === null || $prototype === true) {

            HTMLPurifier_ConfigSchema::$singleton = HTMLPurifier_ConfigSchema::makeFromSerial();

        }

        return HTMLPurifier_ConfigSchema::$singleton;

 

Personne pour m'aider??

 

Merci d'avance

Cordialement.

Denis

Edited by ecoloflamme
Complément info (see edit history)

Share this post


Link to post
Share on other sites

bonjour,

j'ai ce problème d erreur, pouvez vous m'aider svp si le votre a été résolu. comment faire ? merci d'avance

Share this post


Link to post
Share on other sites

Bonjour, 

J'ai été dépanné par Cyril de  https://www.team-ever.com/

contact@team-ever.com

Bon courage 

Share this post


Link to post
Share on other sites
Just now, ecoloflamme said:

Bonjour, 

J'ai été dépanné par Cyril de  https://www.team-ever.com/

contact@team-ever.com

Bon courage 

Merci beaucoup de votre réponse et du coup je me suis débrouillée et j'ai trouvé la solution. tout est ok au moins de ce côté là !!!

bonne soirée

Share this post


Link to post
Share on other sites
il y a une heure, sandrine l a dit :

j'ai trouvé la solution

Et quelle est elle ? histoire d'aider les autres utilisateurs.

Share this post


Link to post
Share on other sites
29 minutes ago, Mediacom87 said:

Et quelle est elle ? histoire d'aider les autres utilisateurs.

  j'ai résolu mon problème de page blanche et de message d'erreur en passant par le fichier FTP depuis mon hébergeur et en passant la donnée de 1 à 0. 

 

Share this post


Link to post
Share on other sites

  j'ai résolu mon problème de page blanche et de message d'erreur en passant par le fichier FTP depuis mon hébergeur et en passant la donnée de 1 à 0. Il faut chercher la ligne "PS_use_htmlpurifier"   et remettre à 0. voilà, j espère que cela aidera d autres utilisateurs.

Bonne soirée

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More