Jump to content
Sign in to follow this  
ngocnam

Cho mình hỏi lỗi này sửa thế nào vậy các bạn?

Recommended Posts

Mình vừa download bản 1.0final về và cài trên local host. Tuy nhiên khi chạy http://localhost/shop/install/index.php để cài đặt thì nó hiện lên thông báo này:
Notice: Undefined index: REQUEST_URI in E:\SERVER\web_php\shop\install\index.php on line 8

Notice: Undefined index: REQUEST_URI in E:\SERVER\web_php\shop\install\index.php on line 8

Notice: Undefined index: REQUEST_URI in E:\SERVER\web_php\shop\install\index.php on line 8

Notice: Undefined index: REQUEST_URI in E:\SERVER\web_php\shop\install\index.php on line 8

Notice: Undefined index: REQUEST_URI in E:\SERVER\web_php\shop\install\index.php on line 8
This application need you to activate Javascript to correctly work.

. Mình không thể qua bước 2 được. Bạn nào biết lỗi do đâu xin chỉ giáo.

Share this post


Link to post
Share on other sites

This application need you to activate Javascript to correctly work.

Có lẽ chưa cài Java?

Mà sao đường dẫn lạ nhỉ, ko phải là htdocs sao?
BẠn có thể cho biết cấu hình webserver và PHP dc ko?

Share this post


Link to post
Share on other sites

This application need you to activate Javascript to correctly work.

Có lẽ chưa cài Java?

Mà sao đường dẫn lạ nhỉ, ko phải là htdocs sao?
BẠn có thể cho biết cấu hình webserver và PHP dc ko?


Chưa cài java là sao hả bạn? Code này là php mà.
Mình dùng php 5.0, mysql 5.0 và server IIS.
Mình tạo môt thư mục có tên là SHOP, sau đó chép toàn bộ các code mình download trên website vào trực tiếp thư mục này.
Tạo một database tên shop trên mysql. Cấu hình server IIS để thực thi(Right Click vào Default Web Site->New->Virtual Derectory->Đặt tên là shop->Trỏ đến thư mục shop->finish)
Mình không hiểu ý bạn hỏi cấu hình webserver là bạn cần hỏi gì nên mình miêu tả như thế. có gì không hiểu bạn cứ hỏi lại mình nha.
Mình vẫn cài nukeviet, joomla, các code khác và bản thân website mình đang lập trình vẫn chạy tốt trên localhost của mình nên mình không nghỉ là việc cài đặt server của mình có vấn đề.
Cảm ơn bạn đã quan tâm và mong sớm nhận được hồi âm của ban!

Share this post


Link to post
Share on other sites

Mình cũng ko rành lỗi này vì ko xài IIS nên ko bị.

This application need you to activate Javascript to correctly work.


Bạn thử cài XAMPP (apache) thay cho IIS xem còn bị ko?

Share this post


Link to post
Share on other sites

1. Server của bạn phải đáp ứng các yêu cầu hệ thống sau:

   *  Linux, Unix, or Windows
   * Apache Web server
   * PHP 5.0 or later. (You may have to activate PHP 5 on your hosting service.)
   * MySQL 4.1.14 or later


Vì PS chỉ hỗ trợ Apache WEb server nên biến $_SERVER['REQUEST_URI'] là không xác định ( undefined) do bạn đã tạo một new virtual directory với 1 alias không nằm trong documentRoot wwwroot ( mình nghĩ vậy).

2. Với Apache, documentRoot không nhất thiết phải là "/xampp/htdocs".
Bạn có thể thay đổi nó trong file \xampp\apache\conf\httpd.conf
Tìm tới dòng sau:

DocumentRoot "/xampp/htdocs"



3. Trong Apache, Bạn cũng có thể tạo 1 ScriptAlias như sau

ScriptAlias /cgi-bin/ "/xampp/cgi-bin/"



#
# "/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#

   AllowOverride None
   Options None
   Order allow,deny
   Allow from all


Giải pháp đưa ra là bạn phải chuyển sang dùng Apache + PHP5 + MySQL5 ( + Linux)
Nếu bạn chọn IIS thì nên dùng IIS + ASP + SQL Server + (Windows)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More