Jump to content
Sign in to follow this  
hvdk

pb de login sur la partie admin de la boutique

Recommended Posts

Bonjour,

Je désire tester la mise en production de ma boutique. (v.1.0 de prestashop)
Pour la partie ftp, pas de soucis.
Pour la partie data, j'exporte ma base locale pour l'importer sur la base de prod.
Malheureusement, le login et password pour ../maboutique/admin.. ne fonctionne pas sur ma base de prod.
J'ai chercher mais....

Si je peux avoir une aide. (g vérifié les data, fichier sous /config/ etc.)

Share this post


Link to post
Share on other sites

Petit truc tout bête : Est-ce que tu as donné le même nom aux dossier local et distant.
J'ai eu ce problème en faisant un upgrade, je n'ai pas donné le même nom a mon dossier upgradé, resultat impossible de me logguer à la partie admin, dès que j'ai eu redonné le bon nom je pouvais a nouveau me logguer correctement.

Share this post


Link to post
Share on other sites

Verifie peut être cette ligne dans le fichier config/setting.inc qu'elle soit la même que dans ta précédente installation

define('_COOKIE_KEY_', 'ton cookie key');

Share this post


Link to post
Share on other sites

@astragor : c'est peut-être parce que tu avais copié aussi ta boutique déjà installée en local sur le serveur, dans ce cas le fichier conf/settings.inc.php n'avait pas une bonne valeur pour PS_BASE_URI qui indique le dossier d'installation.

@cans38 : j'allais le dire ;-)

Share this post


Link to post
Share on other sites

cans38 : le cookie key ne fonctionne pas (g remplacé)

astragor : g le bon chemin dans PS_Base_URI

Share this post


Link to post
Share on other sites

j'ai un soucis du même genre...
Le front office est ok mais la page de login à l'admin me redirige vers... la page de login à l'admin.
Si je mets un mauvais login ou mot de passe, j'ai bien l'affichage d'une erreur.

ça vous inspire quelque chose ?

Share this post


Link to post
Share on other sites

KImweb,

Verifie peut être dans le fichier config/setting.inc que le cookie key soit la même que dans ta précédente installation

quelle manip as tu fait (import de base, transfert de l'appli locale vers le web ou réciproque ?)

Pour moi, je ne modifiais pas le bon fichier setting.inc.... !!

mon pb est résolu.

Share this post


Link to post
Share on other sites

merci hvdk de ta réponse.

En fait j'ai mis en place la boutique sur un serveur de test (tout fonctionne) et c'est en passant sur le serveur définitif que j'ai ce problème de connexion à l'admin.
J'ai donc effectivement :
- transféré les fichiers via FTP
- importé la base de données
- modifié le fichier setting.inc.php en changeant les paramètres de connexion et le chemin PS_BASE_URI

Peut-être une info qui pourrait donner une piste : je n'ai pour l'instant que le serveur, sans nom de domaine. J'accède donc au site par nsXXXXXX.ovh.net/~login/

Toutes vos idées sont les bienvenues

Share this post


Link to post
Share on other sites

avez vous les mêmes nom de dossiers apres ftp ?
verifier le htacces

Share this post


Link to post
Share on other sites

Par hasard la casse est elle bien la même pour les dossiers d'admin et l'url ? Windows et Linux ne traite pas de la même façon la casse.

Share this post


Link to post
Share on other sites

a priori je ne vois pas de problème de casse ni de htaccess.

je ne sais pas trop quoi essayer...

Share this post


Link to post
Share on other sites

Une info supplémentaire : si je m'identifie avec un compte client, côté front, je reste sur la page authentication.php?back=my-account.php
un peu le même problème que pour l'admin donc.

Share this post


Link to post
Share on other sites

Oui oui, la boutique fonctionnait sur mon serveur de test, également chez OVH (donc normalement c'est le même htaccess)

Share this post


Link to post
Share on other sites

tu n'as pas changer les permissions sur les dossiers sous ovh ?

Share this post


Link to post
Share on other sites

non... je n'ai rien fait d'autre que l'upload de la boutique, l'import de la bdd et la modification du fichier setting.inc.php

Share this post


Link to post
Share on other sites

Si ta base était vide, si tu as bien importé tes data, il n'y a que le fichier setting.inc qui peut poser pb.

Share this post


Link to post
Share on other sites

une histoire de cookie peut-être ?
J'ai laissé COOKIE_KEY et COOKIE_IV comme sur mon 1er serveur...

Share this post


Link to post
Share on other sites

TON PREMIER SERVEUR EST SOUS OVH OU EN LOCAL ?

si tu étais en local, alors tu dois configurer ton htaccess pour php5

Pour ma part, à force de chercher, je ne modifiais pas le bon setting.inc (je sais que c idiot, mais c'est vrai.. hélas..)

Share this post


Link to post
Share on other sites

mon 1er serveur est chez OVH.

il y a plusieurs setting.inc ?
J'ai modifié celui qui se trouve dans le dossier config, à la racine de la boutique.

Je me demande si je ne vais pas refaire une installation classique sur le nouveau serveur...

Share this post


Link to post
Share on other sites

Bon, j'ai donc finalement tenté une nouvelle installation de prestashop sur le nouveau serveur.

Le problème est le même, pas de connexion possible.

Est-ce que la Presta Team aurait une idée ?

Pensez-vous qu'il est nécessaire d'avoir un nom de domaine pour que cela fonctionne ? (ce qui ne m'arrangerait pas car je travaille sur une refonte de site actuellement hébergé sur un serveur Windows et que j'aurais voulu transférer le NDD au dernier moment, une fois la nouvelle boutique prête)

Share this post


Link to post
Share on other sites

Il reste actuellement un bug connu sur le cryptage du cookie en blowfish (le decryptage en fait surtout ^^).
Nous sommes conscient de ce problème et nous essayons de le résoudre activement, mais ce genre d'algo dépend de paramètres aussi improbables que la marque du processeur (AMD et Intel n'arrondissent pas les float de la même façon après beaucoup de chiffres après la virgule, sisi !) ou son type (32bits et 64bits, man pack/unpack).

Pour continuer à travailler malgré ce problème, vous pouvez commenter le cryptage en remplacant dans le fichier classes/Cookie.php (v1.0.0.8) :
Ligne 195 : $content = $_COOKIE[$this->_name];
Ligne 229 : $content = urldecode($cookie);

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More