Jump to content
smolapbz

Certyfikat SSL

Recommended Posts

Witam, wykupiłem certyfikat ssl, wszystko w miarę działa, tylko jest jakiś błąd z szyfrowaniem obrazków.

Pisałem do dostawcy certyfikatu o otrzymałem taką odpowiedz:
„Taki komunikat może oznaczać, że linki do obrazów, i innych elementów strony używają połączenia http zamiast https. „

„pozmieniać wszystkie odwołania w kodzie, często wystarczy zmienić jeden rekord w bazie danych.”


W jaki sposób mogę to naprawić ?

Share this post


Link to post
Share on other sites

Wstawione w stronę obrazki zostały wstawione nie za pośrednictwem poprawnego kodu, tylko adresy url tych obrazków zostały wstawione (najprawdopodobniej) ręcznie, gdzie podany był adres z http:// zamiast https://

Nie ma uniwersalnego rozwiązania, nie wiadomo o jakie obrazki chodzi i za pośrednictwem czego zostały dodane (np jakiś moduł / czy ręczna modyfikacja plików szablonu).

 

zatem:

- identyfikujesz obrazy dodane za pomocą url z http://
- sprawdzasz w jaki sposób zostały dodane do szablonu (moduł / modyfikacja plików tpl)
- wzależności od sposobu dodania tych obrazków modyfikujesz:
-- moduł (jego pliki tpl),
-- moduł (np. wstawiony kod jeżeli moduł oferuje dodawanie własnych tresci),
-- pliki tpl szablonu

Share this post


Link to post
Share on other sites

Nie mam zielonego pojęcia jak to zrobić, nie ja instalowałem sklep i nie znam się na tym. jedynie instalowałem gotowe moduły

Share this post


Link to post
Share on other sites

W konsoli przeglądarki powinieneś zobaczyć które elementy nie ładują się z https, później masz już z górki bo po umiejscowieniu elementu możesz określić co za niego odpowiada.

Share this post


Link to post
Share on other sites

Tak, masz tam 2 żółte pola z wykrzyknikami które mówią o tym co jest ładowane niepoprawnie.

Share this post


Link to post
Share on other sites

A jak należy zmienić tą grafikę żeby nie pojawiał się już ten błąd ?

Share this post


Link to post
Share on other sites

Najprawdopodobniej masz linki wpisane w stylach jako http, wystarczy zmienić na https i będzie dobrze.

 

Najpierw:

zaawansowane -> wydajność -> Inteligentna pamięć podręczna dla CSS ustaw na NIE, wtedy w konsoli zobaczysz poprawne pliki stylów z ich adresami i linią w arkuszu.

Potem już tylko odszukać odpowiednie pliki stylów i zmienić http na https

screen.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More