Jump to content

Recommended Posts

bonjour
mon url :
http://www.unesourisetmoi.info
j'ai mis le script dans:
http://www.unesourisetmoi.info/shop/ (version : prestashop_1.0)
et si je lance :
http://www.unesourisetmoi.info/shop/install/
j'ai cette erreur :

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/39/d141584484/htdocs/shop/install/classes/LanguagesManager.php on line 7

hébergeur : 1&1;pour un test de débutant, c'est pas vraiment le top !
merci pour votre aide
@+
b g

Share this post


Link to post
Share on other sites

merci pour la réponse
j'ai déjà un fichier .htaccess :

AddCharset ISO-8859-1 .xml
AddType text/xml .xml


AddCharset ISO-8859-1 .xslt
AddType application/xml .xslt


je ne sais pas si je peux y toucher ... si je mets ceci :

AddCharset ISO-8859-1 .xml
AddType text/xml .xml


AddCharset ISO-8859-1 .xslt
AddType application/xml .xslt

AddType x-mapp-php5 .php 
RewriteBase / 


cela irait-il ?
@+
b g

Share this post


Link to post
Share on other sites

cela irait-il ?


Il faut essayer... Ca ne risque pas grand chose.

Concernant le :
RewriteBase /
ce ne sera bon que si ta boutique est à la racine de ton serveur. Si tu l'a mises dans un dossier /shop/, alors il devra être :
RewriteBase /shop/

Share this post


Link to post
Share on other sites

merci c'est du rapide et cela à l'air de fonctionner ... je teste !
j'ai ceci :
Ouverture des URL externes autorisée (est sur NON)
important ou pas ? à quoi sert cette option ?
merci
@+
b g

Share this post


Link to post
Share on other sites

C'est fait ! la solution était la bonne et pour un "install" chapeau bas, c'est le top !
j'ai ceci :

Bienvenue sur votre panneau d'administration !
Merci d'utiliser les onglets du menu afin de naviguer dans votre panneau d'administration !
Update check unavailable
To get Prestashop update warnings, you need to activate the allow_url_fopen directive in your php.ini conf file. [plus d'infos]
Si vous ne savez pas comment procéder, merci de contacter l'administrateur de votre hébergeur !

là je coince ... comment faire ?
merci
@+
b g

Share this post


Link to post
Share on other sites

Gros problème !!!
php5 est bien activé certes, mais des scripts sur mon hébergement semblent ne plus fonctionner maintenant ... là ça me pose de gros problèmes !
comment revenir en arrière ? et remettre le php par defaut d'origine ?
Ensuite s'il le faut vraiment je ferai de nouveau l'install sur un autre domaine
merci de me dépanner, là ça urge ...
@+
b g

Share this post


Link to post
Share on other sites

j'ai remis le fichier d'origine à la racine du site et un autre dans le répertoire shop avec toutes les indications données ici, mais ça ne change rien ...
@+
b g

Share this post


Link to post
Share on other sites

j'ai mis un fichier phpinfo.php
et voilà ce que cela me donne :

Linux infong 2.4 #1 SMP Tue Dec 18 22:34:10 UTC 2007 i686 GNU/Linux
Build Date     May 19 2008 09:17:19
Configure Command     '../configure' '--program-suffix=5' '--with-pear=/usr/lib/php5' '--with-config-file-path=/usr/lib/php5' '--with-mysqli' '--with-kerberos' '--with-imap-ssl' '--enable-soap' '--with-xsl' '--enable-mbstring=all' '--with-curl' '--with-mcrypt' '--with-gd' '--with-pdo-mysql' '--with-freetype-dir' '--with-libxml-dir' '--with-mysql' '--with-zlib' '--enable-debug=no' '--enable-safe-mode=no' '--enable-discard-path=no' '--with-png-dir' '--enable-track-vars' '--with-db' '--with-gdbm' '--enable-force-cgi-redirect' '--with-ttf' '--enable-ftp' '--enable-dbase' '--enable-memory-limit' '--enable-calendar' '--enable-wddx' '--with-jpeg-dir=/usr/src/kundenserver/jpeg-6b' '--enable-bcmath' '--enable-gd-imgstrttf' '--enable-shmop' '--enable-mhash' '--with-mhash' '--with-openssl' '--enable-xslt' '--with-xslt-sablot' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--with-imap' '--with-iconv' '--with-bz2' '--with-gettext' '--enable-exif' '--with-idn' '--with-sqlite' '--enable-sqlite-utf8' '--enable-zip'
Server API     CGI
Virtual Directory Support     disabled
Configuration File (php.ini) Path     /usr/lib/php5 


là je n'y connais rien !!! je ne sais pas si c'est la config par défaut ni comment y revenir ???
@+
b g

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More