Jump to content

[PS 1.7.2.4]Impossible d'ajouter un produit au panier


Marc
 Share

Recommended Posts

Bonjour,

Un client m'a remonté hier qu'il est impossible d'ajouter un produit au panier.Je viens de tester et effectivement, le bouton "Ajouter au panier" ouvre bien la popup "Produit ajouté au panier avec succès" ,mais on peut voir également dans cette même pop up :

Citation

 

Il y a 0 article dans votre panier.

Total produits : 0,00 €

Frais de port : gratuit

Total : 0,00 € (HT)

 

 

Je ne comprends pas ce qui ne fonctionne pas... l'action d'ajout au panier semble se déclencher, mais il n'ajoute rien!

Je tente de trouver une solution dans mon back office,par exemple vider le cache smarty. Mais ça ne change rien.

Voici l'url de mon site : 1001manchettes.fr

Merci de votre aide

 

Share this post


Link to post
Share on other sites

Bonjour

Aucun thème installé ou modifié, pas de mise à jours de module, rien de tout ça :(

J'ai trouvé un autre ticket disant disant que c'est car le bouton appelle une page en HTTPS, alors que mon site est en HTTP. Il faudrait que j'active le SSL,je suis en train de voir avec mon hébergeur.

 

https://www.prestashop.com/forums/topic/593458-resolu-17-impossible-dajouter-au-panier/?tab=comments#comment-2503500

Edited by Marc (see edit history)

Share this post


Link to post
Share on other sites

  • 2 years later...
  • 3 weeks later...

Bonjour,

 

J'ai soucis similaire et mon site est bien en SSL. j'ai vidé le cache. Il y a eu des modules mis à jours mais comment trouver l'historique des mises à jours des modules ?

 

Par avance merci pour votre aide et bonne journée.

 

Eric

Share this post


Link to post
Share on other sites

  • 3 weeks later...

Bonjour,

 

J'ai exactement le même soucis, la popup "Produit ajouté au panier avec succès"  s'ouvre bien mais aucun produit dedans.

J'ai beaucoup  de mal à comprendre d'où cela peut venir car ce soucis se produit de façon aléatoire.

 

prestashop 1.7.6

Je suis bien en ssl

j'ai vider le cache

 

 

Par avance merci pour votre aide

 

 

Share this post


Link to post
Share on other sites

Bonjour, pour moi le problème ne se pause plus. Sur une mise à jour j'ai perdu ma boutique. J'ai décidé de passer par un prestataire pour récupérer ce qui est sauvable et limiter la casse.

 

Bonne chance !

Share this post


Link to post
Share on other sites

  • 9 months later...

Bonjour, j'avais le même problème et de mon côté c'était dû à un module et mes cookies. 
Essayez de réduire la durée de vie de vos Cookies. Si vous utilisez le module (produits déjà vus) ce dernier peut causer ce problème (il rallonge et parfois fait dépasser la longueur maxi du cookie).
Vous pouvez forcer la génération d'un nouveau cookie (dans classes/Cookie.php via un override).

Share this post


Link to post
Share on other sites

6 hours ago, Ric34 said:

Bonjour, j'avais le même problème et de mon côté c'était dû à un module et mes cookies. 
Essayez de réduire la durée de vie de vos Cookies. Si vous utilisez le module (produits déjà vus) ce dernier peut causer ce problème (il rallonge et parfois fait dépasser la longueur maxi du cookie).
Vous pouvez forcer la génération d'un nouveau cookie (dans classes/Cookie.php via un override).

le module produit déjà vu posait problèmes car le code s'executait avant le chargement des JS

pkoi le temps de vide des cookies est un soucis ? 

merci

Share this post


Link to post
Share on other sites

15 hours ago, abouzouzou said:

le module produit déjà vu posait problèmes car le code s'executait avant le chargement des JS

pkoi le temps de vide des cookies est un soucis ? 

merci

Bonjour, l'ajout au panier d'un produit rallonge la chaîne du cookie, si elle est à son max, le produit ne peut être ajouté... Réduire la durée de vie du cookie permet renouveler ces derniers plus régulièrement...

Share this post


Link to post
Share on other sites

j'ai mis 360 je sais plus si c secondes ou minutes....

 

czar j'ai un seul client qui a le soucis

 

 

On 7/20/2021 at 5:06 PM, Ric34 said:

Bonjour, j'avais le même problème et de mon côté c'était dû à un module et mes cookies. 
Essayez de réduire la durée de vie de vos Cookies. Si vous utilisez le module (produits déjà vus) ce dernier peut causer ce problème (il rallonge et parfois fait dépasser la longueur maxi du cookie).
Vous pouvez forcer la génération d'un nouveau cookie (dans classes/Cookie.php via un override).

le module produit déjà vu posait problèmes car le code s'executait avant le chargement des JS

pkoi le temps de vide des cookies est un soucis ? 

merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More