Jump to content

Update from to Error MySql 5.7 required?


Recommended Posts

Hi, I installed one week ago 1.7.3 and made a fresh shop. Now I wanted to update to but getting always an error and only a rollback is possible. 

Updating database schema...,Executing: ALTER TABLE sps_bsf_supercheckout_analytics DROP FOREIGN KEY sps_bsf_supercheckout_analytics_ibfk_1,, , [Doctrine\DBAL\DBALException] , Unknown database type bit requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it. , ,,prestashop:schema:update-without-foreign [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-s|--shell] [--process-isolation] [-e|--env ENV] [--no-debug] [--id_shop [ID_SHOP]] [--id_shop_group [ID_SHOP_GROUP]] [--] ,,


and the message

Error upgrading doctrine schema

I know this one table is a module one page checkout, but I even deleted it and uninstalled the plugin, don't need it anymore. Nothing. I found a solution here with PS Cleaner, made it also, but still the same. 


A friend told me now, that the SQL squery BIT is only supported in MySQL 5.7 and I got 5.6. Do I need to update, will the error be than gone or any other help. 


Link to comment
Share on other sites

delted the plugin and restarted the php module and now I get only this message


Updating database schema...,, , [Doctrine\DBAL\DBALException] , Unknown database type bit requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it. , ,,prestashop:schema:update-without-foreign [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-s|--shell] [--process-isolation] [-e|--env ENV] [--no-debug] [--id_shop [ID_SHOP]] [--id_shop_group [ID_SHOP_GROUP]] [--]  ,,


so withouth the module. Something want to update but request a BIT????? and this is I think only possible in mysql 5.7

Link to comment
Share on other sites

  • 2 weeks later...

still the same with, this pisses me really of. Installed a complete new version of Prestashop 1.7.3 on my system, added now 480 products and I can't update it. For now, ok, but what will be in one or two months when we got further versions which fix major problems and I can't install it. Looks like some other users have the problem too. 


Here is the screenshot of the newest update which also doesn't work. 

Bildschirmfoto 2018-05-04 um 10.24.07 AM.png

Link to comment
Share on other sites

i reviewed both PS v1.7.3.0 and v1.7.3.1, and a few things

1) The database schema has not changed and are identical between the 2 versions

2) Prestashop does not use bit types

You likely have installed a custom module, or perhaps added a custom table or column to an existing table using the bit column type.  Which means this issue is specific to your store.  You will need to go through your database tables and locate which table has a column with a bit type, and change it to perhaps an int instead.

Alternatively if you need to use bit type, then you should try to perform a google search for the error message, and you might find solutions like the following...


  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Hello Bellini13, 


Thank you for your reply. This is the error that i am having. Do you know how i can fix this problem? 

I tried prestashop cleaner but nothing changed. 

Thank you for your time. 




, , [Doctrine\Common\Annotations\AnnotationException] , [Semantical Error] The annotation "@Doctrine\ORM\Mapping\I" in class PrestaShopBundle\Entity\StockMvt does not exist, or could not be auto-loaded. , ,,prestashop:schema:update-without-foreign [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-s|--shell] [--process-isolation] [-e|--env ENV] [--no-debug] [--id_shop [iD_SHOP]] [--id_shop_group [iD_SHOP_GROUP]] [--] ,,


(added for search engines)



Link to comment
Share on other sites

does anybody uses Prestashop 1.7.3 in real live. Founding every day some new bugs and wished I had used 1.6, which was grounded. Now I got 500 products and can't really go back. Why there isn't a feature to export all products with all files and import them. Than I would go back. 

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...