Jump to content
Max

Webservice problème surcharge (contrôleurs et classes)

Recommended Posts


Bonjour,
Sur une boutique dont je m'occupe, l'API retourne un problème de fonctionnement. La majorité de celle-ci est accessible nomdedomaine.com/api/addresses  et bien d'autres. Seulement lorsque je tente d'accéder à /api/categories et que je spécifie l'ID : api/categories/3/
 

Quote

Erreur d’analyse XML : instruction de traitement XML ou texte pas au début d’une entité externe Emplacement : https://www.nomdedomaine.com/api/categories/3/ Numéro de ligne 2, Colonne 1 :

<?xml version="1.0" encoding="UTF-8"?>

^


 

Idem pour les produits (api/products).
Après avoir effectué quelques tests, le thème et ses modules ne sont pas en cause.
Lorsque je désactive "toutes les surcharges", via la fonction disponible dans "paramètres avancés > performances", le problème n'apparaît plus et il est de-nouveau possible d'accéder à la totalité de l'API.
Quel pourrait-être la source du problème ? Avez-vous déjà rencontré ce type de problème ?
Cordialement,

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More