Jump to content
aurelienb

Formulaire de contact V 1.7.3.1

Recommended Posts

Bonjour à tous,

J'ai effectué la MAJ vers la version 1.7.3.1 je me suis rendu compte que le formulaire de contact avait disparu (theme classic) ..

Je l'ai donc ré-installé, c'est un module gratuit développé par prestashop.

Une fois en ligne il ne fonctionne plus, voici l'erreur (capture d'écran).

une idée ?

merci d'avance,

Capture d’écran 2018-04-17 à 17.29.28.png

Share this post


Link to post
Share on other sites

Bonjour,

dans un premier temps activez le mode debug de votre boutique puis regardez dans la console de votre navigateur les erreurs possibles puis prenez l'habitude de ne jamais utiliser les termes génériques comme Test pour effectuer vos test ces textes peuvent être bloqués par sécurité puisque se sont de base des choses fausses.

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

Désolé de ne pas avoir informé, j'ai trouvé la solution.

il faut remplacer le ficher contactform.php par celui de la version 1.7.3

et ca fonctionne. 

ps: les mots test c'était juste pour la photo (pas envie de balancer mon email à tout le monde!)

Edited by aurelienb (see edit history)

Share this post


Link to post
Share on other sites

image.png.7b43b5de8b169d42a9ed3d81de641afb.png

Bonsoir,

meme probleme pour moi je trouve pas de solution

Qui peut m'aider??

Share this post


Link to post
Share on other sites

Désolé mais en version 1.7 (et bien avant d'ailleurs), il n'existe plus normalement de fichier contactform.php

Le dispatcher renvoi sur controllers/front/ContactFormController.php en 1.6 et il s'agit bien d'un module "Formulaire de contact" en 1.7 (modules/contactform)

Là, il semble que vous ayez des mélanges de version +/- conflictuelles

 

Share this post


Link to post
Share on other sites
On 18/04/2018 at 11:05 AM, aurelienb said:

Bonjour,

Désolé de ne pas avoir informé, j'ai trouvé la solution.

il faut remplacer le ficher contactform.php par celui de la version 1.7.3

et ca fonctionne. 

ps: les mots test c'était juste pour la photo (pas envie de balancer mon email à tout le monde!)

Bonjour,

Je rencontre le même problème que vous . Je suis novice en php, où trouve t on le fichier de la version 1.7.3 dont vous parlez?

merci pour votre aide

FC

Share this post


Link to post
Share on other sites

Bonjour, j'ai rencontré le même problème et j'ai trouvé la solution :

Pour information après les versions 1.7.3.X le module contactform n'est plus (bizarrement) installé et activé par défault. Il faut aller dans MODULES / CATALOGUES DE MODULES, rechercher le module "Formulaire de contact" puis l'installer et le configurer. Sa dernière version est à ce jour la 4.1.1.

Share this post


Link to post
Share on other sites
Le 15/02/2019 à 10:44 PM, rricci34 a dit :

Pour information après les versions 1.7.3.X le module contactform n'est plus (bizarrement) installé et activé par défault. Il faut aller dans MODULES / CATALOGUES DE MODULES, rechercher le module "Formulaire de contact" puis l'installer et le configurer. Sa dernière version est à ce jour la 4.1.1.

Malheureusement introuvable sous 1.7.5.1 😕

Capture d’écran 2019-03-03 à 23.55.28.png

Share this post


Link to post
Share on other sites
il y a 35 minutes, Xtase.fr a dit :

Malheureusement introuvable sous 1.7.5.1 😕

cherchez juste contact mais de toute manière il est installé de base en 1.7.5 et si il est installé il se trouve dans Module Manager et pas dans le catalogue.

Share this post


Link to post
Share on other sites
il y a 17 minutes, Mediacom87 a dit :

il est installé il se trouve dans Module Manager

Bien vu ! Merci 😊 

Share this post


Link to post
Share on other sites

Bonjour, 

J'ai également un problème avec le formulaire de contact. Le module est bien installé et configuré mais comment el faire remonter sur une page CMS ? En bref, comment le faire accessible en front ?

cordialement, 

Share this post


Link to post
Share on other sites
On 4/5/2019 at 3:37 PM, Adeline said:

J'ai également un problème avec le formulaire de contact. Le module est bien installé et configuré mais comment el faire remonter sur une page CMS ? En bref, comment le faire accessible en front ?

Dans ce cas vous n'avez aucun problème, vous essayez de faire quelque chose qui n'est pas prévu nativement.

Donc vous devriez plutôt créer un topic "Comment ajouter le formulaire de contact sur une page CMS ?".

A priori comme le module intègre l'interface Widget ça doit être la solution la plus simple

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/4/2019 at 12:32 AM, Mediacom87 said:

cherchez juste contact mais de toute manière il est installé de base en 1.7.5 et si il est installé il se trouve dans Module Manager et pas dans le catalogue.

Bonjour,

Désolé mais je suis en 1.7.5.2 et le module Formulaire de contact et le module Créer un compte (formulaire de création d'un compte Client) ne se trouve pas Module Manager...pouvez-vous m'aider à les installer/trouver ? Merci

Edited by Nico741 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

Je  me greffe sur votre sujet car j'ai le même problème.

Mon formulaire de contact fonctionne pas .

J'ai installé un module de demande de devis après avoir constater le dysfonctionnement du module de contact.

Et lui il fonctionne bien.

Je n'arrive pas à comprendre ou cela bloque malgré le debug mode?

Avez vous une idée  sur le sujet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More