Jump to content

[SOLVED] How to remove "Shop powered by Prestashop" in Facebook link?


Recommended Posts

OK, I thought I edited all files where the PrestaShop power is mentioned but it appears I missed some. As much as I love PrestaShop, I'd like to remove that from Facebook links (for example, when I post my website link on the FB wall). Where is that sneaky file that I should edit?
Thanks!

Share this post


Link to post
Share on other sites

  • 1 month later...

Hi Rocky,

I followed your suggestions but I still can't get rid of the "Powered by Prestashop" away from the Facebook link's and also I would like to have only one single specific thumbnail showing instead of the customer choice of 13 that I can see in facebook. The first choice thumnail choice is totally wrong. I wish to make the advertising.jpg the prefered one.

My site:
www.dans4ever.se

I tested to edit my header.tpl with some other suggestions found in

http://gnorml.com/blog/facebook-link-thumbnails/
http://developers.facebook.com/docs/share

But still no score..
confused to from where the Power by Prestashop is beeing extracted to facebook.

Thanks in advance.

Share this post


Link to post
Share on other sites

  • 1 month later...

I haven't done anything else except Rocky's suggestion:
Go to Preferences > Meta-Tags, edit the “index” page, then change the “Meta description” field.

It worked right away. I don't know why you guys are having this problem.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Problem SOLVED

My steps.

1. check the table ps_meta_lang in the database, and delete the duplicated entry ("shop powered by Prestashop"), because when you change the Meta Tags with the tool, Preferences > Meta-Tags, you not delete the old entry.

2. enter this site: http://developers.facebook.com/tools/lint/
and put your url and you can see your new information.

thanks a lot.

  • Like 9
  • Thanks 1

Share this post


Link to post
Share on other sites

  • 3 weeks later...

Hi there,

Where is meta_lang meant to be found?

The following 'tables' I can find are:

CHARACTER_SETS
COLLATIONS
COLLATION_CHARACTER_SET_APPLICABILITY
COLUMNS
COLUMN_PRIVILEGES
KEY_COLUMN_USAGE
PROFILING
ROUTINES
SCHEMATA
SCHEMA_PRIVILEGES
STATISTICS
TABLES
TABLE_CONSTRAINTS
TABLE_PRIVILEGES
TRIGGERS
USER_PRIVILEGES
VIEWS

Matt

Share this post


Link to post
Share on other sites

No, it is not normal. That means you don't have a database. PrestaShop won't work without one. Do you have PrestaShop up and running yet? Are you sure you are looking at the same server you installed PrestaShop?

Share this post


Link to post
Share on other sites

  • 1 month later...
Problem SOLVED

My steps.

1. check the table ps_meta_lang in the database, and delete the duplicated entry ("shop powered by Prestashop"), because when you change the Meta Tags with the tool, Preferences > Meta-Tags, you not delete the old entry.

2. enter this site: http://developers.facebook.com/tools/lint/
and put your url and you can see your new information.

thanks a lot.


i tried as you said but i didnt find anything that says "shop powered by prestashop". what else can i do??????

Share this post


Link to post
Share on other sites

I see. I think that is the page's meta-description. Go to Preferences > Meta-Tags, edit the "index" page, then change the "Meta description" field.


i use p.s 1.3.6
i tried as you said but it doesnt work. my meta description even use very different words and nothing said "shop powered by prestashop". and i also open my database and looked at ps_meta_lang, but it doesnt even say anything like "shop powered by prestashop". what should i do? the module i use to share my website is addthis module. please help me rocky. thank you

Share this post


Link to post
Share on other sites

  • 4 months later...
  • 2 months later...
  • 1 month later...

Hi all

for those of you who are struggling to find the location of the index.php file and how to make the changes try this:

 

1. Click on the Preferences tab

2. Click 'SEO & URLs' subtab

A list of SEO &URLs should appear.

3. Click on the edit button (on the right hand side under the 'Actions' column, & looks like a pencil on paper)

4. Change the Meta-Description to what ever you want

5. Click 'Save'

 

Tested and works on Prestashop version 1.4.5.1

 

Good luck :)

Mike

Share this post


Link to post
Share on other sites

  • 2 months later...
  • 2 months later...
  • 3 months later...
  • 1 month later...

Problem SOLVED

 

My steps.

 

1. check the table ps_meta_lang in the database, and delete the duplicated entry ("shop powered by Prestashop"), because when you change the Meta Tags with the tool, Preferences > Meta-Tags, you not delete the old entry.

 

2. enter this site: http://developers.fa...com/tools/lint/

and put your url and you can see your new information.

 

thanks a lot.

 

Thanks I had the same problem (shop powered by Prestashop) but with your steps It was resolved.

First I delete the duplicate entry in meta_lang and then I went to http://developers.fa...com/tools/lint/ and give my url in (Input URL, Access Token, or Open Graph Action ID )

and then push the button debug.

 

Thanks :rolleyes:

Share this post


Link to post
Share on other sites

I see. I think that is the page's meta-description. Go to Preferences > Meta-Tags, edit the "index" page, then change the "Meta description" field.

 

Hey Rocky Balboa! I just changed it in my ps-store. Run 1.5 RC1

Preferences -> SEO & URLs ->index (edit) -> Change meta-description .. Just this and voila!!

post-354701-0-54816700-1344670979_thumb.jpeg

  • Like 1

Share this post


Link to post
Share on other sites

  • 7 months later...
  • 2 weeks later...
  • 2 months later...
  • 2 weeks later...

Hey All, I have got the same issue in my Linkedin account. I have done the index changes in Preferences-> Seo etc... all fine, then I deleted my web entry in my linkedin. Nothing changed so far, still displaying "shop Powered By Presta shop", have gone to the "phpMyAdmin/index.php?db=information_schema&token" to look for the ps_blablabla but can't find the file... Using presta 1.5.4.1

 

Could you please help? IDon't get that issue in facebook apparently though.

 

Cheers!

Share this post


Link to post
Share on other sites

Hey All, I have got the same issue in my Linkedin account. I have done the index changes in Preferences-> Seo etc... all fine, then I deleted my web entry in my linkedin. Nothing changed so far, still displaying "shop Powered By Presta shop", have gone to the "phpMyAdmin/index.php?db=information_schema&token" to look for the ps_blablabla but can't find the file... Using presta 1.5.4.1

 

Could you please help? IDon't get that issue in facebook apparently though.

 

Cheers!

 

can you please share the url to your website? i will check it

Share this post


Link to post
Share on other sites

  • 3 months later...

Hi,

I change Meta-Tags field (index), but i continue to see "shop powered by prestashop" when i share the link in facebook, someone has another idea that could be?.

 

 

thanks a lot.

I was having the same issue.  But after a while it was fixed.  It seems that it took a while for the change to propagate.  But Rocky on post #4 got it right on.  Thanks!

Share this post


Link to post
Share on other sites

yes that's right, im convinced that this should work.

problems with this are usually related to websites cache, exactly the same as on facebook (where you have to use debugger tool to "refresh" results)

  • Like 1

Share this post


Link to post
Share on other sites

For the line of description showing up wrong on Facebook (e.g. Powered by Prestashop), a quick fix is simply to click on the line of words showing up wrong and Facebook will allow you to edit it. For the wrong image showing up (or you want a custom image), simply hover over the image and upload one of your choice.

Share this post


Link to post
Share on other sites

  • 4 weeks later...

HELP!!!  I was trying to do this, went to preferences, SEO-URLS, INDEX, removed the meta tag and now I cannot get into my website!  This is the error that I am getting.  I cannot get back to change the setting back.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites

HELP!!!  I was trying to do this, went to preferences, SEO-URLS, INDEX, removed the meta tag and now I cannot get into my website!  This is the error that I am getting.  I cannot get back to change the setting back.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Hi Joy, please read the 500 Error blog post in my signature. You probably need to delete your .htaccess from FTP manually. 

Share this post


Link to post
Share on other sites

Hi Benjamin

I read through the post and changed the file from false to true, then attempted to get back into my back office with no success.

Any other ideas?

 

How do I manually change my .htaccess from FTP?  Sorry, but I am new at this so you will probably have to 'dumb down' your answers LOL

Edited by Joy Laney (see edit history)

Share this post


Link to post
Share on other sites

Well, now I am not able to log in to my ftp panel. (It will not accept my password)  I have contacted my hosting provider for help, but that usually takes a while and my website is down.  I do have access to my file manager.  Can I delete this .htaccess file there?  If so, where do I find it?

Share this post


Link to post
Share on other sites

Well, now I am not able to log in to my ftp panel. (It will not accept my password)  I have contacted my hosting provider for help, but that usually takes a while and my website is down.  I do have access to my file manager.  Can I delete this .htaccess file there?  If so, where do I find it?

 

You mean you can't use your ftp client (filezilla etc.)?  In the file manager they should be in the same locations as you would see them in the FTP client.  There are several .htaccess files.

Share this post


Link to post
Share on other sites

  • 3 months later...

I haven't done anything else except Rocky's suggestion:

Go to Preferences > Meta-Tags, edit the “index” page, then change the “Meta description” field.

 

It worked right away. I don't know why you guys are having this problem.

PERFECT!!! Thanks Works Perfect-- it is called URL and SEO  instead of Meta Tags-- This will get you to the MetaTags edit the index page and it works great

Thanks

Share this post


Link to post
Share on other sites

  • 2 months later...

Hi everyone,

 

I'm new to prestashop and FB adverts. I'd like to remove the "By Prestashop 1.5" which is appearing on FaceBook Adverts for my website/products. How do I do this?.

Please see yellow highlighted portion of the attached screenshot.

 

Thanks

 

 

post-792374-0-73754400-1399945010_thumb.png

Share this post


Link to post
Share on other sites

No it's not a module. It just keeps appearing on my paid ads on FB. It shows my website URL on one side (blocked in the attached) then it shows "By Prestashop 1.5" on the other. I could send you a full screenshot directly if you wish.

Share this post


Link to post
Share on other sites

  • 4 months later...
  • 4 weeks later...

Solved it by editing 

 

/public_html/XXX/modules/socialsharing.php

 

$this->name = 'socialsharing';
$this->author = 'Your Name;
$this->tab = 'advertising_marketing';
$this->need_instance = 0;
$this->version = '1.2.7';
$this->bootstrap = true;
$this->_directory = dirname(__FILE__);

Share this post


Link to post
Share on other sites

  • 5 months later...
  • 1 month later...

Problem SOLVED

 

My steps.

 

1. check the table ps_meta_lang in the database, and delete the duplicated entry ("shop powered by Prestashop"), because when you change the Meta Tags with the tool, Preferences > Meta-Tags, you not delete the old entry.

 

2. enter this site: http://developers.facebook.com/tools/lint/

and put your url and you can see your new information.

 

thanks a lot.

This doesn't work with me. The duplicate entry is not there. I use 1.6.0.14 :)

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 6 months later...
  • 2 months later...
  • 3 months later...
  • 1 month later...
  • 9 months later...
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More