Jump to content

[Solved] Problem with enable Friendly URL


redfordnl
 Share

Recommended Posts

Hello friends,

When I enable Friendly URL's in backoffice, some of my modules crash. The modules that are crashing are the WizNav-module, Product Rating module and the Language-Currency module. What happens is that after enabling friendly urls, you see big question marks in those three modules, for the rest everything is workin fine! So no trouble with .htaccess file, pretty sure about that.

What could it be??

30793_xrO8xmJdcl9HXfdb1tWu_t

Share this post


Link to post
Share on other sites

Well the code you would need to change would be in both the tpl and php of a module, although searching through all those modules for the code and modifying it would be very time consuming and I'm very busy atm.

You could try replacing those modules with simillar ones that work with seo friendly url's

Share this post


Link to post
Share on other sites

it wasn't all of that you guys were sayin'. I fixed all three in maybe 5 minutes...

problem was in the php-files and tpl-files.

problem was this..

before change (not working all three)


img src="modules/wiznav/img/aboutus.png"


after change (all three working)


img src="{$base_dir}modules/wiznav/img/aboutus.png"


simples as that just add {$base_dir} for "modules" with friendly url enabled.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More