Jump to content
miccom

Nie działa koszyk :( POMOCY

Recommended Posts

Cześć.
  Zaktualizowałem sklep do najnowszego php 1.6.18, przeniosłem sobie na serwer dedykowany i wszystko ( prawie ) jest jak należy.

Po kliknięciu w przycisk DO KOSZYKA nie ma reakcji, produkt nie dodaje się do koszyka.

 Co mam zmienić w ustawieniach aby pomogło?

CACHE i SMARTY usunąłem.

Proszę o pomoc bo sklep stoi :)

 

Adres sklepu to www.caser.pl

 

Edited by miccom

Share this post


Link to post
Share on other sites

czy istalowale ostatnim czasem jakis nowy modul? to po pierwsze

dwa, jaka wersja PHP.

trzy, najwazniejsze, w pierwszej kolejnsoci. wlacz DEV_MODE powinien wprost pokazac i w jednym i drugim wypadku co go boli

Share this post


Link to post
Share on other sites

Moduły kodowane ioncube loaderem wywalają taki błąd jak działają na niewłaściwej domenie.  Takie moduly ma np.  X13.

Share this post


Link to post
Share on other sites

A gdzie mam właczyć DEV_MODE?

 

A wersja php to: PHP 7.0.28-0 ubuntu 0.16.04.1

Share this post


Link to post
Share on other sites

No mam takie moduły od x13... jak to rozwiązać?

 

Moduły mam wykupione, ale działają na tej samej domenie...

Edited by miccom

Share this post


Link to post
Share on other sites

[PrestaShop] Fatal error in module file :/modules/x13linkrewrite/x13linkrewrite.php:
Class 'x13LinkRewriteModel' not found

Share this post


Link to post
Share on other sites

Może pomoże usunięcie całego katalogu modułu i zainstalowanie go ponownie?

Share this post


Link to post
Share on other sites

Wygląda jakby brakowało jakiegoś pliku z tego modułu, sprawdź czy podczas kopiowania nic nie zostało pominięte.

Share this post


Link to post
Share on other sites

ok, pokazało mi taki błąd:

Duplicate entry '0' for key 'PRIMARY'

 

INSERT INTO `pshd_cart` (`id_shop_group`, `id_shop`, `id_address_delivery`, `id_address_invoice`, `id_carrier`, `id_currency`, `id_customer`, `id_guest`, `id_lang`, `recyclable`, `gift`, `gift_message`, `mobile_theme`, `delivery_option`, `secure_key`, `allow_seperated_package`, `date_add`, `date_upd`) VALUES ('1', '1', '331', '331', '0', '2', '258', '204258', '2', '0', '0', '', '0', '', '', '0', '2018-03-29 13:19:48', '2018-03-29 13:19:48')

 

i taki błąd:

at line 791 in file classes/db/Db.php

 

786.         if ($webservice_call && $errno) {
787.             $dbg = debug_backtrace();
788.             WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
789.         } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) {
790.             if ($sql) {
791.                 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
792.             }
793. 
794.             throw new PrestaShopDatabaseException($this->getMsgError());
795.         }
796.     }

Share this post


Link to post
Share on other sites

Nadpisałem pliki i nic, może usunę faktycznie katalog i dokonam wgrania ponownego ?

Share this post


Link to post
Share on other sites

Teraz mam tak, ze katalog modułów otwiera się, ale są krzaczki a potem lista modułów:)

 

 

 

 

 

Edited by miccom

Share this post


Link to post
Share on other sites

Usunąłem katalogi z modułów x13 i błąd krzaczków zniknął...

Ale koszyk nadal nie działa :(

Share this post


Link to post
Share on other sites

Witam, co do krzaków -> pojawiają się jak nie ma aktywnego ioncube loadera -> wystarczy włączyć go w opcjach PHP na serwerze.

 

Ten moduł działa automatycznie od 5.3 do 7.1, z koszykiem jak napisze Pan do nas maila to pomożemy.

Przy okazji jak jest problem a naszym modułem to proszę na maila od razu pisać :)

Share this post


Link to post
Share on other sites

Wasza odpowiedź:

Witam, brak ioncube loader aktywnego

A jak go uruchomić?

To już typowo administrator serwera powinien wiedzieć

Share this post


Link to post
Share on other sites

Pytał Pan z tego co kojarzę z serwera dedykowanego, i tutaj wszystko zależy od dystrybucji, nie ma niestety 1dnego przycisku jak w większości paneli typu cpanel, directadmin, czy nawet nieszczęsna nazwa.pl

 

Share this post


Link to post
Share on other sites

Do tego jak kliknę na produkty to widzę alert:

 

Notice w linii 70 w pliku /home/public_html/classes/cache/CacheFs.php
[8] unserialize(): Error at offset 1007 of 1189 bytes
 

Share this post


Link to post
Share on other sites

Więc teraz mam tak:

 

root@root:~# php -v
PHP 7.0.28-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.0, Copyright (c) 2002-2018, by ionCube Ltd.
    with Zend OPcache v7.0.28-0ubuntu0.16.04.1, Copyright (c) 1999-2017, by Zend Technologies

Ale krzaki pozostały.

 

Napomknę ze wersję sklepu mam na razie 1.6.1.17

 

I teraz od pana z firmy x13.pl otrzymałem nowe moduły tylko jest pewien problem :)

 

Jeśli kliknę zakładkę MODUŁY to wywala krzaki

W jaki sposób mam zaktualizować moduły z x13.pl ?

Nadpisanie katalogów nie pomaga.

Proszę o pomoc.

Edited by miccom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More