Jump to content

[résolu] Problème avec les Attributs et groupes


Recommended Posts

Bonjour,
Voila j’ai un gros gros problème avec les Attributs et groupes sur la version 1.2.1 de presta shop.

j’ajoute donc mes Attributs et groupes, que cela soit couleur ou taille. Une fois ajouté je valide.. Je met bien le bon nombre de stock à chaque Déclinaisons.

je vais voir mon articles, pendant que la page ce charge j’ai bien le bouton ajouter au panier. Une fois la page fini de le bouton disparait puis j’ai ce message:
Disponibilité : Ce produit n’existe pas dans cette déclinaison. Vous pouvez néanmoins en sélectionner une autre.
0 pièce en stock pièces en stock
Prévenez-moi lorsque le produit est disponible

J’ai ce bug sur IE7 IE8, sur mozzila aucun soucie y a le bouton ajouter au panier, les Déclinaisons son parfaites les images ce change en fonction des couleurs etc….
Theme d’origine a l’instalation presta, quelle que modif perso comme voir les tarif si conpte crée ou pas.

Ps: au début une fois le site instalez les codages modifier… les ajouts d’artcles et Déclinaisons tout fonctioner sans probleme et la y a un gros bug impossible de s’avoir dou cela viens.
Pouvez-vous m’aider svp assez urgent
Cordialement

Share this post


Link to post
Share on other sites

Merci yoya971 ,

Voilà,
Encore plusieurs tests effectués ce matin... remise du thème d'origine sans modification du code, remise du
codage des fichiers touchés, toujours le même bug sur IE, safarie, crome, il n'y a que sur mozzila où tout va
bien.
On vire les déclinaisons tout va bien, on les remet bug de retour... Au chargement de la page, on voit bien
le bouton panier et le stock, mais quand la page est finie de charger, le bouton panier disparait et un message apparaît à la place.
Je suis vraiment dépassé là et je ne sais plus quoi faire help me please ;o)
Merci d'avance pour vos réponses
Cordialement

Share this post


Link to post
Share on other sites

Bonjour,
oui j'ai même tenter de mettre les répertoires js et tools de la version 1.3.1
Car j'ai bien pensé à un probèlme du js. Mais visiblement rien ne change. C'est pourquoi je doute qu'une mise à jour ne change quelque chose.
J'ai aussi déinstaller tout les modules qui ne sont pas d'origine tourjours même problème.
Cordialement

Edit : j'ai 3 sites en tout, deux site sur la version 1.2.1 et un sur la version 1.3.1
Mon premier site sur 1.2.1 fonctionne parfaitement bien aucun soucis avec, idem pour le 1.3.1.
Y a que un des sites qui me pose problème.

Share this post


Link to post
Share on other sites

Oui sur mon serveur dédier OVH

Je c'est pas si je peux vous mettre le liens d'un arcticle pour vous faire voir un exemple en cas un Modo supprimera le liens.

http://www.gworldfrance.fr/ensembles-sexy/314-heartbreak.html

Essayer avec IE et une autre ouverture avec mozzila vous allez vite vous rendre compte du problème. Regarder bien au chargement de la page sur IE

edit : Ah oui une différence entre les deux sites 1.2.1. celui-ci dans le cadre ou y a le choix des couleurs, j'ai une petite flêche verte a coter. Que je n'est pas sur l'autre site. Impossible de s'avoir comment et pourquoi y a cette flêche

Share this post


Link to post
Share on other sites

Bonjour,
encore un test de fait.
J'ai prit un artiles au hasard qui n'avait pas de Déclinaisons ... bouton panier pas de problème visible stock visible...
J'ajoute une Déclinaisons couleur ou parfum etc... le bouton pannier disparait message qui me dit que : ce produit n'est plus en stock avec ces options. Sur mozzila toujours aucun souci....
Donc la je c'est plus quoi faire.

Share this post


Link to post
Share on other sites

Bon Bon Bon ;o)
Donc petit test encore effectué
changemengt de theme, que j'ai prit sur un autre de mes site... le bug disparait, y a toujours un problème avec le stock mais plus avec les déclinaisons.
Mdr pour la petite flêche verte cela vient du theme d'origine... c pourquoi je les pas sur les autre site
Alors si vous avez une petite idée ;o)
Cordialement

Share this post


Link to post
Share on other sites

La je viens de faire une copie du ftp, avec la base de donnée, j'ai supprimer tous les articles; les atribut et les déclinaison... ce la me fait pareil Toujours bug sur IE.
de plus il m'invers les couleur et les tailles Rouge SM il me met Bleue SM etc...
j'ai aussi tenté une réinstale complet de presta et mit la base de donnée toujours le même bug, donc déja je c'est que cela viens de la base enfin un truc qui c mal passer dans les articles car a l'instalation les articles d'origine foncrtion tres bien.

Share this post


Link to post
Share on other sites

Bon apres plusieur teste j'ai enfin trouver !!!!!!

Installe d'un nouveau ftp ! avec prestshop au propre... une fois installer je modifie le settings.inc.php pour allez sur la base de mom site ! et la tout fonctionne... déclinaison photos etc... je pense donc à un fichier détruit ou autre...
je décide alors d'envoyer les modules installez sur le bon ftp... et la op même bug !!
Apres la recherche donc du mondul qui me fesait le bug !!! c'etait le module block libre à cause de ce code:

[removed][removed]
[removed]
new TWTR.Widget({
version: 2,
type: 'profile',
rpp: 1,
interval: 6000,
width: 60,
height: 180,
theme: {
shell: {
background: '#faf7fa',
color: '#b5afb5'
},
tweets: {
background: '#2c346b',
color: '#ffffff',
links: '#91948f'
}
},
features: {
scrollbar: false,
loop: false,
live: false,
hashtags: false,
timestamp: false,
avatars: false,
behavior: 'all'
}
}).render().setUser('gworldfrance').start();
[removed]


2 semaine de galere pour rien !!!!

Share this post


Link to post
Share on other sites

Bonjour,

pas pour rien, vous venez d'apprendre que lorsque l'on cherche un bug on doit souvent reprendre tout à zéro ou désactiver tous les modules rajoutés pour les réactiver une par un et tester si le bug apparait.
C'est fastidieux, mais il n'y a pas d'autre solution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More