Jump to content
tamisa07

Presta wymaga czyszczenia pamięci cache przy ponownym logowaniu, dlaczego?

Recommended Posts

Witam serdecznie,

mam taki problem, gdy mam wyczyszczoną pamięć podręczną cache w przeglądarce mogę zalogować się do panelu prestashop. Jeśli przez dłuższy czas nic nie robię w panelu to po ponownym wejściu muszę podać login i hasło, ale gdy to robię to system przeładowuje mi stronę logowania i jestem cały czas w punkcie logowania do prestashop (nie widzę panelu tylko pole "podaj login" i "hasło") dopiero jak wyczyszczę cache przeglądarki i ponownie podam login i hasło to mnie zaloguje, czemu tak się dzieje? Jest to irytujące bo średnio muszę to robić kilkanaście razy dziennie

Edited by tamisa07 (see edit history)

Share this post


Link to post
Share on other sites

Konsolę w przeglądarce sprawdzałeś ? Foldery na serwerze maja odpowiednie uprawnienia ?

Share this post


Link to post
Share on other sites

Jakie powinny mieć uprawnienia foldery? Była instalacja normalna nic ręcznie nie zmieniałem. Co do przeglądarki to sprawdzałem i dzieje się tak na dwóch różnych komputerach.

Edited by tamisa07 (see edit history)

Share this post


Link to post
Share on other sites

Chciałbym aby tak było ale tak nie jest, usuwam token z adesu https://mojadomena/gkldlkjgfsdf/?controller=AdminLogin&token=75789789943cfb4249bd011cdaa28f6a689&redirect=AdminDashboard

 

zostawiam samo: https://mojadomena/gkldlkjgfsdf

i jest tak samo, ciągle jest widoczny panel logowania, nawet jak uda mi się zalogować po wyczyszczeniu cache to gdy jestem w panelu to potrafi mnie przy przełączaniu między menu nagle znów wylogować (tzn pokazać panel logowania) gdzie mam już wpisane login hasło, i klikam tylko -> ZALOGUJ SIĘ i nic, do póki nie wyczyszczę cache będę mógł tak wciskać guzik ZALOGUJ w nieskończoność, czy to może być związane z serwerem?

Edited by tamisa07 (see edit history)

Share this post


Link to post
Share on other sites

Uprawnienia dla katalogów i plików:

chmod a+w -R config/ 
chmod a+w -R cache/ 
chmod a+w -R log/ 
chmod a+w -R img/ 
chmod a+w -R mails/ 
chmod a+w -R modules/  
chmod a+w -R translations/ 
chmod a+w -R upload/ 
chmod a+w -R download/


chmod a+w -R themes/default-bootstrap/lang/ 
chmod a+w -R themes/default-bootstrap/pdf/lang/ 
chmod a+w -R themes/default-bootstrap/cache/

Nie opowiedziałeś czy występują błędy w konsoli. Pewnie nie sprawdziłeś. To że problem występuje na dwóch różnych stanowiskach nie przybliża nas do rozwiązania problemu a jedynie potwierdza że jest problem. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More