Jump to content
ceriz

Erreur Warning en mode debug aide résolution

Recommended Posts

Bonjour à tous,

 

Depuis ce matin mon site rame (il a tendance a ramer régulièrement)

Je suis sur un serveur dédié :

Server information: Linux #1 SMP Debian 4.9.30-2+deb9u5 (2017-09-19) x86_64

Server software version: nginx/1.13.4

PHP version: 7.1.10-1+0~20170929170818.9+stretch~1.gbp501135

Memory limit: 512M

Max execution time: 0

Version PS / 1.6.1.12

 

Je pense qu'un module ou autres chose a tendance a faire ramer le site;

je suis connecté a mon fournisseur via un module; (peut etre que lui le fait ramer)

j'ai aussi un autre problème; la fonction rechercher de prestashop ne fonctionne plus malgré que tout les produits soit bien intégré;

 

Voici toutes les lignes d'erreur que j'ai rencontré; (j'ai les informations suivantes avec un module "debug" qui affiche les problèmes en FRONT OFFICE ET DANS LE BO)

visible sur le FO

Deprecated: Function mcrypt_decrypt() is deprecated in /var/www/**********/web/classes/Rijndael.php on line 68

Warning: Declaration of OrderOpcController::removeJS($file) should be compatible with FrontControllerCore::removeJS($js_uri, $check_path = true) in /var/www/*********/web/override/controllers/front/OrderOpcController.php on line 0

 

J'ai des erreurs avec les modules suivants (mais ils sont supprimés)

Ebay; amazon; et gshoppingflux (les trois modules sont supprimé du BO)

Visible dans le BO /

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'steasycontent'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'stmultilink'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'stadvancedmenu'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'stadvancedbanner'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'pm_advancedsearch4'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'brandssync'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'massupdates'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'cdiscount'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'metatagsgenerator'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'cronjobs'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'bestkit_opc'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'amazon'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'cron'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'stiosslider'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'gshoppingflux'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'lgseoredirect'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'ebay' 

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Warning à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[2] Illegal string offset 'followup'

Notice à la ligne 1438 du fichier /var/www/*************/web/controllers/admin/AdminModulesController.php
[8] Array to string conversion

Unknown error à la ligne 68 du fichier /var/www/*************/web/classes/Rijndael.php
[8192] Function mcrypt_decrypt() is deprecated
 

Merci a vous pour votre aide

 

 

Edited by ceriz (see edit history)

Share this post


Link to post
Share on other sites

Si vous êtes en Prestashop 1.6 ou inférieur retrogradez votre version php en 5.6 max. pour commencer. Ces versions ne sont pas compatibles php7

Share this post


Link to post
Share on other sites

Je suis en Version PS 1,6,1,12

Vous pensez que pour commencer, il faudrait que je passe soit en PS 1.7 (qui est compatible?)  soit je change ma version de PHP ?

Share this post


Link to post
Share on other sites

Je vous déconseille fortement de passer en 1.7 qui buguée à mort et pas stable du tout (lisez le forum^^)

Pour le reste, je pense avoir été clair:

il y a 8 minutes, Eolia a dit :

Si vous êtes en Prestashop 1.6 ou inférieur retrogradez votre version php en 5.6 max. pour commencer.

 

Share this post


Link to post
Share on other sites

C'est un ami qui héberge le site;

Il est possible pour lui de rétrograder la version PHP juste pour mon site ?

Share this post


Link to post
Share on other sites

Vous ne pensez pas qu'il serait plus judicieux de poser la question à votre ami ?

Je n'héberge pas votre site et je ne connais pas la configuration de son serveur et même en consultant ma boule de cristal je n'ai pas plus d'éléments...

Ah si...

image.png.0e32cacbc38bdcc9d4a3c190cf9fe5a5.png

  • Like 1

Share this post


Link to post
Share on other sites

Je sais bien; c'etait juste pour savoir si c’était possible

je vais lui poser la question mais la il n'est pas dispo.

Share this post


Link to post
Share on other sites

C'est possible sur un serveur configuré comme tel où chaque instance php est distincte et où les différentes versions sont disponibles.

Share this post


Link to post
Share on other sites

:-)

Cet article est tout simplement faux, il reste une cinquantaine de lignes qui buguent.

Mais si vous avez vos réponses, en fait je me demande pourquoi vous posez la question.

 

Share this post


Link to post
Share on other sites

Oh mais Monsieur vous avez peut etre un statuts legend ici mais ne soyez pas comme ça, limite blazé d'etre sur le forum a répondre a des personnes comme moi qui n'y connaissent rien !

donc cet articles et les dizaines d'autres qui existent sont faux ?

Mon site fonctionne bien depuis aout 2017 et depuis quelques semaines il déconne, c'est PEUT ETRE autre chose que le PHP

Edited by ceriz (see edit history)

Share this post


Link to post
Share on other sites

Prestashop aurait dû être compatible à partir de la 1.6.1.15 mais ce n'est toujours pas le cas.

Vous avez un override non conforme

Vos messages d'erreurs sont typiques du mode strict de php7

 

 

Share this post


Link to post
Share on other sites

ça marche, je vais voir ça avec le PHP;

je reviendrais ici pour détailler la résolution du problème,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More