Jump to content

Can't generate product combinations


Recommended Posts

Got a problem on Prestashop with combinations, tested on and 1.7.3. I found related topics, but none of them has an answer yet.

Select an attribute in combination panel and click on "generate" seems to have the same effect of the save button. No error is showing neither in the console, nor in memory tools. A green pop-up on the right-top corner mention "Settings up to date", but nothing happens. No combination line appears on the page. When I save and quit/refresh the page, the "combination" tab is removed, and the product become a "Simple product" (with no combination) again.

Can you help me please ? I Need an urgent way to fix...

Thank you in advance.


EDIT : The big part of my problem come from my child theme. It seems that child themes can't work properly with some themes which have a lot of tricky dependencies (mine was a Postheme). Moreover, a part of the problem came from a override of a theme which ask to replace the "src" folder by his own. I think that the sources they bring are to old to work on my Prestashop version.

Edited by Nox
Resolved (see edit history)
Link to comment
Share on other sites

Ok I tried to copy all files in a new instance, and it worked again for a moment : here's what happened : My prestashop runs on a local Ubuntu server. When I wanted to change a translation for a module (in the right native section), apache started to create a lot of instances, and my browser was totally blocked in an infinite loading. [...]

Edit : wrong path. 

Edited by Nox (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...