Jump to content
Sign in to follow this  
elode

[RÉSOLU]Problème d'installation chez Free

Recommended Posts

Bonjour, :)

J'essaye actuellement d'installer Prestashop chez Free.
J'ai bien mis le fichier .htaccess avec «php 1» dedans, et j'ai ajouté un dossier «sessions»
Tout c'est bien passé pendant l'installation elle-même.
Au moment de me connecter dans l'admin, Prestashop m'a demandé d'effacer le dossier /install pour des raisons de sécurité. Ce que j'ai donc fait. J'ai également renommé le dossier /admin.
J'arrive donc à la page de connection qui me demande mon adresse e-mail et mon mot de passe... que je donne, et alors... rien. Je reste sur cette page de connection. Aucun message d'erreur et impossible d'aller plus loin.

D'autre part, dans la partie publique, je vois bien la boutique en ligne, mais sans aucun style appliqué. Comme s'il ne trouvait pas la feuille de style.
Je vérifie donc en ouvrant le code source de la page... et je trouve ceci: <link href="/install/mthemes/prestashop/css/global.css" rel="stylesheet" type="text/css" media="all" />
Rien ne marche: tous les liens qui partent de ma page d’index pointent sur des pages situées dans le dossier /install…
exemple: quand je clique sur panier, j’obtiens une erreur 404; et dans les propriétés du lien, j’ai: http://zoucaplot.free.fr/install/morder.php

Bizarre, non?

Croyant que qu'il s'était peut-être passé quelque chose pendant l'installation, j'ai tout recommencé depuis le début. (téléchargement, installation, etc.), mais rien n'y fait.

Si quelqu'un avait la gentillesse d'éclairer ma lanterne. il aurait toute ma reconnaissance. :)

Share this post


Link to post
Share on other sites

As-tu bien appliqué les droits CHMOD sur les répertoires dans ton serveur ?

Share this post


Link to post
Share on other sites

Récupère le fichier settings.inc dans le dossier config et verifi si tout te parait correct en l'occurrence la ligne :

define('__PS_BASE_URI__', '/'); => pour une installation à la racine

define('__PS_BASE_URI__', '/boutique/'); => pour une installation dans un répertoire exemple (boutique)

Share this post


Link to post
Share on other sites

Effectivement, dans le fichier settings.inc, j'ai cette ligne:

define('__PS_BASE_URI__', '/install/m');

Pourtant, quand j'ai fait mon transfert ftp, j'ai tout copié à la racine!

Que dois-je faire?

Merci beaucoup pour votre aide :)

Share this post


Link to post
Share on other sites

Tu dois spécifier le répertoire dans lequel tu as installé PS.

Par exemple moi j'ai mis tous les fichiers dans un dossier "prestashop" situé à la racine du site. Donc j'ai :
define('__PS_BASE_URI__', '/prestashop/');

N'oublie pas le '/' après le nom de ton dossier.

Je sais pas si ce sera suffisant. C'est bizarre que tu aies ce problème et tu risques d'en avoir d'autres...

Share this post


Link to post
Share on other sites

Si tu as tout copié à la racine tu dois mettre:

define(’PS_BASE_URI‘, ‘/’);

Share this post


Link to post
Share on other sites

Merci, ça a l'air de marcher :)

Je me demande vraiment ce qui a pu se produire…

Merci à tous pour vos réponses.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More