Jump to content
bortonecesario

[FREE MODULE] FAQ - Frequently asked questions

Recommended Posts

This module allows BO administrators to create a FAQ page with questions and answers

The module for PS 1.6 add a link in the Information Block of the footer and a link in the top menu

The module for PS 1.7 add a link only in the top menu because in PS 1.7 you can add the link in the footer through the "Link Widget" button under Design Configuration button 

I've tested the module with Bootstrap Theme on PS 1.6 and with Classic Thene on PS 1.7

This is my first module so let me know if anything goes wrong during installation.

If you like the module you can send me a donation via paypal to: cesario.bortone@hotmail.it

[updated on 15/01/2019 with ps 1.7 version]

PS 1.6 ------>   faq_ps16.zip

PS 1.7 ------>   faq_ps17.zip

 

 

1.JPG

1.JPG

Cattura.JPG

1.JPG

 

 

Edited by bortonecesario
  • Thanks 1

Share this post


Link to post
Share on other sites
hace 21 horas, bortonecesario dijo:

This module allows BO administrators to create a FAQ page with questions and answers

The module add a link in the Information Block of the footer and a link in the top menu

 

I've tested the module with Bootstrap Theme and PS 1.6

 

This is my first module so let me know if anything goes wrong during installation

 

If you like the module you can send me a donation via paypal to: cesario.bortone@hotmail.it

 

 

faq.zip

4.JPG

 

 

1.JPG

1.JPG

 

I have built a review of your module in Spanish to share it with the Spanish Community of Prestashop

http://victor-rodenas.com/2018/02/20/modulo-preguntas-frecuentes-en-prestashop/

Sorry for my English,

  • Like 1

Share this post


Link to post
Share on other sites
On 2/19/2018 at 4:10 PM, bortonecesario said:

This module allows BO administrators to create a FAQ page with questions and answers

The module add a link in the Information Block of the footer and a link in the top menu

I've tested the module with Bootstrap Theme and PS 1.6

This is my first module so let me know if anything goes wrong during installation

If you like the module you can send me a donation via paypal to: cesario.bortone@hotmail.it

 

faq.zip

 

 

 

 

1.JPG

1.JPG

Cattura.JPG

 

Greetings @bortonecesario.

Thank you very much for this new free module which seems very interesting.

However while I was willing to test it on my test server I am facing a problem on installation, here is the error I am getting:

faq.thumb.jpg.dde76784cb58daa29bb81134f54485f6.jpg

 

Seems that it does not seem to like CURRENT_TIMESTAMP.

I am on PS 1.6.0.14 with php 5.5 and mysql 5.1.

Any ideas or suggestions maybe?

Thank you.

 

Share this post


Link to post
Share on other sites

hi Muad'Dib

you can try with this version.

i've tested it with ps 1.6.0.14 and php 5.6 and works good!

 

i can't replace your error but i think that it don't depends from my module but it's about you environment

 

let me know

 

 

faq.zip

Share this post


Link to post
Share on other sites

Hey @bortonecesario many thanks for your fast reply, much appreciated,

 

I did not have time to test the new attached version in your previous post, however I realize even if I am using a plain copy of default bootstrap theme with only very minor modifications, this theme is not named with defaut name anymore. Do you think that could be the reason why I am having issues?
This being said I don't see why it would cause problems with table creation.
Maybe I need to edit some files myself.

I really see no reasons why your module would not work with my environment when I don't have any issues installing other modules compatible with my version using their own db table or not.

This is the first time I am having an issue like this, and for some reasons it seems to be related to the way the module table is created into the database.

Please let me know if I have to manually edit/copy a few files somewhere in my theme folder, or if you would have some ideas in case that could be the reason.

 

Regards,

 

Share this post


Link to post
Share on other sites

AAt This point i have no idea why you receive the error.

I want help you. It You give me the access to your site i can help you of you want

 

Br

Share this post


Link to post
Share on other sites

Ciao bortonecesario tante grazie per il modulo!

li ho appena instalato, in el back office se che sta, ma in il front office non li vedo, sono in la versione 1.6.0.6 theme Transformer

Grazie mille!

Share this post


Link to post
Share on other sites
1 minute ago, Bonifero said:

Ciao bortonecesario tante grazie per il modulo!

li ho appena instalato, in el back office se che sta, ma in il front office non li vedo, sono in la versione 1.6.0.6 theme Transformer

Grazie mille!

 

if you have cache enabled, try to clear cache of PS and from browser and reload the site. 

If you don't see FAQ in information footer try to enable debug on ps.

 

Share this post


Link to post
Share on other sites

Hello, thank you for your quick answer!
Correct, I have disabled the cache, and I do not see errors in debug :mellow:

Share this post


Link to post
Share on other sites

Yes, attached image, but I can not see it in the front office

FAQ-Module.png

Share this post


Link to post
Share on other sites

Thank you for making the FAQ module available for the PS community.  

Does this module support PS 1.7.X.   AS I've installed it on PS 1.7 and I only get the footer link .  When clicked it gives an error " The page you are looking for was not found."

Appreciate your assistance.

Edited by alsharif

Share this post


Link to post
Share on other sites

 

Hi bortonecesario,

My prestashop version is 1.7.x

i have this error when i try to access to the faq page :

[PrestaShopException]

No template found for faq.tpl
at line 68 in file classes/Smarty/TemplateFinder.php

Share this post


Link to post
Share on other sites
On 12/5/2018 at 7:59 AM, alsharif said:

Thank you for making the FAQ module available for the PS community.  

Does this module support PS 1.7.X.   AS I've installed it on PS 1.7 and I only get the footer link .  When clicked it gives an error " The page you are looking for was not found."

Appreciate your assistance.

 

Hi,

this module has been tested on PS 1.6. I ve tested it on PS 1.7 and didn't work.

i will release the version for Ps 1.7 asap

br

 

 

 

Share this post


Link to post
Share on other sites
On 5/15/2018 at 3:55 PM, bortonecesario said:

 

Hi,

this module has been tested on PS 1.6. I ve tested it on PS 1.7 and didn't work.

i will release the version for Ps 1.7 asap

br

 

 

 

Will you be considering to include Categories (i.e group FAQ by subject) in the upcoming update?

Share this post


Link to post
Share on other sites
On 2/19/2018 at 5:10 PM, bortonecesario said:

This module allows BO administrators to create a FAQ page with questions and answers

The module add a link in the Information Block of the footer and a link in the top menu

I've tested the module with Bootstrap Theme and PS 1.6

This is my first module so let me know if anything goes wrong during installation

If you like the module you can send me a donation via paypal to: cesario.bortone@hotmail.it

 

faq.zip

 

 

 

 

1.JPG

1.JPG

Cattura.JPG

Hi, i have some problem install the module - i got this: The following module(s) could not be installed properly:

  • faq :

.

Please can help to figure what is the problem? My site url: axel-company.ro     I use Prestashop 1.6.1.11

Thanks in advance!

Share this post


Link to post
Share on other sites

hi daniela,

 

i see on your site that the module works good!

i see the link faq in the section informatii and the link work fine

I see also that you have inserted a question

 

let me know if you need others

Share this post


Link to post
Share on other sites

By when do you expect to release an update in support of PrestaShop 1.7.x.  Thanks

Edited by alsharif

Share this post


Link to post
Share on other sites

Great module, @bortonecesario thanks a lot for sharing!
with debug mode activated i have this two notice ... not a problem at all if i disable debug, everything is ok
any suggestion?

notice-after-faq-install&configure.jpg

Share this post


Link to post
Share on other sites

 

@salah3wkom : to fix your front template exception, replace the line 15 of faq/controllers/front/faqpage.php file :

 

$this->setTemplate('faq.tpl');

by :

$this->setTemplate('module:faq/views/templates/front/faq.tpl');

 

As documented here  ;)

Share this post


Link to post
Share on other sites

Hello, a problem with the installation with prest 1.6.1.11, error in the query
Do you have a solution?

Bonjour, un problème à l'installation avec prest 1.6.1.11, erreur dans la requère
avez vous une solution?

Ciao, un problema con l'installazione con perst 1.6.1.11, errore nella query
hai una soluzione?

Share this post


Link to post
Share on other sites
On 05/06/2018 at 12:14 PM, bortonecesario said:

hi daniela,

 

i see on your site that the module works good!

i see the link faq in the section informatii and the link work fine

I see also that you have inserted a question

 

let me know if you need others

Hello,

Problème:

  • Mauvaise requête SQL

Hello, a problem with the installation with prest 1.6.1.11, error in the query
Do you have a solution?

 

 

Share this post


Link to post
Share on other sites
On 16.09.2018 at 10:43 AM, bortonecesario said:

 

Thank you for the answer. I installed and see the page but it shows right column. I've tried to disable right column at themes page (advanced settings)  but it doesn't shown the faq page. Is there a search availability inside the faq page?

 

Regards,

Share this post


Link to post
Share on other sites

Hola:

          No me funciona en Prestashop 1.7.4.4, ¿alguien me puede ayudar? ¿Debería funcionarme en esta versión?

Muchas gracias.

Share this post


Link to post
Share on other sites

Muy buenos días!

Estoy buscando algún modulo de Faq para mi tienda, y he visto muchos de pago, y buscaba algo gratuito y este parece un gran gran modulo para hacer las funciones precisas. 

Lo que pasa es que veo que los enlaces están caídos o ya no están, si alguien fuera tan amable de decirme el enlace de donde lo puedo conseguir o pasármelo de alguna manera, estaría muy agradecido.

Muchas gracias de antemano.

Share this post


Link to post
Share on other sites
Hello,
Your module is top. Exactly what I needed. Install on the local zero problem.
The problem is on my site https: installation ok but when I click on configure: "SQL request error".
I have to do what?
Thank you in advance for your answer.

image.thumb.png.4ce96c774a97eedc3343c935d02e5956.png

Share this post


Link to post
Share on other sites

Audweb

2 minutes ago, Audweb said:

Hello,
Your module is top. Exactly what I needed. Install on the local zero problem.
The problem is on my site https: installation ok but when I click on configure: "SQL request error".
I have to do what?
Thank you in advance for your answer.

image.thumb.png.4ce96c774a97eedc3343c935d02e5956.png

Enable debug and send me What You see when you click on configure

Share this post


Link to post
Share on other sites

Disinstall and reinstall the module with Enable debug?

 

Share this post


Link to post
Share on other sites
1 minute ago, Audweb said:

Disinstall and reinstall the module with Enable debug?

 

Disable the debug, disinstall and reinstall. Let me know

Share this post


Link to post
Share on other sites
27 minutes ago, Audweb said:

Always the same problem

If you send me in private message the credential of your backend i can help you 

Share this post


Link to post
Share on other sites

Sorry, but I can not. I would do without. Thank you for your quick reply.

Share this post


Link to post
Share on other sites
Just now, Audweb said:

Sorry, but I can not. I would do without. Thank you for your quick reply.

Ok the problem is db side. The table faq_lang is missing.

Share this post


Link to post
Share on other sites

Hi, thanks you for the module first.

I've installed the module in Prestashop 1.6.1.20 and all is ok but i can't see the Faq link in footer. Cache cleared but link don't appear.

Any idea please?

Share this post


Link to post
Share on other sites

Hi, i have to do anything special to put the FAQ link on footer? I can't see the link in footer.

 

Share this post


Link to post
Share on other sites

Hi, i have to do anything special to put the FAQ link on footer? I can't see the FAQ link in footer...

Thanks in advance.

Share this post


Link to post
Share on other sites
Just now, juanman said:

Hi, i have to do anything special to put the FAQ link on footer? I can't see the FAQ link in footer...

Thanks in advance.

The module for PS 1.7 add a link only in the top menu because in PS 1.7 you can add the link in the footer through the "Link Widget" button under Design Configuration button 

Share this post


Link to post
Share on other sites

Thanks for your reply. I'm using Prestashop 1.6.1.20.

Share this post


Link to post
Share on other sites
Just now, juanman said:

Thanks for your reply. I'm using Prestashop 1.6.1.20.

In PS 1.6 you have to check if you have the folder blockcms under \modules and if this module is activated.

PS 1.6 don t permit to customize the block cms in the footer through the backend so the module override the native module of PS

 

 

Share this post


Link to post
Share on other sites

Block Cms module is active and i have the blockcms folder under /modules. It's weird but i don't know why don't appear the FAQ link under Information group of footer.

Share this post


Link to post
Share on other sites
1 minute ago, juanman said:

Block Cms module is active and i have the blockcms folder under /modules. It's weird but i don't know why don't appear the FAQ link under Information group of footer.

UnInstall the module, Active the debug and reinstall and check some errors

Share this post


Link to post
Share on other sites

Hi, 

I would like to put this module on my contact page. How can I do that ? 

 

Thanks for this module !

Share this post


Link to post
Share on other sites
56 minutes ago, VB2095 said:

Hi, 

I would like to put this module on my contact page. How can I do that ? 

 

Thanks for this module !

you cannot do this with this module. 

Share this post


Link to post
Share on other sites

Thanks a lot for your quick answer ! 

Which one do you think does that ? 

Share this post


Link to post
Share on other sites
16 minutes ago, VB2095 said:

Thanks a lot for your quick answer ! 

Which one do you think does that ? 

really i don't know

  • Sad 1

Share this post


Link to post
Share on other sites

:/  Probably going to do it myself i guess

Share this post


Link to post
Share on other sites
Posted (edited)

PS 1.7

Tested with theme PANDA, module doesn't work.

Panda doesn't use default menu and disable default footer link.

If you use a theme that perform the same action, according to my experience, this module doesn't show on the website.

Just my 2 cents.

 

Edited by SashaBrno

Share this post


Link to post
Share on other sites
17 minutes ago, SashaBrno said:

In PS 1.7 is not possible to use this module if you use a theme that disable main menu and footer default link.

If you use MEGA MENU the FAQ will not show in CSM content or in any option.

I've tested the module with Classic Theme on PS 1.7

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, bortonecesario said:

I've tested the module with Classic Theme on PS 1.7

Not telling is wrong, just sharing what happened to me using this module with theme PANDA.

EDIT:  The module create a hook to https://domain.tld/module/faq/faqpage with this in mind is possible to create a anchor or a link everywhere.

Edited by SashaBrno

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More