Jump to content
MrNastykilla

How to make field as required field?

Recommended Posts

Hi. How to make existing field to be required? I checked Localization/Country but I can't or don't know how to make it required. I'm trying to bypass hard-coding if possible, to not scramble my project. Thanks for replies.pic2.thumb.png.7c6711d7db20b6851c0b8fa1d98de35b.png

Share this post


Link to post
Share on other sites

On back-office of your shop go to tab "Customers" - > customers ->  on bottom you will find: Set required fields for this section. Check Phone-no. BTW Phone-no IS MANDATORY, perhaps you are using a theme on which this filed is ignored as mandatory ? In this case you should revert to theme developer.

  • Like 1

Share this post


Link to post
Share on other sites

I checked set required fields. But there is not phone-no option. I have classic theme. How to revert to theme developer? And can module help me with that?

 

Edited by MrNastykilla (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Which Prestashop version exactly are you using ? Phone no. is mandatory field. See here: http://doc.prestashop.com/display/PS17/Customer+addresses

If there is another mask, than it could be that it was removed for now. PS 1.7 is still in development. In this case you can add this issue to the bug tracker and there is no solution for now.

bugtracker: http://forge.prestashop.com

  • Like 1

Share this post


Link to post
Share on other sites

I'm using Prestashop 1.7.2.4. Maybe hard-code will help. Just have to put option that person "must" fill phone number field. That's all i need. Don't have to confirm is it true or not.

  • Like 1

Share this post


Link to post
Share on other sites

I found solution. Have to change Localization > Country, check required fields. Didn't see at first, then later came up. Actions that I made refreshing, chache clearing, switch Demo mode. Thank you for replies.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, MrNastykilla said:

I found solution. Have to change Localization > Country, check required fields. Didn't see at first, then later came up. Actions that I made refreshing, chache clearing, switch Demo mode. Thank you for replies.

Yes this was also added to localization, but in past for customer accounts the options were there where I indicated. Perhaps they are moving the option now entirely to this tab. I don't know. For now it is a bug.

  • Like 1

Share this post


Link to post
Share on other sites

I have just tried this

 

Quote

back-office of your shop go to tab "Customers" - > customers ->  on bottom you will find: Set required fields for this section.

 

But it only gives me Field Name 'Partner Offers'

I want Telephone number and country as a required field.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 2/16/2018 at 7:41 PM, gray said:

I have just tried this

 

 

But it only gives me Field Name 'Partner Offers'

I want Telephone number and country as a required field.

 

o have the same, only partner offers, any idea?

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

The issue is still that you cannot seem to make registration phone (or mobile phone) mandatory as you could in previous versions.

Edit:

I take that back, as per another post Customers/ Addresses, at bottom set required fields.

Edited by jetx (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More