Jump to content

Recommended Posts

After clicking Save & Export I get error "Gateway Timeout. The gateway did not receive a timely response from the upstream server or application.". What could be the reason? Prestashop 1.6.1.0. 163 products.

Share this post


Link to post
Share on other sites
  • Replies 301
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Here is a free module to let you export your products to the Google Merchant Center, and make them available on the Google Shopping market place. It's an evolution to the GoogleShopping module made by

Well the whole stock related stuff surly needs a rewrite, i noticed it yesterday when i was working on product combinations. In your case, you are having multistore - question is if it shares sto

@Glasso I acually just came across something like that. How is your "Google categories"? Do any of your categories have an "availability" set? if that is the case, please set them all to default, then

Posted Images

@gzuk86 please activate prestashop debug mode, to get a better error Reporting.

open config\defines.inc.php file and locate the following line:

define('_PS_MODE_DEV_', false);

replace it with:

define('_PS_MODE_DEV_', true);

Share this post


Link to post
Share on other sites
5 hours ago, Casper_O said:

@carl@easy-pharma.ca

Just to be sure. You already used eMagic software?

And when you made the category in BO of prestashop, the category list in this module updated ?

Yes indeed I use eMagic software and the categories that were not appearing were created using the eMagic software. 

Then i went on the prestashop admin part, created a category and deleted the category. Now the Google Shopping Module sees all the categories. 

But i see another issue now, Google seems to tell me there are some fields missing... 

Missing value [shipping]
- Missing value [tax]
Invalid value [gtin]
Missing value [gtin]
- Invalid image [image link]

- Invalid value [price]

Etc, etc, .... How can i correct this? Where is this defined in the flux that is setup? 

Share this post


Link to post
Share on other sites
2 hours ago, gzuk86 said:

A few theme module warnings but no errors from the gshoppingflux module.

And what when you try to save and export?

 

1 hour ago, carl@easy-pharma.ca said:

But i see another issue now, Google seems to tell me there are some fields missing... 

Missing value [shipping]
- Missing value [tax]
Invalid value [gtin]
Missing value [gtin]
- Invalid image [image link]

- Invalid value [price]

Etc, etc, .... How can i correct this? Where is this defined in the flux that is setup?

I just realized your from Canada, and there are some really special requirements for merchant center feeds, tax is one of them.

https://support.google.com/merchants/answer/7052209?hl=en

 

Share this post


Link to post
Share on other sites
3 hours ago, Casper_O said:

I just realized your from Canada, and there are some really special requirements for merchant center feeds, tax is one of them.

https://support.google.com/merchants/answer/7052209?hl=en

 

And how am i supposed to change this? 

Is this taken care of in the module or do i need to do some modifications in order to send the proper information?

Share this post


Link to post
Share on other sites

@carl@easy-pharma.ca

I just found out that Canada do not require the tax field. So the module should work.

If you also wanted to have a feed for the States, you can do the tax part in Merchant center.

While that is said, from what i have been reading regarding the requirements for a canadian feed, it needs to be excluding tax. So in the module config, go down under the categories and find the "export languages and currencies" part and make sure the EN / CAD feed is set to be excluding tax.

image.thumb.png.c7295f39ae263969aa04b45990e42b5f.png

All the other things you mention was wrong with the feed must be only with few amount of products that is giving you problems. Regarding images it can acually be listed as invalid for the first two days.

Share this post


Link to post
Share on other sites
18 hours ago, Casper_O said:

And what when you try to save and export?

 

Only "Gateway Timeout. The gateway did not receive a timely response from the upstream server or application." error.

Share this post


Link to post
Share on other sites

Hello - 

PS Version: 1.7.4.2

Current Core Modifications: None.

Downloaded latest code from GitHub as the in-forum zip link appears to be broken.

This looks promising.  However, I am getting this error on install and therefore it does not appear to be finishing the initDB routine and therefore I have no Google Categories or the ability to configure them:

 

INFO: Starting module install and enable process
17:01:27 ERROR     [console] Error thrown while running command "prestashop:module install gshoppingflux". Message: "Call to a member function getLanguages() on null" ["exception" => Error { …},"command" => "prestashop:module install gshoppingflux","message" => "Call to a member function getLanguages() on null"] []

In gshoppingflux.php line 160:

  Call to a member function getLanguages() on null

This is when I attempt to install it at the command line, which is how I install and configure all of my modules.

Please let me know how to keep moving on this.  My shop is English only.

I am able to generate a feed, it looks fine, just puts in the default (wrong) values in for the feed category.

I found that the tables were created in the database.  I only sell one type of item, and so by editing the one line that had the "example" text in it that was getting flagged as an error previously to reflect the correct Google category, Google now uses the import successfully.

It does remain that I cannot configure Google Categories from within the module. 

 

image.thumb.png.3e752d679bf15750920c1b8cb639d00b.png

Edited by juchems
Screenshots, work around, general clarity. (see edit history)

Share this post


Link to post
Share on other sites
4 hours ago, ItalianBoutiqueShoes said:

Dear Casper, for a multistore I have to add something to the cron url? Like shop_id=x? Thanks, Daniele

You should run the cronjob from each store, so need to have shop_id in url

store01.tld/modules/gshoppingflux/cron.php

store02.tld/modules/gshoppingflux/cron.php

36 minutes ago, juchems said:

This is when I attempt to install it at the command line, which is how I install and configure all of my modules.

If you want to install the module by Command line, you are on your own and can not help you and can not tell you the correct ID for your languages.

11 hours ago, gzuk86 said:

Only "Gateway Timeout. The gateway did not receive a timely response from the upstream server or application." error.

That sounds really odd, sadly it can be anything an without a php error code or similar, I can not help and anything I would suggest, is only going to be wild guessing.

Share this post


Link to post
Share on other sites

Hey Casper, thanks for the quick reply -

When I install by drag and dropping the module into back office module installation screen, same issue.  It installs without error but there is still no ability to configure the categories.

Share this post


Link to post
Share on other sites

Hi, I see than the module "- automatically export shipping prices ( Thanks to GuillaumeGBzh )", I want to know if this module can export shipping prices by each reference product,

I do droppshipping, and I have products of 4 providers and each provider have a shipping price different.

thanks

Share this post


Link to post
Share on other sites

@iansaslu@gmail.com It will try to make the shipping cost depending on the "Price range" or "weight range" for each carrier available for the product. Im not sure if the module can do "External calculation", since i have not the option to test this.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
On 8/28/2018 at 3:17 PM, Naturel Deluxe said:

This is the output I get: 

 

(Small picture off the xml file) 

Capture.PNG

I have the same issue, can anyone please help us?

Share this post


Link to post
Share on other sites
On 7/8/2019 at 12:56 PM, mrc26 said:

I have the same issue, can anyone please help us?

The problem is that I press "Save and Export" and nothing happens... After 5 minutes it shows a 404 error page. I dont know what has happened, it seemed to work fine until last 1-2 weeks. The cron job and the generated xml file are having issues.

Capture2.PNGCapture3.PNG

Edited by mrc26 (see edit history)

Share this post


Link to post
Share on other sites

Hello,

hope you are doing well.

Store Manager is designed to work with the default PrestaShop database and indeed, may not work with all the modules and extensions.

Though, if you would like to combine store administration with both you have, you can contact Store Manager support and techs will investigate such possibility.

Edited by Alexandra Kolodovska (see edit history)

Share this post


Link to post
Share on other sites
On 7/8/2019 at 1:58 PM, mrc26 said:

The problem is that I press "Save and Export" and nothing happens... After 5 minutes it shows a 404 error page. I dont know what has happened, it seemed to work fine until last 1-2 weeks. The cron job and the generated xml file are having issues.

Capture2.PNGCapture3.PNG

Could you please help me with this issue? I have searched for the problem and no solution. What has happened with my prestashop 1.6.1.16? Has anyone experienced it? 

Share this post


Link to post
Share on other sites
On 7/11/2019 at 9:54 AM, Holian said:

Did anyone test module on the PS 1.7.5.2? It works?

Yep, it works perfect. I mean, with the demo products. Because I'm afraid that Prestashop 1.7 could cause problems in a shop with many articles. But maybe that's not justified. Basically the module works like a charm under 1.7.5.2.

On 7/11/2019 at 11:39 AM, mrc26 said:

Could you please help me with this issue? I have searched for the problem and no solution. What has happened with my prestashop 1.6.1.16? Has anyone experienced it? 

Like you said: It is either a Prestashop or a server problem and has nothing to do with this module. Was there recently an upgrade of the PHP version?

Share this post


Link to post
Share on other sites
14 hours ago, Martijn++ said:

Like you said: It is either a Prestashop or a server problem and has nothing to do with this module. Was there recently an upgrade of the PHP version?

Yes, it was from 5.3 (or 5.4, I don't know for sure) to at least 5.6. There is no lower version on our server. With PHP 5.6 the module doesnt work 100% anymore? The xml file is populated with only 2-300 active products from 850, and a huge execution time (over 300 sec). When I enter the xml file, it shows a red error with 'extra content'.

Share this post


Link to post
Share on other sites

I recommend min php 5.6 due to some function used in the module that is first native in php from that version. Workarounds have been made so lower versions should be able to also use it.

When that is said, what you should get is a error 500 when it times out - not an error 404. The server you are on must be configured wrong or something else override and throw an error 404. 

 

What is your server max execution time?

Share this post


Link to post
Share on other sites
16 minutes ago, Casper_O said:

I recommend min php 5.6 due to some function used in the module that is first native in php from that version. Workarounds have been made so lower versions should be able to also use it.

When that is said, what you should get is a error 500 when it times out - not an error 404. The server you are on must be configured wrong or something else override and throw an error 404. 

 

What is your server max execution time?

Server's max execution time is 240. They can't increase it, they are afraid to not affect their server. But I don't know if this is the problem. The module worked fine till last month . Till then back office exporting and saving items is a constant problem, very slow, duration in minutes. I have a paid module, SEO Manager, which is not saving seo title and description anymore. I deactivated all non native modules, installed only Google Shopping Flux and the problem persists. Something is wrong with some file, files of prestashop. The cron jobs (which are on server set, not in the module) are not executing anymore... Issues, issues, issues. 

Edited by mrc26 (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Привет, отличный модуль! Я получил предупреждение от Google, что в категориях товаров не указано, что в настройках модуля я указал "107"   http://prntscr.com/omkkc1  

http://prntscr.com/omkkl1

http://prntscr.com/omkmtq

PS 1.6.1.24  PHP 7

I never used eMagic, I tried to delete and create categories, but they did not appear. Please help with this

Edited by staut82 (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

The products that are not in stock, should not be exported wuth the availability tag as "out of stock" ??

Now is saying "in stock" even if the quantity is 0.

I think is better to export the product with the "out of stock" tag, otherwise if you took it out from the feed, the history record of the product in the merchant center would not be erased?

Share this post


Link to post
Share on other sites

Hello 

 

I have the same issue for export catalog.. 

It takes a lot of time then 504 error . The execution seems not work . 

With another shop it works perfectly and in another one with same configuration, i have this issue. 

I have seen that it is when i set large picture that it doesn't work. With middle picture it is ok. The issue is that middle picture is not good for facebook. 

I would need to know how to overpass this time of execution

If someone has find the solution? 

I am with ovh servor, prestashop 1,6,1,18

 

Best regards

 

Share this post


Link to post
Share on other sites
  • 2 weeks later...

hi

I have 98% products with Combinations

few products ( 0.25% of all product combinations ) are rejected by merchants center for Mismatched [price] (page crawl)

for a particular case of product : 2 combinations out of 4 are rejected while 2 are accepted.

XML shows proper information passed.

Raw as well as Final Feed attributes are properly fetched 

I checked the URL from the feed ( as well as xml) with combination parameters and its reaching perfect page and the pricing is properly shown on the front end pages

However "Information found on your site"  tab is showing price of the Default Combination.

Issue is not with the module as all data passed is correct.

 

My Query

I can understand that the issue is at display level, if there are 2 combinations out of which  the default one is approved while the other is disapproved.  However in this case there are 4 combinations where Default + one more is approved while other 2 are disapproved!! 

 

This is beyond my understanding and I need help and guidance. I am doing something wrong?

Screenshot(106).thumb.png.15b5e565f0b82c9102cd96f5eafa42b6.png
 

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hello everyone!

I'm getting a strange problem: when I'm listing all the categories, it doesn't show some of them, even though they are activated.

Anyone with the same problem?

 

Thank you!

Share this post


Link to post
Share on other sites
  • 4 weeks later...
  • 3 weeks later...

I need help,

Im migrating our server to google cloud, everithing work ok, but when i save system told me on a green color:

"The settings have been updated.
https://www.XXXXXXXXXXXXX.com/modules/gshoppingflux/export/XXXXXXXXXXXXXXXXXXXXXX.xml : 136 products exported."

or

"OK, export completed successfully. 0.82348799705505sec"

But file is missing, I have check the folder permissions and it's 755, the right ones.

some help please?

best regards and thanks.

Share this post


Link to post
Share on other sites

Hello,

First, thanks for this work and module offered.

I am with Prestashop v1.7.6.1 and your module v1.7.3.

The installation of the module is ok, the flow works well and is recovered by google merchant center.

On google merchant center this makes me a mistake "Unknown value for attribute 'Google product category'."
How can I fix this?

thank you very much

Share this post


Link to post
Share on other sites

Hello, 

I am running Prestashop 1.7.6.1 and your module version v1.7.3.

I am running my shop in 2 languages French and English, But i need to export my feed to 4 files 

- 1 feed for French language with Euro Currency

- 1 feed for French language with Canadian Currency

- 1 feed for English language with Canadian Currency

- 1 feed for English language with US Currency

 

But i can't find a way to have more than 2 exports as i have now 

- 1 feed for French language with Canadian Currency

- 1 feed for English language with Canadian Currency

 

Any idea where i can change this? 

 

Thanks!!!

Share this post


Link to post
Share on other sites

On the product pages of my e-commerce there are some icons/emoji, therefore the products feed is exported to Google Merchant Center with representative codes of those icons/emoji (e.g. the check symbol is exported as “done_all”). Is there any way to avoid exporting icons/emoji codes?

Share this post


Link to post
Share on other sites
  • 1 month later...

Hi, thanks for the module i would like to know if there is the possibility to change the gtin line?

I try to explain better i have a lot of produtc that doesn't have a full gtin but a mnp with 9 numbers and not 13 like EAN. Google give me the error because didnt recognise the gtin. i try to modify the gtin line manually with mnp and it works the problem is that every time that i update the file it change the mnp in gtin. prestashop dosent have a mnp option so i cant update these product. is a way or command that can say ift the gtin has 9 number the line has to be called mnp??? thanks

Share this post


Link to post
Share on other sites
  • 3 weeks later...
En 10/11/2019 a las 6:49 PM, Josele Hernández dijo:

I need help,

Im migrating our server to google cloud, everithing work ok, but when i save system told me on a green color:

"The settings have been updated.
https://www.XXXXXXXXXXXXX.com/modules/gshoppingflux/export/XXXXXXXXXXXXXXXXXXXXXX.xml : 136 products exported."

or

"OK, export completed successfully. 0.82348799705505sec"

But file is missing, I have check the folder permissions and it's 755, the right ones.

some help please?

best regards and thanks.

Help please!!!

Share this post


Link to post
Share on other sites

Hi, I installed the modul.

But when I try to generate the XML File, it only export 1 Product. But there should be a couple hundreds. Do I make an error while export?

I have prestashop 1.7.6.2

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Hello everybody!

I am using PS 1.7.6.3 and shopping flux module version 1.7.3 and I have problems to set google shopping catagories cause there is no button or function to add a category:

image.thumb.png.8117d4eebb14e2b6a0c1a7ecafdaf4be.png

it would be very nice if someone could help me ☺ to fix it 

Share this post


Link to post
Share on other sites

Hello, Thank you very much for your contribution. The module has made my job a lot easier.
I have a problem and it is that in google merchand center, I get the following error:

The attribute does not contain the country code of ISO 3166: shipping.country

Where do I have to put the iso code of Spain? It would be ES?  I use prestashop 1.7.52

I hope your news, greetings and thank you very much

Edited by mbantolin (see edit history)

Share this post


Link to post
Share on other sites
  • 1 month later...

Is the development of this fine module stopped?

It works overall fine, but the experimental shipping costs calculating is unfortunately still pretty buggy. So cannot really be used here.

Not sure if possible, but would be best if the module could pick the shipping data from same place/calculations as actually displayed on the FO appearance.

For example it does not take any Free Shipping values into considerations (many use various free shipping modules for this, since default options are quite limited). The modules seem to base its shipping values on the raw carrier settings, and not the actual options/prices available in FO, so various filters / module overrides are not taken into considerations.

Also if creating XML's for several countries/currencies, the shipping costs for each country are also included in each XML file and somewhat  just currency converted. I guess Swedish shipping costs shown in Danish kroner in the Danish feed and vice versa is not so relevant.

I know the feed is initially for Google Shopping, but guess most also use it for other stuff like Facebook, Affiliate sites etc. So it would be nice if could also be able to export XML files for other customer groups (like resellers etc.).

Thanks! 
 

 

 

 

Share this post


Link to post
Share on other sites

Hi Casper,

Thanks for this nice module, I use it on a lot of client's shops without problems. However, on one client's shop there are issues. I am trying to export approx. 20 categories and all others are set as inactive. When I check the xml output the feed is empty, it only contains information about the shop, no products, but in Google Merchant we see almost all products are exported - but not the ones we want.

The shop has 100s of categories/subcatecories - I don't know if this can be the problem? Other than that the setup is pretty much standard with no special modules. It is PS 1.6.1.22 and the module version is 1.7.3

 

shopping-flux-xml.jpg

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hi there,

I just installed the latest version, available in the first post, in my Prestashop 1.6.1.4 (default template) and it seems to be working smooth. I changed the settings, save&export and it exported the 800 products I was expecting.

I add the feed to merchant center and now waiting to see any possible issues. I think I am gonna have trouble because I do not have GTIN/ETAN/EAN codes...is this mandatory? For each of my products I have Prestashop ID and my own reference number but no other reference code.

Thanks for the module and for your help!

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hello

I have liked this module for the last two years but I gather that support has stopped. Perhaps this seems so since there is no need at the moment for change since all is fine. But I am no developer nor seo expert and wonder if this module is still a recommendation or if we should better look for something else since there might be new options or features?

Are there alternatives you reccomend`?

Share this post


Link to post
Share on other sites
  • 2 weeks later...

I have PS 1.7.6.5 and the module version 1.7.3. My shop has three languages: spanish, english and chinese. When I run the module the default language for the BO turn to chinese and need to go to pick on localization and immediately turn to spanish again.

Share this post


Link to post
Share on other sites
  • 5 weeks later...

Great module. many thanks.
There is a small error when "generating" the product link in multi-languages.
In line 2298 of the gshoppingflux.php the variable $ id_lang should be used instead of $ lang, that should be changed:
$ cat_link_rew = Category :: getLinkRewrite ($ product ['id_gcategory'], (int) $ lang);
therefore:
$ cat_link_rew = Category :: getLinkRewrite ($ product ['id_gcategory'], (int) $ id_lang);
But apart from that the module works wonderfully in my prestashop 1.7.6.4 store.
Once again thanks and congratulations for your fantastic module.

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Hello!

I've installed GShopping Flux on PrestaShop and i've see when exporting feed on google merchant it cut title of product.

How we can resolve this problem?

Share this post


Link to post
Share on other sites
  • 1 month later...
On 2/1/2018 at 8:50 PM, Casper_O said:

....

If all of your shop products belong to the same Google Shopping category, you can just set it for your root/home category, no need to set it for all of your categories. Children categories automatically get the same parameter. The module works the same way for the condition attribute, availability, gender and age_group attributes.

....

Download

gshoppingflux-1.7.3.zip 50.31 kB · 611 downloads

FYI: Google_Product_Taxonomy_Version: 2019-07-10:

https://www.google.com/basepages/producttype/taxonomy.en-US.txt

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Good Morning,

I am having this error :

public_html/classes/db/DbPDO.php on line 174
PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 65536 bytes) in Unknown on line 0

Is there any way to improve memory utilization ?  I think that it's trying to read from database all products at once.

DAniel

Share this post


Link to post
Share on other sites
  • 2 weeks later...
On 2/1/2018 at 8:50 PM, Casper_O said:

Last updates:

- ability to manually specify the shop's product type (optionnal)

 

Hi, first of all thank you for your contribution, your module is very useful, I´m using it on PS 1.6.2.1 and I can´t compleate the "product_type" attribute, even one for all items, only the google category.

<g:product_type>

<![CDATA[ ]]>

</g:product_type>

I was looking inside your code and I believe it takes this info from the breadcrumb of each product but I have that information, so I´m a bit confuse, any ideas?

Share this post


Link to post
Share on other sites
  • 2 weeks later...

 I have a problem, im using this module, but in 2 categories i saw problem.

When i matching Google category and put number of category then i see in file: "Google Category Example > Google Sub-Category Example" instead number.

How can i repair this?

Maybe i have to clear cache this module, but how?

 

//edit

I probably solved the problem - i removed cache.

i deleted content of var/cache/dev and var/cache/prod

 

Edited by szredi (see edit history)

Share this post


Link to post
Share on other sites

Hello, with the latest google news relating to the upload of an additional local product inventory feed, I ask you to enter the google store code of the Google MyBusiness card (<g: store_code> NOMESHOP </ g: store_code >).
So the xml code must contain that code, for each product.
Indeed, google gives the possibility to enter even more store codes (up to 20 codes), in fact a product can be available in several Mybusiness cards.

I ask that Shopping flux be modified by pre-selling:
- inserting google store codes;
- create a new feed only for local product inventory with different file name, according to google provisions.

I report the reference links:

https://support.google.com/merchants/answer/7360778

https://support.google.com/merchants/answer/3061198

https://www.dibix.it/guida-inserimento-prodotti-merchants-center-su-google-my-business/

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi.

I installed and configured my first feed but I can't find the exported file. There is nothing on my server so the shopping link goes to a 404 error. Can you help ?

Thanks

 

Edit: My bad. Misconfiguration of the default category. All good

Edited by @rthur (see edit history)

Share this post


Link to post
Share on other sites

While reviewing the data on google merchant center I noticed the ID or SKU was set to the product.id_product. I changed the source to make this the product.reference so the product is easier to find in both the FO and BO. In a future release, would it maybe be possible to add an option to either use id_product or reference  for the SKU? 

Everything else is working nicely. 1500+ products with multiple shipping countries selected. Thanks again, great module!!!

Share this post


Link to post
Share on other sites
8 hours ago, Alex Neacsu said:

Hi there.

Where can we find the last version file download? Can you please share a link?

See the first page of this thread. You can find the download links there. 

Share this post


Link to post
Share on other sites
20.06.2019 o godzinie 23:27 juchems powiedział:

 

 

image.thumb.png.3e752d679bf15750920c1b8cb639d00b.png

Has anyone managed to solve the problem of missing categories in the list?
In the store there are 2 languages (Polish and English)
After the update, the file began to generate incorrectly and as I checked it turned out that the category field is empty

Share this post


Link to post
Share on other sites
  • 2 weeks later...
On 10/25/2020 at 8:46 AM, schirinzi said:

Hello, with the latest google news relating to the upload of an additional local product inventory feed, I ask you to enter the google store code of the Google MyBusiness card (<g: store_code> NOMESHOP </ g: store_code >).
So the xml code must contain that code, for each product.
Indeed, google gives the possibility to enter even more store codes (up to 20 codes), in fact a product can be available in several Mybusiness cards.

I ask that Shopping flux be modified by pre-selling:
- inserting google store codes;
- create a new feed only for local product inventory with different file name, according to google provisions.

I report the reference links:

https://support.google.com/merchants/answer/7360778

https://support.google.com/merchants/answer/3061198

https://www.dibix.it/guida-inserimento-prodotti-merchants-center-su-google-my-business/

 

I've found a solution for adding the store code to the feed, its a little hacky but it works and can be automated. It uses sed and has the following variables;

  • the feed is named 'shopping.xml', this needs changing to the same name as your feed usually .....googleshopping-s1-gb-GBP.xml or something
  • the store codes are the ones you have in google my business e.g 1 for single store or 1,2 & 3 for multi store are shown in the examples

 

FOR ONE STORE

sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\
<g:store_code>1</g:store_code>|g" shopping.xml


FOR MULTIPLE STORES

sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\
<g:store_code>1</g:store_code>\\
<g:store_code>2</g:store_code>\\
<g:store_code>3</g:store_code>|g" shopping.xml

 

Share this post


Link to post
Share on other sites

I have strange message displayed:

image.thumb.png.5588c9d3ceeab30856c3c7c3d2ac8362.png

Can someone explain me what it means? What is the reason for 187 products to not be exported? All my products are "the same", there is nothing different, they should be all exported.

Also, what means "2 products exported: 10 products with attributes, 15 attributes combinations. Total 17 exported products" This message makes literally no sense.

image.png

Share this post


Link to post
Share on other sites
On 11/11/2020 at 11:55 AM, dominictayloruk said:

I've found a solution for adding the store code to the feed, its a little hacky but it works and can be automated. It uses sed and has the following variables;

  • the feed is named 'shopping.xml', this needs changing to the same name as your feed usually .....googleshopping-s1-gb-GBP.xml or something
  • the store codes are the ones you have in google my business e.g 1 for single store or 1,2 & 3 for multi store are shown in the examples

 

FOR ONE STORE


sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\
<g:store_code>1</g:store_code>|g" shopping.xml


FOR MULTIPLE STORES


sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\
<g:store_code>1</g:store_code>\\
<g:store_code>2</g:store_code>\\
<g:store_code>3</g:store_code>|g" shopping.xml

 

Hello,
You can explain better how to add the store code?

Does anyone know how to validate this module for google normal sitemap?
It works perfectly in Google Merhant, but generates tag errors in the search master.
It is difficult to find free modules that generate links to associated images and link attributes from products.

 

 

Share this post


Link to post
Share on other sites
2 hours ago, rb10 said:

hi, how i can impor XML generated in Google Merchant ?

Hi, This module do exactly the oposite. If you have 1.7, go to catalog/products and on your top left will see a gear weel to access the import area

Share this post


Link to post
Share on other sites
32 minutes ago, Pablus said:

Hi, This module do exactly the oposite. If you have 1.7, go to catalog/products and on your top left will see a gear weel to access the import area

I mean, i have generated XML file with mercado but when i go in google merchant and i upload file it not import any products.

Share this post


Link to post
Share on other sites

Thanks,

But where I put this code?

sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\ <g:store_code>1</g:store_code>\\ <g:store_code>2</g:store_code>\\ <g:store_code>3</g:store_code>|g" shopping.xml

Share this post


Link to post
Share on other sites
On 11/11/2020 at 3:55 PM, dominictayloruk said:

sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\ <g:store_code>1</g:store_code>|g" shopping.xml

For info i'm in Prestashop 1.6.1.24

Share this post


Link to post
Share on other sites

No, ssh into your server and execute something like the following;

ssh user@123.123.123.123

cd /var/www

sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\ <g:store_code>1</g:store_code>|g" shopping.xml

 

Share this post


Link to post
Share on other sites

I'am connected with putty in ssh but this code

sed -i "" "s|<g:availability>in stock</g:availability>|<g:availability>in stock</g:availability>\\ <g:store_code>1</g:store_code>|g" shopping.xml

don't work??? Other solution???

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hello,

I wisch the best for 2021...

I have receive today this message from Google :

100% d’offres sont affectées par l'erreur "Attribut obligatoire manquant ou incorrect : store code"

?

Share this post


Link to post
Share on other sites

First of all thanks for this module.

I have installed the module version 1.7.2 on Prestashop 1.7.6.7 and I cannot find out why almost 30% of my products are exported with price = 0,00 euro.

is there anyone who can help me out? I cannot find a common property for all these products, it appears the error presents itself randomly. Updating the feed does not change a thing and the same products keep the error.

Thanks in advance for your precious help and happy 2021!

Share this post


Link to post
Share on other sites
  • 3 weeks later...