Jump to content

Recommended Posts

Hi Casper_O.

I just want to say thanks for this awesome module and for all the time you've dedicated to it. You have given me the possibility to get all my products on Google Shopping with no effort at all.

I believe I ran into some sort of a bug. When the option to calculate the shipping costs for each product is used, your module temporarily creates a shopping cart for each product/combination (which makes sense). Unfortunately, this has the side effect of increasing the AUTO_INCREMENT value of the id_cart column on the dbprefix_cart table by the number of existing products/combinations.

In my case, since I have around 4500 active products/combinations this id grew quite a lot in just a few days.

 

Would it be possible, at the end of the export, to reset the AUTO_INCREMENT value to the highest existing id_cart cart? I honestly still don't have the PHP skills to do this.

 

Thank you once again.

Share this post


Link to post
Share on other sites

Hi

 

Just upgraded to 1.7.2 from 1.6.2 and when i do a save, no products get exported

 

I switched back to 1.6.2 and it is exporting products again

 

Is there something i missed?

Share this post


Link to post
Share on other sites
On 14/9/2018 at 2:25 AM, sosimple said:

Hi Casper_O.

In my case, since I have around 4500 active products/combinations this id grew quite a lot in just a few days.

Would it be possible, at the end of the export, to reset the AUTO_INCREMENT value to the highest existing id_cart cart? I honestly still don't have the PHP skills to do this.

Thank you once again.

 

From the beginning it was going to be rewritten - today is the day, that I am testing out something and I think you should be able to help out if you want to test also. This SHOULD maximum use 1 cart ID each time you run the feed. Acually i don't think it use any for the moment.

https://github.com/dim00z/gshoppingflux/commit/41339484bc6bc1e73da90c94070fe82f61bf1a00

Edited by Casper_O (see edit history)

Share this post


Link to post
Share on other sites

problem with languages
The module has the option to add google categories in other languages, although when saving it gives an error and does not save google categories in other languages

Any solution?

 

problema con idiomas
El modulo tiene opcion de añadir las categorias de google en otros idiomas, aunque al guardar da un error y no guarda en otros idiomas las categorias de google

Alguna solucion?

Share this post


Link to post
Share on other sites

Hi, I am trying to use this module, but I get an error in Google Merchant Center, all items are missing color attribute.  I sell custom made jewelry, handbags and phone cases, and not everything has a specific color.  Is there a way to override this?

Share this post


Link to post
Share on other sites

Prestashop multilanguage

Principal Spanish

image.thumb.png.dcfd65a7a1ed93f2e48998252e24dc63.png

change language and write category

image.thumb.png.bdffdae9e54f11406c9f065f95555ec0.png

 

Update / save and error

image.png.105e41dba88ae5d64bf4d091d5c0d245.png

 

show all in other language, dont save 

 

Share this post


Link to post
Share on other sites

Hi,

I have installed Google Shopping Flux, and ALL of my products have been dissaproved my Google Shopping Merchant because of "Missing value ".

In each of my categories, I have the option to select my color attributes in "Products color feature", but the "Default product type" parameter does not give me options for that (see attached pic).  The only option I have in that section is "Product feature doesn't exist", and it defaults to being selected.  I am unable to deselect that option, when I try, it defaults back to being selected.

I think if I had these attributes available for selection on the main "Default Product Type" page, they would export properly.  Am I wrong?  Is there anyone who can help me with this please?  I am not comfortable editing files on my server, so I am hoping this can be resolved in my back office module "Google Shopping Flux".



Thank you,


: )


Teresa

GoogleFlux.jpg

Share this post


Link to post
Share on other sites

Have you created a feature called 'Color' and entered values for each colour?

Have you selected the relevant colour on each product's 'Features' tab?

Share this post


Link to post
Share on other sites

Yes, all of my items have a color attribute.  Google Shopping Flux shows me those color attributes in each category (and yes, I have them selected), but they are not available for selection on the main "Default Product Type" page.  See the attached image from my previous post.

Share this post


Link to post
Share on other sites

 

"Yes, all of my items have a color ***attribute****."

"..shows me those color ****attributes**** in each ****category*****"

Yes, but do you have a ***feature*** on each product and the colour selected as a ***feature*** on each product*?

Share this post


Link to post
Share on other sites

For instance, one attribute for my leather phone cases is "leather color", and a drop down menu for - black, brown, red, etc ...

Yes, every single item in my shop has a color attribute, that the customer has to select via drop-down menu.  Is that what you mean by "feature"?

Share this post


Link to post
Share on other sites

No, I don't mean that.

Go to admin->catalogue->Features and add a feature called 'Color' then add all of your different colours as values.

Then select the relevant colour on the 'Features' tab of each product.

Nothing to do with attributes and the customer, this is for Google.

Share this post


Link to post
Share on other sites

My colors are assigned with the "attributes" in Prestashop, not features.  I have another website, also using "attributes" for the different colors.  ("Features" also disabled on that website).  It works fine with Google Shopping.   I am, however, using the "Google Merchant Center" module on that website.  I was just trying to avoid having to purchase it twice, thought I would try out Google Flux instead. 

Share this post


Link to post
Share on other sites

Hi Tztudio

you don't need to add a feature, to make this work. It should work with Attributes. Normally i would suggest that you select the attributes that have colors for each category. What you could try, is to edit the root category in the module, and select all attributes that should be handled as a color by the module, and see if that help you.

I know that Google Shopping Categories is carried over from parent category to child categories, but im not sure if it also count for colors.

Share this post


Link to post
Share on other sites
9 hours ago, Casper_O said:

What you could try, is to edit the root category in the module, and select all attributes that should be handled as a color by the module, and see if that help you.

If you see my original post, with attached picture, that is exactly my problem.

In each of my categories, I have the option to select my color attributes in "Products color feature", but the "Default product type" on the main page of the module, does not give me options for that (see attached pic).  The only option I have in that section is "Product feature doesn't exist", and it defaults to being selected.  I am unable to deselect that "Product feature doesn't exist" option.  When I try, it defaults back to being selected.

I think if I had these attributes available for selection on the main "Default Product Type" page, I think they would export properly.

GoogleFlux.jpg

Share this post


Link to post
Share on other sites

This picture (see attached) is from my other website's back office, which uses "Google Merchant Center" module.  As you can see, on the main page, under "feed data options", all of my attributes are there and I am able to select them.  THAT is what is missing from the main page of my "Google Shopping Flux" module.  The attributes are not showing up.

Thank you for your help, BTW, I really appreciate it.

: )

GoogleFlux2.jpg

Share this post


Link to post
Share on other sites

tzstudio try edit "Start" category, and select all color attrbutes in this. It should then push it to the child categories. it is the first Category in the "GOOGLE CATEGORIES" list.

 

Share this post


Link to post
Share on other sites
7 hours ago, Casper_O said:

try edit "Start" category, and select all color attrbutes in this. It should then push it to the child categories. it is the first Category in the "GOOGLE CATEGORIES" list.

 

THAT is exactly my problem (see the attached picture again) ... my attributes are missing from the "start" category.  No attributes are visible to select.  I have circled the area in red, so you can see ... no attributes available for selection.  The inserted image on the right is one of my categories.  All of my categories have attributes visible for selection, but the main page does not.  That is what I have been trying to point out.

GoogleFlux.jpg

Share this post


Link to post
Share on other sites

It is because you are not doing, what i am asking you to do. 

Ignore the Main page of the module.

Look at the "Google Categories" section, at the first category it is often called "Start" or "root" - edit this one, and select all your color attributes, and you should be good. Please see the attached photo

 

 

example.png

Share this post


Link to post
Share on other sites
55 minutes ago, Casper_O said:

the first category it is often called "Start" or "root" - edit this one, and select all your color attributes, and you should be good.

 

That has been done.  The attributes have always been selected for my root category.

Thank you for your help.  Has anyone else ever reported this problem?

: )

Share this post


Link to post
Share on other sites

p.s.  My root category is "Apparel & Accessories".  Is that acceptable for a root category?  That wouldn't make a difference, would it?

Share this post


Link to post
Share on other sites

As long the products default category, is "Apparel & Accessories" or a catgory below that, it should not be a problem.

I checked with 2 Prestashop 1.6.1.X stores and non of them had the problems - They both export Color attribute as expected.

 

Share this post


Link to post
Share on other sites

Many thanks for the module. The guy you are well done. solves questions with both google and Facebook

presta 1.6.1.6

 

However, I have a question.
How to export products to the feed so that the state is not available (out of stock)

I do export products with the enabled option.
image.png.0ce48dada6d1cb3025b59a4e921fee2b.png

Products are exported to the feed, but have status avalible (on stock)

Edited by rusbolik (see edit history)

Share this post


Link to post
Share on other sites

Hi,

I have the exact same problem as tztudio has. I think I've tried everything so far but it will not export the color and material. Are there any suggestions what else I could do?

My PS Version is 1.6.1.17

Many thanks  

 

 

categories.thumb.jpg.1161d90508f6cb85ff75ce469a4275a3.jpg

Share this post


Link to post
Share on other sites
On 11/13/2018 at 4:48 AM, Steppu said:

My PS Version is 1.6.1.17

Interesting ... that is the exact same version I am using.  Google Shopping Flux obviously has an issue with version 1.6.1.17.

Share this post


Link to post
Share on other sites

@Steppu i noticed something, your Color and Material are both "Silber" - german for "Silver"... Correct? What is the options in this Attribute called "Silber"?

Please provide me with a link to your store, the merchant XML feed file and i'll have a look at it. If you dont want to post at forum, feel free to send it via private message.

 

23 hours ago, tztudio said:

Interesting ... that is the exact same version I am using.  Google Shopping Flux obviously has an issue with version 1.6.1.17.

I would not be that fast... I have stores at 1.6.1.16 running fine with colors as descripted an i do not see anything in changelog telling me, something should blow up how the module works:
https://www.prestashop.com/en/system/files/ps_releases/changelog_1.6.1.17.txt

Edited by Casper_O (see edit history)

Share this post


Link to post
Share on other sites

I ended up purchasing Google Merchant Center module, and it is working fine. 

Thank you so much for all your time, I really appreciate it. 
I'm sorry it didn't work out.

: )
T.

Share this post


Link to post
Share on other sites

Hi, I've downloaded this module (gshoppingflux-master.zip) and uploaded it to my 1.6.1.5 version prestashop, but why when I try to search it, I can't find it?

I set the research filtering in this way: "all modules", "all authors" and "installed and not installed"

Thank you for your kin answers

 

Share this post


Link to post
Share on other sites

Hi, finally I managed to install gshoppingflux.zip, I've set the parameters and I've clicking to Save&Export and the module relased me the following message:

The settings have been updated.
https://www.gioielleriamomentipreziosi.it/googleshopping-s1-en-EUR.xml : 686 products exported: 71 products with attributes, 195 attributes combinations.
Total: 881 exported products, and 27 not-exported products (non-available).
https://www.gioielleriamomentipreziosi.it/googleshopping-s1-it-EUR.xml : 686 products exported: 71 products with attributes, 195 attributes combinations.
Total: 881 exported products, and 27 not-exported products (non-available).

 

but I can't understand if my products are exported to Google shopping or not. Because when I do the research on google shopping, my products doesn't appear 

Thank you very much for your help

Share this post


Link to post
Share on other sites

The module only generate a XML file that “Google Merchant Center” can read.

You would need to setup a google merchant account yourself.

Share this post


Link to post
Share on other sites
On ‎11‎/‎15‎/‎2018 at 7:39 PM, Casper_O said:

i noticed something, your Color and Material are both "Silber" - german for "Silver"... Correct? What is the options in this Attribute called "Silber"? 

Please provide me with a link to your store, the merchant XML feed file and i'll have a look at it. If you dont want to post at forum, feel free to send it via private message.

Hi Casper and sorry for the late reply, too much to do right now. :(

You are right "Silber" stands for silver in the color and the material. Material is not necessary for Google but it does not make a difference, with material and without it, it does not work. Your question: "What is the options in this Attribute called "Silber"? " I do not understand, sorry for that. I attach a photo where I choose the colour and hope that helps. The link to my XML-file I will send via private message.

I really appreciate your interest and help, thank you for that.

000029.jpg

Share this post


Link to post
Share on other sites
37 minutes ago, Casper_O said:

The module only generate a XML file that “Google Merchant Center” can read.

You would need to setup a google merchant account yourself.

Ok, I got it, do you have a guide to learn how to setup merchant account? Because I don't know where I have to setup the xml file

Thank you very much

Share this post


Link to post
Share on other sites

@c.cristinziano

No, i dont - i would suggest that you make a Google Search for it.

@Steppu:

I have had a look at your store. "Silber" is a attribute, just like your "Size".

If it is not something your customer can select between (if the item should be made of Gold or Siver), then I belive the right thing to do, is making a "Color" and "Material" Feature instead.

https://www.prestashop.com/en/blog/difference-product-attribute-product-feature

Share this post


Link to post
Share on other sites

Hi, since I would like to upload xml file via SFTP, but the module don't generate me xml file but just the xml link, is there anyone who know how could I do?

Thank you very much

 

 

Share this post


Link to post
Share on other sites

hi @c.cristinziano

The module do generate an XML file in the root of your store or in the module folder. That is where the xml link goes to.

How to make the SFTP work i can’t help you with.

Share this post


Link to post
Share on other sites
6 minutes ago, Casper_O said:

hi @c.cristinziano

The module do generate an XML file in the root of your store or in the module folder. That is where the xml link goes to.

How to make the SFTP work i can’t help you with.

Hi Casper, do you know why when I click on the following generated file link: https://www.gioielleriamomentipreziosi.it/googleshopping-s1-it-EUR.xml 

I see the following error? 

This page contains the following errors:

error on line 746 at column 12: EntityRef: expecting ';'

Below is a rendering of the page up to the first error.

Thanks a lot

Share this post


Link to post
Share on other sites
2 hours ago, Casper_O said:

@c.cristinziano

How to make the SFTP work i can’t help you with.

Casper - I can provide you with a version of your module with working FTP code in it to automatically upload the .xml file to Google after it's been created, if you want to incorporate the FTP part into your module. The code is very simple.

The upload URL/user/pass is currently hardcoded, but you could add some input boxes to capture that in the module's config page.

Just pm me where you want it uploading (not here - I'm not able to support it).

Share this post


Link to post
Share on other sites
On 11/12/2018 at 8:18 PM, Casper_O said:

Rusbolik try "Export product quantity"

YESSSSSSSS!!!!! Good work. Thx. 🖕

Share this post


Link to post
Share on other sites

I can't understood why despite I've fulfill any fields of parameters and matching my categories with google categories, when upload the xml file on Google Merchant Center, I see just 58 products imported and aslo from not matched categories...  

I hope that someone wants help me

I've also attached the screenshots like I had set the module

Thank you

 

 

Untitled-1.gif

Untitled-2.gif

Untitled-3.gif

Untitled-4.gif

Untitled-5.gif

Share this post


Link to post
Share on other sites

@c.cristinziano

I checked your feed -the error is due to, that your g:id is the reference or so, and contains & - I would recommend that you upload the recent version 1.7.2 added to the first post today (or github)

1.7.2 release note:

This changes is required, to make the <g:id> stable and unique for each product / Product-combination.

IMPORTANT if you update from older version

Any history you might have where you use this Google Shopping Feed WILL be lost, since the ID in the feed for each product will change!

Share this post


Link to post
Share on other sites

Hi Casper, I've uploaded the new version of module, and the xml file uploaded all the products but they aren't active due to errors you can see on screenshot I've attached...

Do you know how could I solve that issues? as invalid "country code" and "Missing value shipping" maybe would I've to fill in something in the module?

Thank you very much

untitled-6.gif

Share this post


Link to post
Share on other sites

Well it did for sure fix the feed, so it looks nice and all.

Now, i dont know how you have configured the module, but when i look at your feed there is nothing related to shipping at all. I guess you have chosen not to export anything, so you should look at this i guess, that should help you with most.

https://support.google.com/merchants/answer/6069284

For Gender:
https://support.google.com/merchants/answer/6324479

Else check the ? mark in the list, it should lead you to the same support info, that i can give you.

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

First of all @Casper_O, thanks for this module.

It seems that I have a problem with the module - it doesn't create the feed XML file.

I configured everything, saved and exported and the file path (/TEST_googleshopping-s1-he-ILS.xml) leads me to 404 page.

Any ideas on how to solve this?

I currently run Presatshop 1.6.1.17

 

Thanks!

 

Share this post


Link to post
Share on other sites

Hi Casper, I've set shipping informations in Merchant center, and now I can see the 23% of my items pending.

Since I've set up free shipping for Italy and $ 25 for United States, could you make me an advise how could I set up "Shipping Methods" and "Shipping price" into the module? Because I'm not sure how to do..

Attached you can see as I've set up that fields

Thank you very much

Untitled.jpg

Share this post


Link to post
Share on other sites

The cron.php link generates a 403 Forbidden error for me, so I'm having to update the feed manually after every couple of orders. Any ideas on how to fix this?

Share this post


Link to post
Share on other sites

I installed this module, and I am very happy with it! There is only one thing, my product reviews / start ratings do not show up in google shopping. I use the official Prestashop product review module, is it a common problem? How can I get the star rating appear in Google shopping?

Thank you in advance!

 

Prestashop 1.6.1.23

Edited by joostjoost (see edit history)

Share this post


Link to post
Share on other sites

Thank you, excellent module, very useful! waiting for feed google validation, best regards

Share this post


Link to post
Share on other sites

hello 

thanks for your module

i m from greece and sorry for bad english

can i have in the xml fields the short description and the long description; I need both of them

thanks

Share this post


Link to post
Share on other sites

Hi everyone, do you know a way to show discounted prices on my shopping ads?

Because how you can see on attached picture, the users see the standard price but not discounted price...

Thank you very much for your kind answers

Untitled-1.gif

Share this post


Link to post
Share on other sites

Unfotunately is not working well in 1.7.4.2, I have te following errors:

Google Google product category unknown

The recommended attribute does not appear or is not valid: description

 

Share this post


Link to post
Share on other sites

Hi!

I'va got a problem with the gtin and I can't seem to find a pattern.

My settings: 

Export products with no GTIN code - YES

 

Export products with no brand - YES

Set <identifier_exists> tag to FALSE - YES

For some reason, some products with no EAN, especially the newer ones, are exported to XML with no gtin, but the <g:identifier_exists>FALSE</g:identifier_exists> is missing.

Not sure how to solve this!

F

 
 

Share this post


Link to post
Share on other sites

Excellent module.

Is it possible to add custom labels ? and match them with specification, quantities or other prestashop attributes ?

 

Share this post


Link to post
Share on other sites

 

excellent form .. congratulations .... a question can you convert the description text to lowercase or just the first capital letter?

Share this post


Link to post
Share on other sites

Hello, i'm using your module (1.5.4) on an 1.6.0.11 Prestashop.

When i generate the flux, all my products have "free shipping" cause the "Shipping Cost" was set with 0 cost. But is there a way to not setting up the shipping cost in the setting and take the product's shipping cost instead ? (the shipping cost depend on the product). 

What i must set in the Shipping cost field for ignore it ?

Thanks in advance.

settings.png

Share this post


Link to post
Share on other sites

Hi there, I've tried to install this module on my Prestashop 1.6.1.11 but the process doesn't work.

I've tried to install via admin and via FTP, but the system warns me with an error in "gshoppingflux.php".

There is an unexpected [ into this file.

 

Any solution around?

 

EDIT: I've tried some previous versions, but same issues 😕

 

Thanks

Edited by Fulvio Barbella (see edit history)

Share this post


Link to post
Share on other sites

 

@xarhs  - No, the module will not export both Short_description and descriotion for the products. you have to select one of them

 

@clubvapea - Would like to know the Module version

@Meryle - It is not something i plan to work with, if you or other want to do the work it will tested and an accepted if the PR is ok.

 

@overbags - No it is not planned to change the texts Upper/lower case before export.

@GregKelcible - To get shipping for each item, you would need to use the module version 1.7.X - A new will be released soon, that is a bit faster than the current version.

@Fulvio Barbella - It would require some more details, like PHP version your store is running at.

Share this post


Link to post
Share on other sites

I have been working on fixing the shipping cost calculation for each product. Now it is also checked if a given carrier is not available for the product!

A new version will be released when it have been tested. Here is some stats for the export time:

271 products exported: 136 products with attributes, 355 attributes combinations.
Total: 626 exported products.

Before: 110-120 secs for export to complete
Now: 25-29 secs for export to complete

https://github.com/dim00z/gshoppingflux/commit/e66d1e2d2d903fd2381b492263a96b7b1e856fca

Share this post


Link to post
Share on other sites

Hi Casper,

I downloaded 1.7.2 from latest release. Installation was smooth, and it generated the XML well. 

I am facing few issues

1) Category Section is blank and need guidance to map categories with google categories.

2) The XML generated has around 347 products/combinations while we have 900 products + their combinations extra

3) The Xml has <g:google_product_category>Google Category Example > Google Sub-Category Example</g:google_product_category> instead of the categories.

Can you let me know what I need to set it right

Thanks

Amit

www.swasthyashailee.com

Screenshot(54).png

Screenshot(55).png

Share this post


Link to post
Share on other sites
32 minutes ago, traktap said:

Hi Casper,

I downloaded 1.7.2 from latest release. Installation was smooth, and it generated the XML well. 

I am facing few issues

1) Category Section is blank and need guidance to map categories with google categories.

2) The XML generated has around 347 products/combinations while we have 900 products + their combinations extra

3) The Xml has <g:google_product_category>Google Category Example > Google Sub-Category Example</g:google_product_category> instead of the categories.

Can you let me know what I need to set it right

Thanks

Amit

www.swasthyashailee.com 

Screenshot(54).png

Screenshot(55).png

 

I am using Prestashop 1.6.1.19 version.

 

Share this post


Link to post
Share on other sites

@traktap what php version are your Site Running?

could you try the following:

- reset the module

- uninstall the module and install it again

- add a new category to your store, and check if they listed

If possible, turn on debug mode as be doing the above, it might give us the reason for why this happens

Edited by Casper_O (see edit history)

Share this post


Link to post
Share on other sites
5 hours ago, Casper_O said:

@traktap what php version are your Site Running?

could you try the following:

- reset the module

- uninstall the module and install it again

- add a new category to your store, and check if they listed

If possible, turn on debug mode as be doing the above, it might give us the reason for why this happens

Running on PHP 7.0 (ea-php70)

Screenshot_2019-02-22 Modules • Swasthya Shailee(1).png

Screenshot_2019-02-22 Modules • Swasthya Shailee.png

Share this post


Link to post
Share on other sites

thanks for the pictures, it do sadly not help me much. PHP 7 should be fine.

The Notice about 2771 have been fixed in the most recent gshoppingflux.php on github, but it should not cause this kind of issues and is not related to the categories.

It do not show any kind of warning with debug mode active, if you uninstall the module and install it again? Or when you are adding a new category?

Share this post


Link to post
Share on other sites
On 2/20/2019 at 6:52 AM, Casper_O said:

@Meryle - It is not something i plan to work with, if you or other want to do the work it will tested and an accepted if the PR is ok.

For the moment, I edited the gshoppingflux.php to have my custom labels.

Did you know that your xml file is compatible for Facebook catalogs too? it's very useful.

Share this post


Link to post
Share on other sites

@Metfab yes I know that the xml is compatible with Facebook catalogs, I mention it in github, might have forgot it here.

It also works for Pricerunner, shopalike and  others that will accept the same file format.

Share this post


Link to post
Share on other sites

 

4 hours ago, Casper_O said:

@traktap I was reading issues on github, when I found this:

https://github.com/dim00z/gshoppingflux/issues/50#issuecomment-426673971

Could you check that your Root and/or Start Category is not for some reason not active?

@Casper_O

Yes,  this was the issue. It was not showing the Category List because the Home ( root ) was not visible.

1) Category Section is blank and need guidance to map categories with google categories.  RESOLVED

2) The XML generated has around 347 products/combinations while we have 900 products + their combinations extra  will Check and Reply

3) The Xml has <g:google_product_category>Google Category Example > Google Sub-Category Example</g:google_product_category> instead of the categories.  RESOLVED

 

Your help and guidance is highly appreciated.

 

 

 

Share this post


Link to post
Share on other sites
On 2/23/2019 at 3:04 AM, traktap said:

2) The XML generated has around 347 products/combinations while we have 900 products + their combinations extra  will Check and Reply

Do you have any updates related to this ?

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, Casper_O said:

Do you have any updates related to this ?

XML Results

1 products exported: 321 products with attributes, 471 attributes combinations.
Total: 472 exported products.

Actually

1830 Total

1520 Attributes combinations which are Active  ( with and without Stock)

1329 Attributes Combinations Active with Stock

-------

I am still not understanding why only 471 are generated.   and Trying to figure out the what combinations are hurting the disappearance of the Attributes combinations

Share this post


Link to post
Share on other sites

@traktap Thanks to the extra details in PM, I have found that the issue might be related to the advanced stock management.

Sadly it will take some time to figure that out and what needs to be fixed for it to work.

Share this post


Link to post
Share on other sites
On 2/27/2019 at 9:27 AM, Casper_O said:

@traktap Thanks to the extra details in PM, I have found that the issue might be related to the advanced stock management.

Sadly it will take some time to figure that out and what needs to be fixed for it to work.

 

Hello its form is excellent and is the only one I've used for years. but now I have updated to the latest versions of the module, it installs correctly and I frea the feed, but when I send it to Shopping it gives me an important missing attribute: The attribute does not contain an ISO 3166 country code: country I entered the lva oce IT in shipping country (we ship only in Italy), but the problem persists. how could I solve? thank you

Share this post


Link to post
Share on other sites
Posted (edited)

[SOLVED]

HI,

I installed (on Prestashop 1.7.3.2) the module but when I try to configure it I receive this error

[PrestaShop] Fatal error in module file: /public_html/modules/gshoppingflux/gshoppingflux.php:1836

Maximum execution time of 30 seconds exceeded

Thanks

Edited by kaferklaus (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Hello, I am trying to run the module.

I tried with v1.7.2 , v1.6.7, v1.6.2b, v1.7.0 and

I tried with php version 7.0, 7.1,7.2,7.3 and 5.4

prestashop version 1.7.3.2

always shows white page when I "save and export"

I have a bd with +9000 products

I want to export only 3 category

when click on Generated files links, shows

Error de lectura XML: no se encuentra el elemento raíz
Ubicación: https://www.wiwi-pc.es/googleshopping-s1-es-EUR.xml
Número de línea 17, columna 1:

but this file exits in my / directory

 

Colud you help me please?

Thank you very much

 

Edited by Javi77 (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

I could not get a cronjob going. When I enabled the logging the following error displays

PHP Notice:  Undefined index: REQUEST_METHOD in /xxx/public_html/classes/controller/FrontController.php on line 763

Can somebody explain or resolve. It little research on other forums indicates that the error is generated due to the fact that a front-end class is requested and is not necessary for a cron job. But I'm not a developer.

Edited by bourat (see edit history)

Share this post


Link to post
Share on other sites

Hi

I start using this module and it looks very handy and easy to use. Thank you!

After import the feed to Merchant Center, it's showing error related with shipping… in my store shipping is free, how can I overcome this issue? I read documentations on google merchant but I can't understand how it works…

Thank you

Share this post


Link to post
Share on other sites

Hi!
 

having trouble with shoppingflux and multistore.

I have 2 stores in my prestashop 1.6.1.20 and the xml generated from the second store is the same of the store1. 

is it possible to create a second xml? 

 

Share this post


Link to post
Share on other sites

Hello!

The module is working fine on our instalation of 1.6.1.10.

Thank you @Casper_O, @dimooz and @jmartin82 and the rest of the members.

I want to duplicate this module, because I need a different product feed (one with all the combinations, and another without).

I think the only possible way is to duplicate the module, right?

If so, how can I do it without messing up the one existing?

 

 

Thank you!

Bruno