Jump to content
sarantias

No Green Padlock in Prestashop 1.4.9

Recommended Posts

These errors need to be fixed to get the green padlock in my Prestashop 1.4.9 Front office. Backoffice has green padlock. Please make me an offer.

Kind regards

Robert

 

Mixed Content -  Errors

Hard Failure
A file with an insecure url of "http://fonts.googleapis.com/css?family=Open+Sans|Noto+Sans" was loaded on line: 4 of https://www.hemi-sync.de/.
This URL will need to be updated to use a secure URL for your padlock to return.

Soft Failure
A file with an insecure url of "http://www.assoc-amazon.de/e/ir?t=hemisync-21&l=as2&o=3&a=3869916923" was loaded on line: 18 of https://www.hemi-sync.de/.
This URL will need to be updated to use a secure URL for your padlock to return.


Form Failure
A form with the action of "http://www.hemi-sync.de/suche" exists in the source code of the tested page. This form needs to be updated to use "https://www.hemi-sync.de/suche" or another secure URL for your padlock to return.

Share this post


Link to post
Share on other sites

Shouldnt you consider to upgrade your shop? You are using shopsoftware of 2012. The software is outdated.

Maybe it works, but you can wait till problems occur. On mobile and tablet the shop is unreadable(everything very small)

According to the SSL issues, they are easy to fix but there are more errors. When browsing your shop i get multiple: For example:

 

errors.png

Share this post


Link to post
Share on other sites

Hi 

I saw on your index alone over 103 different parts which are linked from not secure location :

Mainly your menu which has a lot of links having http instead of https. 

Your menu holds a "display none"  for your category description - a huge PS bug. The point is that the category descriptions have at least a single link using http. You tried for SEO the interlinking technic, but you left the links without https. 

Your logo image is coming from http. 
Your fonts are coming  from non-secure locations (edit your header tpl)

And that all only for the index. 
 

I need to agree, that upgrading your store to at least 1.6 would cost you less, than manually going ower each page. 
As I see your store the 1click Upgrade would work till 1.6.x .

I hope it helped.

Kind Regards 

Leo

 

Share this post


Link to post
Share on other sites
On 1/23/2018 at 5:34 AM, sarantias said:

Please make me an offer

Probably several hours worth of work to go through all of the pages on your website, locate any insecure URL, and then locate the code in your store that is needed to change.  You are probably in the hundreds of dollars, and you will still be using old and unsupported software

As already stated... you would do better investing that money into the upgrade of your store. 

However if you really just want to fix these errors, then you can save some money by doing the legwork yourself.  Start by going through all of the pages in your website, and document all of the insecure links that need to be changed.  It is likely fonts, images, css and javascript files, insecure forms like the search bar.  however it may also be remote files (like the google fonts for example), you first need to determine if those remote files can even be served over https (don't assume they can be)

once you have that list, post it and perhaps someone will provide a reasonable quote.  However I would anticipate you paying someone for a days worth of work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×