Jump to content
  • 0
pavol

Delete install folder from localhost

Question

Hi everybody,

I am trying to install prestshop for the first time on my local machine and experiencing issues with changing permissions/deleting install folder after installation completed.

I am using XAMPP as a localhost.

Everything went smooth to the point till I had to delete the install folder, however I can't change the permission as it's always comes with an error that I don't have the permission to change the permission.  I am able to change the permission on all other files which are not within my prestshop.

Any help would be appreciated.

 

Thanks

 

Screen Shot 2018-01-11 at 12.24.58.png

Screen Shot 2018-01-11 at 12.26.20.png

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I assume you are using MAMP?  If so, try to stop the MAMP services and then delete the install folder.  If that does not work, then perhaps you should visit MAMP or MAC forums, as this issue is unrelated to Prestashop, and more related to the use of MAMP on your MAC

Share this post


Link to post
Share on other sites
  • 0

Hi, I am using XAMPP

 if I stop XAMPP I cannot access the files anymore as the folders within the XAMPP are mounted only when the XAMPP is running.

Thanks, I will try to research it a bit more.

 

 

Share this post


Link to post
Share on other sites
  • 0

I do not know if this will help, but I also use MAC and XAMPP.

My solution was to give full permissions to the folder prior to "Install", I mean the folder that contains it in my case my "PrestaShop" folder. 

I right-click this folder, click on "Get information", then in permissions I have added all possible users "admin", "_mysql", "user (me)", "everyone".

Then I have unlocked the small yellow padlock, and click on the small gear wheel, and click "Apply to the included items..." This is going to apply the changes to all the folders inside your PrestaShop folder. Then you have to be able to delete it.

Hope this work for you. 

Also, I'm having a problem to access to my admin page that can´t resolve :( hope someone here could help.

Regards!

PS. Tell me if you misunderstand something.

Share this post


Link to post
Share on other sites
  • 0

Hi All, thanks for your support. 

I have managed to delete the folder after using the MAMP instead of XAMP-VM so it's all working locally now and on live server too.

With XAMP I have tried delete, rename the install folder or re-install the whole shop and tried again but none of those worked, no sure.

Thanks for help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×