Jump to content
Tibo05

Bug Frais de Livraison Etape "Paiement"

Recommended Posts

Bonjour à tous,

Voilà, je vous soumets aujourd'hui un problème détecté hier par une de nos cliente lors d'une commande.

Nous avons paramétrés 4 transporteurs différents:

- 1 retrait dans nos locaux, gratuit, paramétré à la main.

- 1 colissimo, avec tranches selon le poids, paramétré à la main sans utiliser le module so colissimo

- 1 mondial relay, avec tranches selon le poids, paramétré à la main en utilisant le module dédié

- 1 colissimo international,avec tranches selon le poids, paramétré à la main sans utiliser le module so colissimo

Nous utilisons un unique mode de paiement qui est le module PayPal basique.

Nous avons deux règles panier pour la gratuité des frais de livraison, déclenchement à partir de 70€ de commande pour les transporteur colissimo et mondial relay et à partir de 100€ pour le transporteur colissimo international.

Nous utilisons la dernière version de prestashop pour la branche 1.6.

Le problème est, lorsque l'on arrive sur le choix du mode de livraison, les 4 modes de livraison sont bien présents avec les bons tarifs affichés (les règles paniers sont bien appliquées selon les conditions définies). Cependant, lors du passage à la 5ième étape, le paiement, le tableau récapitulatif ne tient pas compte du choix effectué à l'étape précédente, ni de l'application des règles panier: c'est le transporteur par défaut qui est automatiquement appliqué lors du paiement.

Par exemple, j'ai un produit à 20€ dans mon panier, avec le transporteur Colissimo définit par défaut dans le BO. Dans l'étape livraison, il est coché par défaut avec 4.10€ de frais de livraison. Je coche mon mode de livraison Gratuit, retrait dans les locaux, à l'étape suivante c'est Colissimo à 4.10€ qui est pris pour l'étape de paiement.

Je change le transporteur par défaut dans le BO et met le retrait gratuit dans nos locaux comme mode de livraison par défaut. Je refais la commande, j'arrive sur la sélection du mode de livraison, le retrait gratuit est sélectionné par défaut, je change pour colissimo 4.10€. A l'étape suivant du paiement, c'est le transporteur par défaut, gratuit dans nos locaux, qui est appliqué pour le paiement.

 

Avez-vous déjà rencontré ce problème? Un souci de paramétrage? Un problème de cache? Un bug connu?

 

Merci à tous pour vos réponses.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More