Jump to content

Recommended Posts

Citation

Type d’install : nouvelle
Version de PS : 1.7.2.4
URL du site concerné : boutique.capron.pro
Thème : défaut
Code : original
Hébergement : dédié
Version de PHP : 5.6.30+deb8u1
Version de MySQL : 5.5.58-0+deb8u1

 

Bonjour tout le monde et merci d'avance pour votre lecture puis votre aide.

Je rencontre un problème sous PS1.7 : lorsque je crée un produit avec déclinaisons sur une boutique, je ne vois pas les déclinaisons dans la fiche-produit des autres boutiques. Lorsque j'ajoute une nouvelle déclinaison après coup (nouvelle couleur, par exemple), elle ne s'affiche que dans le contexte de la boutique créée mais pas les autres. Pourtant, je les vois dans les stocks...

Avez-vous rencontré ce problème ?

Merci d'avance pour votre aide,

Julien

Edited by AndromedaSaint (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

je m'incruste dans ce post car problème similaire

nouvelle instal en multiboutique Prestashop 1.7.2.4

et je rencontre un probleme maintenant avec les declinaisons...

mon précédent problème était sur le bloc texte qui changé pour tous les groupes de boutiques et non pour chaque boutique...qui est résolu en forcant la MAJ du module Bloc texte en V3.0.0 car erreur dans les codes où il manquait les id-shop je sais plus trop..bon résolu mais perdu beaucoup de temps

et maintenant c'est au tour des déclinaisons !

je peux bien creer des caractéristiques pour chaques boutiques en sélectionnant donc la boutique correspondante 

mais quand je veux creer des attributs avec valeur propre à une boutique ca ne fonctionne pas.

Enfait si je créé l'attribut+valeur pour la boutique principale, cela fonctionne le cadre apparaît dans la fiche produit de la boutique mais aussi dans les produits des autres boutiques alors quelles ne sont pas cochés et pas visible en back office quand je suis sur une autre boutique...

je créé des attributs+valeur pour la boutique concerné mais le cadre n’apparaît pas ! donc impossible de creer un produit avec les déclinaisons propres à la boutique...

j'ai tout supprimé car je pensais qu'il y avait un conflit mais non rien y fait je ne sais pas comment faire...je me dit qu'une fois ce soucis reglé quelle sera le prochain...

j'ai perdu déjà beaucoup de temps et ne sais pas pour ce probleme

peut être que cela vient d'un probleme de configuration à la base car j'avais lors de l'install chargé les informations exemples donc j'ai l'impression qu'il y a conflit avec les ID...

mais bon repartir à zero pas top mais je sens que je ne vais pas avoir le choix car je risque de rencontrer d'autres conflits vu comment ça démarre...

si vous avez des idées ?

j'ai lu 

https://www.prestashop.com/forums/topic/514681-déclinaisons-ne-fonctionnent-plus-dans-ma-multi-boutique-ps-1614/

https://www.prestashop.com/forums/topic/630083-activation-de-la-fonctionnalité-attributs-et-valeurs/

PS_COMBINATION_FEATURE_ACTIVE mais chez moi il est bien à 1 par contre j'en ai qu'un dans la BDD

--

Merci d'avance pour votre aide ; je eux creer un new post si besoin mais je pense que ca rejoint le probleme AndromedaSaint

--

Image en PJ

Groupe 1 - Boutique principale M

Groupe 2 - Deuxieme Boutique E

--

01.thumb.jpg.24111b0c5d8e0c08a8d3ac6a01eabf2d.jpg

02.thumb.jpg.b16d9d164fec2f532ccd436048c8a5d1.jpg

03.thumb.jpg.5102248c2db77f748159bcdf45c9d317.jpg

04.thumb.jpg.d5f059246d85f35a5812ae64080d6aac.jpg

05.thumb.jpg.bff0abed44018116cc1127006ccee55b.jpg

06.thumb.jpg.514f124695867ee2de126f8b0331b909.jpg




 

Edited by Thanksall
Modifier l'ordre des images (see edit history)

Share this post


Link to post
Share on other sites

je viens de faire une nouvelle installation
utilisé le cleaner officiel prestashop
créé les catégories racine pour ensuite créer les boutiques
cette fois ci j'ai créé les boutiques dans le même groupe
sans importer les données


j'ai créé des caractéristiques et attributs dans chaque boutiques et c'est toujours le même problème
Ça fonctionne pour caractéristiques chaque boutique a les siennes et c'est fonctionnel lors de la création produits ; 
par contre les attributs
Chaque boutique à bien ses propres attributs, c'est à dire je ne visualise pas ceux de la boutique principale lors d’ajout/modifier
mais bien ceux créés sur la boutique sélectionné mais lors de la création produit le cadre n'apparait pas et affiche les attributs de la boutique principale...

j'ai supprimé les boutiques et créé une nouvelle en important les données sans sélectionnées attributs et caractéristiques
il n'a pas importé les caractéristiques de la boutique principale mais par contre l'a fait pour les attributs alors que ce n'était pas coché...

Ca semble venir plutôt d’un bug similaire au module bloc text dans le code non ?? 


Fix Bloc Text Multiboutique
http://forge.prestashop.com/browse/BOOM-2033

Ou de config ?

je ne suis pas assez callé dans le domaine

il faut ouvrir un sujet sur ce site ducoup ?
--

AndromedaSaint as tu solutionner ton probleme ?

 

merci pour vos retours

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More