Jump to content
sebchapo

"Jeton (token) invalide"

Recommended Posts

Bonjour, 

 

Je débute sur Prestashop et je dois vous avouer que pour l'instant cela m'est bien compliqué. J'ai notamment en ce moment un important problème. Lors de la navigation en backoffice, il est affiché de plus en plus fréquemment "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité.". Je dois alors repartir à la page d'accueil, si bien qu'il ne m'est pas possible d'effectuer des modifications. Cela m'arrive presque systématiquement désormais. J'ai essayé diverses solutions pour tenter de résoudre cela, sans aucun succès. Sauriez vous que faire ?? 

Merci !

 

Le site : husvard

Edited by sebchapo (see edit history)

Share this post


Link to post
Share on other sites

Si le token est invalide, c'est qu'un module modifie cette variable "token" en javascript, soit parce que le nom est le même (ça n'a pas été contrôlé) soit à cause d'un bug.

Share this post


Link to post
Share on other sites

J'ai désinstallé tous les modules potentiellement douteux, et le problème est finalement toujours présent. Qu'entends tu par "soit parce que le nom est le même"  ? Le problème arrive sur de nombreuses pages : en modifiant des produits, etc.  

Edited by sebchapo (see edit history)

Share this post


Link to post
Share on other sites

J'ai supprimé les modules Smartblog et celui pour Upgrade. Il me reste Google Analytics, Paypal comme modules qui n'étaient pas présents de base. 

Share this post


Link to post
Share on other sites

Celui d'upgrade ne fait rien tant qu'on est pas dans la page de sa configuration.

Par contre les anciennes version du smartblog avaient ce souci...

Share this post


Link to post
Share on other sites

Bonjour,

Je suis dans le même cas, avec ce message qui s'affiche continuellement. Je suis en Prestashop 1.7.2.4 chez OVH avec le thème ZOne.

Et je n'ai pas installé Smartblog...

Je pense que cela vient de la version 1.7 car avant je n'avais pas ce problème.

Et je n'ai pas changé d'hébergeur...

Le fichier settings.inc.php contient seulement ceci : <?php //@deprecated 1.7. Est-ce normal ?

J'essaie de trouver des pistes pour trouver une solution.

Je voulais revenir à la version 1.6 mais je ne sais pas comment faire. Avez-vous une piste pour réinstaller cette version ?

Merci, par avance, pour votre aide.

Patrick

Share this post


Link to post
Share on other sites

Vider le répertoire contenant votre 1.7 (ou le renommer), télécharger le zip de la dernière 1.6 (en haut à droite de ce forum), le dézipper sur votre ftp et procéder à une install classique

  • Like 1

Share this post


Link to post
Share on other sites

Merci pour votre réponse, Eolia.

Il s'agit bien du répertoire www lorsque Prestashop est installé à la racine ?

L'install classique se fait comment (désolé je suis débutant) ? En tapant l'url dans le navigateur ?

Share this post


Link to post
Share on other sites

Oui.

renommez votre www en www_old par exemple.

Re-créez un www et dézippez la 1.6 à l'intérieur.

Créez une bdd vide et appellez l'url de votre site

Share this post


Link to post
Share on other sites

Merci Eolia.

Je vais faire comme ça.

Pour la Bdd, je vais la vider (en faisant une sauvegarde avant) car je ne peux créer qu'une seule Bdd.

Je ferai un retour pour tous ceux qui connaissent le même problème (token invalide).

Car je crois que la solution est de revenir à la 1.6.

Bonne journée.

Et tous mes voeux pour 2018...

Share this post


Link to post
Share on other sites

Par contre, comment faire pour que je ne sois pas obligé de remettre mes produits un par un ?

Est-ce que je peux remettre les répertoires images, thème, ... de mon ancienne installation pour ne pas avoir tout à refaire ?

Share this post


Link to post
Share on other sites

Là c'est un peu plus compliqué car les tables ne sont pas exactement pareilles concernant les produits, donc si vous ne vous y connaissez pas trop en requêtes SQL je vous conseille de remettre vos produits à la mano...

  • Like 1

Share this post


Link to post
Share on other sites

Merci pour votre aide, Eolia.

J'ai essayé de réinstallé la version 1.6 et j'abandonne. Plusieurs erreurs dans l'installation...

Je reviens à ma version 1.7.

Je vais attendre que le bug soit corrigé. Il y a une version 1.7.3.0 en Béta. Je vais attendre un peu...

 

Share this post


Link to post
Share on other sites

Pour moi, la désinstallation de SmartBlog n'a pas complètement supprimé le problème, il l'a juste réduit fortement. Je conseille de toujours sauvegarder son travail (Ctrl + C par exemple) avant de passer à la page suivante. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More