Jump to content

Plus d'accès au back office après modification d'un hook


Recommended Posts

Bonjour à tous, 

Après avoir changé le hook du module "shoppingcart" de mon thème de "display cart" à "adminheader" je n'ai plus d'accès à mon back office pourtant le site fonctionne.

Quelqu'un a-t-il une idée de comment résoudre ce problème? 

Merci d'avance pour votre aide,

 

Share this post


Link to post
Share on other sites
il y a 27 minutes, ndiaga a dit :

Bonjour,

 

Il faut remettre le hook a sa place.

Faites le via FTP en commentant la fonction qui s'en charge.

Bonjour,

Merci beaucoup pour votre aide, malheureusement je suis débutante sur Prestashop, j'ai essayé de modifier le hook via le ftp mais je ne sais pas comment faire, pourriez-vous me dire la marche à suivre ? 

Merci ! 

Share this post


Link to post
Share on other sites
il y a 6 minutes, ndiaga a dit :

Ok, quelle erreur s'affiche sur votre browser?

voici le message d'erreur: The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error. More information about this error may be available in the server error log.

Merci beaucoup !

Capture d’écran 2017-12-23 à 08.44.31.png

Share this post


Link to post
Share on other sites

Bonjour, 

J'ai renommé le fichier .htaccess du dossier backoffice en old et ajouté la mention (null) dans le fichier php du module et je peux de nouveau accéder à mon backoffice. 

En revanche le panier à disparu, est-il possible de réinitialiser le module depuis le FTP ? 

Merci par avance,

Cordialement, 

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Merci pour vos réponses. 

J'ai finalement pu accéder de nouveau au back office en désactivant le .htaccess du backoffice dans le ftp. 

Mais malheureusement cela n'a duré qu'un temps car désormais c'est l'ensemble site et back office qui est inaccessible, j'ai le message suivant:  Fatal error: Class 'DbPDO' not found in /var/www/vhosts/eywacorazon.com/httpdocs/classes/db/Db.php on line 230

Savez-vous ce que cela veut dire ? 

Merci d'avance !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More